LINUX.ORG.RU

Несмотря на финансовые трудности проекта, вышел gnash 0.8.8

 ,


0

0

Несмотря на финансовые трудности проекта, разработчики смогли выпустить новую версию gnash. Проект gnash помечен FSF как High Priority Free Software Projects, но от FSF не было получено никакой финансовой поддержки. Если вы желаете помочь проекту материально, то это можно сделать через некоммерческий фонд Open Media Now.

Основные изменения:

  • Добавлена поддержка декодирования видео через VAAPI
  • Добавлена полная поддержка Youtube.com
  • Возможность для браузеров работать с ActionScript через Javascript
  • Реализована поддержка переключения между FFmpeg и GStreamer для работы с аудио и видео
  • Улучшена работа с устройствами ввода при использовании фреймбуфера
  • Реализована поддержка переключения между Cairo, OpenGL и AGG для рендеринга

>>> Подробности

★★★★★

Проверено: maxcom ()

самое главное в новости не сказано - тытубы и вимеи нормально показывает?

k0l0b0k ★★ ()

> Несмотря на финансовые трудности проекта

High Priority Free Software Projects

FSF

а где посмотреть, куда они вкладывают (если вкладывают)?

anonymous ()

>Добавлена полная поддержка Youtube.com

да ладно вам! o_O

nevar ★★ ()

а как это к реконку прикрутить?

Thero ★★★★★ ()

значит ли это, что новость насчет lightspark считать недействительной?

maxt ()

теперь можно 1080p смотреть? или еще нет?

anonymous ()
Ответ на: комментарий от dimqua

> На опеннете гордо сказано «на 100%» :)

про 100% это из анонса на gnashdev

maxcom ★★★★★ ()

гнаш ненужен

anonymous ()

Интересно. А скриншоты Youtube.com с этим gnash есть?

Lucky1 ★★★ ()

swfdec, lightspark, gnush, какая-то херь на яве... а флеш в linux как тормозил так и тормозит...

muhas ★★★ ()

Это они плагина на жабе испугались :)

rudchenkos ()

ура! теперь флэш тормозить не будет! как я долго этого ждал! на моем динозавре только гнаш и может работать. хотя в эпоху хтмл 5 флэш не нужен как таковой

lambrianov ()

почему при установке из репов getgnash gnash зависит от nvidia-блоба??? свобода,такая свобода.

uju ★★ ()
Ответ на: комментарий от devnullopers

этот велосипед вышел совсем недавно и уже работает получше своего старшего брата под линаксом. просто у индусов из адобы нет желания линукс версию пилить

lambrianov ()

Закопайте это гавно вместе с теми кто его тщетно пилит. Не позорились бы.

anonymous ()
Ответ на: комментарий от lambrianov

>этот велосипед вышел совсем недавно и уже работает получше своего старшего брата под линаксом. просто у индусов из адобы нет желания линукс версию пилить

Гнэшу сто лет, и он как был неюзабелен, так и остался.

anonymous ()
Ответ на: комментарий от devnullopers

> кривые либы в браузере не нужны

+1 Закопайте уже наконец Adobe Flash допиленным gnash!

anonymous ()

Анонимусу не нужен. Закапывайте.

anonymous ()

> Добавлена полная поддержка Youtube.com

Враньё. Поставил - вообще ничего не показывает

tuupic ()

ничего не имею против сабжа,

однако флеш должен умереть

hyperion ()
Ответ на: комментарий от uju

почему при установке из репов getgnash gnash зависит от nvidia-блоба?

Пацанчик, читать научись

Добавлена поддержка декодирования видео через VAAPI

nutz ★★ ()

Ubuntu Lucid.

d1337r@d1337r-laptop:~$ sudo apt-get install gnash
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  gnash: Зависит: libmysqlclient15off (>= 5.0.27-1) но он не может быть установлен
E: Сломанные пакеты
d1337r@d1337r-laptop:~$ sudo apt-get install libmysqlclient15off
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Пакет libmysqlclient15off недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
E: Для пакета libmysqlclient15off не найдены кандидаты на установку

d1337r ()
Ответ на: комментарий от d1337r

я под мандриву тоже не смог. правда ставил тогда 0.86 версию. да, rpm

lambrianov ()
Ответ на: комментарий от hyperion

> однако флеш должен умереть

а что взамен? о_0

vovans ★★★★★ ()
Ответ на: комментарий от vovans

> однако флеш должен умереть

а что взамен? о_0

Лично, млин, общение!!! Как наши предки делали!

GluckMan ★★★ ()
Ответ на: комментарий от lambrianov

> html5 их всех закопает. и в придачу silverlight

казнить нелья помиловать

mkfifo ()
Ответ на: комментарий от lambrianov

Нет, вопрос в другом: чем связаны flash-плеер и MySQL?

d1337r ()
Ответ на: комментарий от d1337r

Нет, вопрос в другом: чем связаны flash-плеер и MySQL?

The goal of the Gnash developers is to be as compatible as possible with the proprietary player (including behavior on bad ActionScript code). However, Gnash offers some special features not available in the Adobe player, such as the possibility to extend the ActionScript classes via shared libraries: sample extensions include MySQL support, file system access and more. For security reasons the extension mechanism must be compiled-in explicitly and enabled via configuration files.

mironov_ivan ★★★★★ ()

Один раз только и использовал, надо было перегшнать swf в avi, так это чудо пишет несжатый avi хорошо ролик короткий.

anonymous ()

>Добавлена полная поддержка Youtube.com

А другие видеохостеры? Ждать для каждого сайта новой версии?

anonymous ()
Ответ на: комментарий от lambrianov

> html5 их всех закопает. и в придачу silverlight

скорее silverlight их всех закопает.

anonymous ()
Ответ на: комментарий от nutz

> Пацанчик, читать научись

>Добавлена поддержка декодирования видео через VAAPI

Между блобом от nvidia и VAAPI нет ничего общего.

// ваш К.О.

anonymous ()

Как всегда ничего не работает. Нахрен этот проект вообще нужен...

shahid ★★★★★ ()
Ответ на: комментарий от vovans

>а что взамен? о_0

То, для дублирования чего флеш и разрабатывался. Правда тогда, когда он появился, это было оправдано. А сейчас — не оправдано.

Ttt ☆☆☆☆☆ ()

>Несмотря на финансовые трудности проекта, разработчики смогли выпустить новую версию gnash. Проект gnash помечен FSF как High Priority Free Software Projects, но от FSF не было получено никакой финансовой поддержки.

Они ещё за это деньги получают? Вопрос в том, кто кривой: руки у разработчиков Gnash, или же сам флеш настолько кривой, что альтернативные реализации делать невозможно ЧМЧП.

Ttt ☆☆☆☆☆ ()
Ответ на: комментарий от muhas

Всё это говорит лишь о том, что адобовцы - индусы, и флеш - гумно.

dimqua ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.