LINUX.ORG.RU

Вышла первая версия патчсета pf-kernel для Linux 3.1

 , , , , , ,


0

1

С небольшой задержкой, связанной с отсутствием необходимых патчей, вышла первая версия патчсета pf-kernel для свежего ядра Linux v3.1.

В этой версии:

  • стабилизационный патч Linux v3.1.1;
  • патчсет от Кона Коливаса (Con Kolivas) 3.1.0-ck2, включающий в себя свежайшую версию планировщика процессов BFSv415;
  • планировщик ввода-вывода BFQ v3-r1;
  • альтернативная подсистема гибернации TuxOnIce по состоянию на v3.1-rc8;
  • патч, уменьшающий энергопотребление системы до уровня Linux v2.6.37.

Также открыт канал на Twitter, в котором, по возможности, будут публиковаться новости, связанные с разработкой pf-kernel.

Напоминаю, что этот патч используется на свой страх и риск. TuxOnIce и патч для уменьшения энергопотребления лично мной не были протестированы. Жду отзывов.

Также напоминаю, что патч применяется к чистому ядру 3.1 без стабилизационных патчей.

Официальный сайт (доступен и в сети IPv6)

>>> Скачать патч

в мининовости бы надо.

Напоминаю, что этот патч используется на свой страх и риск. TuxOnIce и патч для уменьшения энергопотребления лично мной не были протестированы. Жду отзывов.

ну его.

ibraim ()

больше чем на мининовость не тянет

Deleted ()

уже сказали, что в арче из-за ауфс не собирается?

svetotat ()

теперь главный вопрос. а нафига оно мне? вроде core i у меня нет.так что все это энергопотреблядство меня не коснулось. ноут итак не шустрый.ускорять то и нечего. суспенд работал и раньше

skai-falkorr ()

собрал пакет linux-pf-3.1.1-1-x86_64.pkg.tar.xz из AUR Но вот не могу установить, вывод такой:

 
yaourt-tmp-root]# pacman -U /tmp/yaourt-tmp-root/linux-pf-3.1.1-1-x86_64.pkg.tar.xz

:: nvidia-pf: требует linux-pf<3.1

В свою очередь переустанавливал nvidia-pf , толку мало.

ЧЯДНТ?

zibert ★★★ ()

Из AUR'а не собирается даже без aufs.

  LD [M]  fs/xfs/xfs.o
  LD      fs/built-in.o
==> ОШИБКА: Произошел сбой в build().
    Преждевременный выход...

Axon ★★★★★ ()

Очевидно, что все эти патчи довольно бестолковые. В мейнстрим их потому и не принимают, как мне кажется. Вот сейчас у меня 3.1.0-7.fc16.x86_64, проц даже холоднее, чем был в Убунту с 2.6.32 ядром. Тормозов не вижу...

Pakostnik ★★★ ()
Ответ на: комментарий от pekmop1024

Та не, я не дурак, чтоб заявлять ерунду. У меня и сейчас вот параллельно стоит другой линукс, там 3.0 было, щас 3.1. И Федорку старую 15-ю снёс неделю как только... Вобщем, или починили, или я тогда не знаю. Но датчик врать не будет. А в квартире у меня щас жарко, отопление работает отлично.

Pakostnik ★★★ ()

ну одна польза уже проявилась. раньше влц бывало сжирал все и вся, завешивая намертво систему. сейчас в аналогичной ситуации - были жееесткие фризы, но не смертельные

skai-falkorr ()
Ответ на: комментарий от Pakostnik

в мейнстрим патчи не принимают, потому что у авторов нет времени переписывать их в соотвествии с принятой архитектурой ядра (то есть переписать так, как принято). и делать это тоже некому

skai-falkorr ()
Ответ на: комментарий от skai-falkorr

раньше влц бывало сжирал все и вся, завешивая намертво систему.

Я не замечал. У меня VLC работал отлично. Но сейчас уже totem стал вполне вменяем, ну и для особо упоротых ситуаций держу Гном-мплеер (тоже стал удивительно качественным) - ушел от ВЛЦ.

Pakostnik ★★★ ()
Ответ на: комментарий от nu11

Почитай рассылку tuxonice-devel, там есть отзывы о неработающей ванильке в плане благодарности за работающий tuxonice. У меня ванильная тоже когда-то не работала, сидел на tuxonice, а сейчас уже нет.

post-factum ★★★★★ ()
Ответ на: комментарий от joy4eg

Пни мейнтейнера арчевского пакета, я туда aufs не совал, это его идея.

post-factum ★★★★★ ()
Ответ на: комментарий от post-factum

>У меня ванильная тоже когда-то не работала

так в чем причина то? Что может его сломать, это же не s2ram?

nu11 ★★★★★ ()
Ответ на: комментарий от anonymous

>UnixBench уверяет что pf работает быстрее Пруф!

я говорил конкретно про скорость саспенда сравнительно с tuxonice, а не про разные сферические тесты.

nu11 ★★★★★ ()
Ответ на: комментарий от nu11

Если бы я знал тогда ответ на этот вопрос, pf-kernel никогда бы не появился.

Упреждая последующие утверждения в стиле «не нужно» — кому не нужно, пускай держит это при себе. Патчсет нашёл своих пользователей.

post-factum ★★★★★ ()
Ответ на: комментарий от post-factum

я просто использую ck ядра, и оно без драйверов для ck ядра не работают, а для вашего ядра я что-то не нашел 173драйверов

z00ke ()
Ответ на: комментарий от post-factum

ага. меня например спасает от 12309. если бы не лень - собрал бы ппа для убунты. наверное как выйдет окончательная версия (без патчей в рц состоянии) - соберу. но пока накропал только инструкцию для убунтят http://skai-falkorr.blogspot.com/2011/11/howto-31-pf-kernel.html

skai-falkorr ()

Пользовался linux-pf. Но всё-таки остановился на linux-ck - TuxOnIce и прочее мне ни к чему. Тем не менее автору удачи желаю я)

hired777 ()

Проблемы сборки 3.1.1-pf через PKGBUILD для Арча вызваны тем, что поверху накатываются патчи aufs. Правьте PKGBUILD перед сборкой ручками, чтобы отрубить aufs.

post-factum ★★★★★ ()

А в zen-kernel есть патч, уменьшающий энергопотребление?

vitruss ★★★★ ()

если K900 на неделе не осилит 3.1 — обещаю попробовать запилить в агилию :)

DoctorSinus ★★★★★ ()
Ответ на: комментарий от zibert

Поправь pkgbuild, убери проверку на linux-pf<3.1. Я так сделал, работает.

cipher ★★★★★ ()
Ответ на: комментарий от DoctorSinus

Да, Агилия. И мне не стыдно, хороший линукс. Только малознакомый народу - че, всем расскажешь?

Ну и ты знаешь про гном...

Pakostnik ★★★ ()

А где дрова на nvidia для этого ядра? Те, что есть, не подходят, там для linux-pf<3.1. Убирать проверку пробовал, все равно не собирается, говорит:

Unable to determine the target kernel version

Motif ()
Ответ на: комментарий от Pakostnik

kaberc-а спроси, где... Я в любой момент помогу - так желающих нету (

DoctorSinus ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.