LINUX.ORG.RU

Ответ на: Re: NVIDIA 1.0-8756 от mr

Re: NVIDIA 1.0-8756

т.е. теперь драйвера от nvidia будут нормально работать с suspend и suspend2 патчами ? правда похоже мой GF2 этого всё равно уже не сможет сделать :(

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от mr

Re: NVIDIA 1.0-8756

Усохни моя душенька! Оно работает! Допинали таки наконец!

У меня карточка geforce4, ядро 2.6.16-rc1-mm1, раньше ни с какими патчами не работало: засыпало, но не просыпалось. Теперь заработало, по крайней мере с первого раза сработало, теперь будем на стабильность его тестировать :-)

Кстати, ложка дёгтя: вылезла картинка за границы экрана, видно, что-то они там перекрутили в очередной раз. Прийдётся xvidtune опять ковырять :-)

mr ★★ ()

Re: NVIDIA 1.0-8756

>The NVIDIA driver does not yet support the GLX_EXT_texture_from_pixmap extension. This extension is used by OpenGL-based composite managers, such as Novell's Compiz, to use X pixmaps as OpenGL textures. Support for the GLX_EXT_texture_from_pixmap extension will be provided in a future NVIDIA driver release.

:(

mojoholder ★☆ ()
Ответ на: Re: NVIDIA 1.0-8756 от mr

Re: NVIDIA 1.0-8756

Народ! Держите меня за руки, я начинаю кипеть! Они там что-то с режимами накрутили, какой-то nvidia-auto-select для выбора видеорежима. Для того, чтобы иметь свой режим, прийдётся править свои конфиги. Пока ещё не понял, что именно...

mr ★★ ()

Re: NVIDIA 1.0-8756

Меня удивляет, что автор не заметил главного в этом релизе - поддержки X Composite Extension и GL одновременно. Помнится, эта тема подымалась NVidia'вцами как проблема в freedesktop'овском списке рассылке.

Также стоило б отметить что давно обещанной поддержки texture_to_pixmap по прежнему пока еще нет.

P.S. Хотя NVidia все равно очень хороший IHV. Пожалуй лучший. Спасибо им за внимание к нам линуксоидам.

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от mr

Re: NVIDIA 1.0-8756

Без паники. :) Надо просто поставить во все нужные Subsection "Display" такую опцию: Modes "имя_моделайна" (иначе драйвер даст выбор видеорежима этому самому nvidia-auto-select). Ничего страшного, хотя LOR faq здесь, конечно, не проходит.

mr ★★ ()

Re: NVIDIA 1.0-8756

"Enabled hardware acceleration of the Render X extension by default"

Про это тоже надо было написать. Для меня это более интересно, чем suspend-to-disk :)

Spectr ★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от mr

Re: NVIDIA 1.0-8756

Хотя нет, в lorfaq это, конечно, есть, только почему-то в разделе "games". :-)

В общем, протестировал я немного этот suspend, похоже всё работает безупречно, быстро и безглючно. Уффф. Можно отправляться спать. :-)

mr ★★ ()

Re: NVIDIA 1.0-8756

Эх. Где бы уже порт для 7174 на 2.6.16 найти... думал следующую видюху от nvidia покупать, пока не купил наткнулся на их заброшеные дрова для GF2. В общем следующую буду брать с видимо ATI.

eXOR ★★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от McGray

Re: NVIDIA 1.0-8756

Да нет, просто там бубнов много надо, все стены можно обвесить. Это раньше было, ща не в курсе =)

ManJak ★★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от los_nikos

Re: NVIDIA 1.0-8756

> А чем тот-же 8178 пропатченый не устраивает?

Там не поддерживаются многие "старые" карты. Эдакая стимуляция пользователей на покупку нового железа.

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от anonymous

Re: NVIDIA 1.0-8756

Как всё грустно с драйверами в линуксе.. Этого нет, это не ставится, это перестали поддерживать. А все из-за нестабильного kernel API!

Annymous ()
Ответ на: Re: NVIDIA 1.0-8756 от anonymous

Re: NVIDIA 1.0-8756

> Там не поддерживаются многие "старые" карты.

Что за бред? До сих пор GeForce 2 поддерживается. А старее этого мне трудно представить.

los_nikos ★★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от Annymous

Re: NVIDIA 1.0-8756

> Как всё грустно с драйверами в линуксе.. Этого нет, это не ставится, это перестали поддерживать. А все из-за нестабильного kernel API!

Анонимусы всегда стесняются своего незнания?

los_nikos ★★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от los_nikos

Re: NVIDIA 1.0-8756

http://www.nvidia.com/object/IO_18897.html

The following products are not supported in the current ForceWare Release 75 driver. Please continue to use the previous ForceWare Release 70 drivers available here.

TNT2
TNT2 Pro
TNT2 Ultra
TNT2 Model 64 (M64)
TNT2 Model 64 (M64) Pro
Vanta
Vanta LT
GeForce 256
GeForce DDR
GeForce2 GTS
GeForce2 Pro
GeForce2 Ti
GeForce2 Ultra
GeForce2 MX Integrated graphics
Quadro
Quadro2 Pro
Quadro2 EX


Supported Products List

GeForce2 MX
GeForce2 MX 100
GeForce2 MX 200
GeForce2 MX 400
...
...

Tester ★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от mr

Re: NVIDIA 1.0-8756

>Кстати, ложка дёгтя: вылезла картинка за границы экрана, видно, что-то они там перекрутили в очередной раз. Прийдётся xvidtune опять ковырять :-)

А не проще моник через DVI подрубить?

suser ()
Ответ на: Re: NVIDIA 1.0-8756 от los_nikos

Re: NVIDIA 1.0-8756

>Что за бред? До сих пор GeForce 2 поддерживается. А старее этого мне трудно представить.

A TNT2 ты себе уже не представляешь? А зря. Она ещё в ходу.

vovans ★★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от RatMann

Re: NVIDIA 1.0-8756

ААА!!! Ущипните меня!!! ОНИ ДОБАВИЛИ TRIPLEBUFFERING!! НАКОНЕЦ-ТО! УРА! СЛАВА ЯЙЦАМ!! СУПЕР!

Option "TripleBuffer" "boolean"

Enable or disable the use of triple buffering. If this option is enabled, OpenGL windows that sync to vblank and are double-buffered will be given a third buffer. This decreases the time an application stalls while waiting for vblank events, but increases latency slightly (delay between user input and displayed result).

Больше никаких тормозов с включенным VSYNC! Ура, думал не доживу :)))

RatMann ★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от los_nikos

Re: NVIDIA 1.0-8756

> Анонимусы всегда стесняются своего незнания?

Я что-то пропустил, и бинарные kernel modules от одной версии ядра начали подходить к более новым? Пока этого нет, линуксу не преодолеет 10-процентный барьер в десктоповой нише. Не понимают этого только упертые. ОпенСоурс это хорошо, но без бинарных драйверов никуда не денешься...

Annymous ()
Ответ на: Re: NVIDIA 1.0-8756 от Annymous

Re: NVIDIA 1.0-8756

>> Я что-то пропустил, и бинарные kernel modules от одной версии ядра начали подходить к более новым? Пока этого нет, линуксу не преодолеет 10-процентный барьер в десктоповой нише. Не понимают этого только упертые. ОпенСоурс это хорошо, но без бинарных драйверов никуда не денешься...

Не может быть - хоть одна здравая мысль на LOR'e

Когда ж Линус разродится?

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от anonymous

Re: NVIDIA 1.0-8756

> Когда ж Линус разродится?

И не надейся. Линукс для него - всего лишь хобби, "just for fun"..

Annymous ()
Ответ на: Re: NVIDIA 1.0-8756 от anonymous

Re: NVIDIA 1.0-8756

Перестал работать dualhead :((( Конфиг не менял :(
Все что в логе есть необычного:
(--) NVIDIA(1): Connected display device(s) on GeForce 6600 at PCI:1:0:0:
(--) NVIDIA(1):     CRT-0
(EE) NVIDIA(1): Unable to find available Display Devices for screen 1.

Т.е. он считает что моник подключен и к ТВ-Ауту :(
С предыдущими дровами все работало. Кто-нибудь уже столкнулся???

hayova ()
Ответ на: Re: NVIDIA 1.0-8756 от eXOR

Re: NVIDIA 1.0-8756

>В общем следующую буду брать с видимо ATI.

Наслушавшись хвалебных речей о крутости nVidia в Linux и проблемах с ATI драйверами купил недавно Asus N6200. Помучался с неделю и вернулся на Radeon 9550. В первую очередь - из-за мыла в 1280x1024. Кроме того, в nVidia так и не смог настроить framebuffer (в ATI работает сразу, без заточек напильником) и были вечные разной степени глюки в иксах (достаточно сказать, что R9200 на P3-1000 выдавал в glxgears 1700fps, 9550 на Cel-1700 выдаёт где-то около за 2000 (точно не помню, проверять влом), а N6200 на этом же Целероне - только 1300 и то не всегда).

Хотя, конечно, новые сабжевые драйвера ещё пощупаю, но... никому N6200 не нужна? Asus retail... :)

KRoN73 ★★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от anonymous

Re: NVIDIA 1.0-8756

>Я новичек в дебиане.... В unstable еще 2 недельки ждать пока добавят в >репозитарий?
А инсталятор от nvidia что лень запустить ?

call ()
Ответ на: Re: NVIDIA 1.0-8756 от call

Re: NVIDIA 1.0-8756

>А инсталятор от nvidia что лень запустить ?

Кому так делать не лень - им и под виндой жить хорошо :)

KRoN73 ★★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от KRoN73

Re: NVIDIA 1.0-8756

Пожалуй подожду пока с новыми дровами.... каменты почитаю.... меня предыдущие устраивают...

P.S. Athlon64-3000+, nForce4, 4*512 DDR400, 120IDE+300SATA, GF6600LE 128Mb

//Computer.Pers

ComputerPers ()
Ответ на: Re: NVIDIA 1.0-8756 от mr

Re: NVIDIA 1.0-8756

> Надо просто поставить во все нужные Subsection "Display" такую опцию: Modes "имя_моделайна" (иначе драйвер даст выбор видеорежима этому самому nvidia-auto-select)
Спасибо, добрый человек. Глаза до сих пор в кучке от режима 60Hz :-)

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от los_nikos

Re: NVIDIA 1.0-8756

M64, Vanta, TNT2 - можно представить, можно.

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от anonymous

Re: NVIDIA 1.0-8756

> Надо просто поставить во все нужные Subsection "Display" такую опцию: Modes "имя_моделайна" (иначе драйвер даст выбор видеорежима этому самому nvidia-auto-select) >Спасибо, добрый человек. Глаза до сих пор в кучке от режима 60Hz :-) >anonymous (*) (08.04.2006 13:13:28)

Чиай про xorg.conf!

Указанным методом 2 монитора на Dualhead'е с разными разрешениями и частотами висят!

1ый - 1280x1024 - 85hz

2ой - 800x600 - 75hz

Конфиг привести?

ComputerPers ()

Re: NVIDIA 1.0-8756

Они открыли i2c!!! Теперь rivatv опять возродится.

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от KRoN73

Re: NVIDIA 1.0-8756

>Кому так делать не лень - им и под виндой жить хорошо :)
А что в фирменном инсталяторе не нравиться то ?

call ()

Re: NVIDIA 1.0-8756

ebuild есть, причем на amd64 - аж стабильный 8-)

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от KRoN73

Re: NVIDIA 1.0-8756

>Наслушавшись хвалебных речей о крутости nVidia в Linux и проблемах с ATI драйверами купил недавно Asus N6200. Помучался с неделю и вернулся на Radeon 9550. В первую очередь - из-за мыла в 1280x1024.

А более убогой карты не нашлось? Бренд ASUS еще ничего не говорит.

>Кроме того, в nVidia так и не смог настроить framebuffer (в ATI работает сразу, без заточек напильником)

А что его настраивать-то? vesafb-tng и вперёд. А ATI даже VBE 3.0 не поддерживает.

>были вечные разной степени глюки в иксах

Бред какой-то. Какие глюки-то? Надеюсь, composite не включал?

>R9200 на P3-1000 выдавал в glxgears 1700fps, 9550 на Cel-1700 выдаёт где-то около за 2000 (точно не помню, проверять влом), а N6200 на этом же Целероне - только 1300 и то не всегда).

GLXGEARS - ЭТО ДЕРЬМО, А НЕ БЕНЧМАРК!!! Результаты Q3 в студию (ты же не будешь утверждать, что 6200 медленнее этого убожества 9200?).

>Кому так делать не лень - им и под виндой жить хорошо :)

Вообще ниасилил смысла фразы :)

RatMann ★★ ()

Re: NVIDIA 1.0-8756

>поддержка suspend-to-disk

Сегодня определенно хороший день, да.

kaktyc ★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от call

Re: NVIDIA 1.0-8756

>А что в фирменном инсталяторе не нравиться то ?

То, что он автоматически не обновляется. Идти куда-то, что-то качать, куда-то заливать, как-то сносить старую версию... влом просто. Во времена портежей ручками ставить софт - ты ещё предложи компилировать в машинные коды на бумажке шариковой ручкой, проставляя ручками все переходы :)

KRoN73 ★★★★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от eXOR

Re: NVIDIA 1.0-8756

apt-get install nvidia-glx-legacy nvidia-kernel-legacy

В Debian две пары nvidia-драйверов: свежие и legacy. вторые -- это 7174. Работают на ура (у меня есть одна машина Sony Vaio Desktop, неапгрейдабельная, TNT2 на борту).

Zulu ★★☆☆ ()
Ответ на: Re: NVIDIA 1.0-8756 от KRoN73

Re: NVIDIA 1.0-8756

>То, что он автоматически не обновляется. Идти куда-то, что-то качать, куда-то заливать, как-то сносить старую версию... влом просто. Во времена портежей ручками ставить софт - ты ещё предложи компилировать в машинные коды на бумажке шариковой ручкой, проставляя ручками все переходы :)

Мда...

# nvidia-installer --uninstall
# sh ./NVIDIA-Linux-x86-1.0-8756-pkg0.run

Что тут сложного? Похоже, пользователи одного известного дистрибутива совсем обленились.

Те, кто ищет лёгких путей, пусть валят в маздай и "откидываются на спинку кресла" (с).

RatMann ★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от RatMann

Re: NVIDIA 1.0-8756

># nvidia-installer --uninstall ># sh ./NVIDIA-Linux-x86-1.0-8756-pkg0.run

А я и не знал что надо делать деинсталяцию, всегда поверх ставил и ничего :). Похоже она сама старую верию деинсталит.

anonymous ()

Re: NVIDIA 1.0-8756

Да что уж все так раскричались про совместимость - несовместимость дров? Через год-другой Интел окончательно продвинет на десктопы EFI, тогда с драйверами станет намного легче - они будут ОС-независимы. В принципе, EFI можно воспользоваться хоть сейчас, никакой особой аппаратной поддержки не требуется. правда, и дров под него пока что раз-два и обчелся. Но с развитием IntelMac'ов дров будет больше - там EFI уже используется, и дрова потихоньку из ОС убирают.

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от KRoN73

Re: NVIDIA 1.0-8756

Люди, вы чего прикалываетась-то! Всё оно автоматически делает, только запусти sh ./NVIDIA*run. Читать по аглицки умеете. Там при установке всё пишется, типа "обнаружены старые дрова, если вы нажмёте ok, они будут деинсталлированы" и всё такое.

На самом деле, главная проблема нвидиевских дров--это их проприетарность и закрытость. Например, производитель сего ПО(nvidia) может по своему усмотрению решать, какие карточки поддерживать, а какие нет. И т.д., и т.п.

А по качеству эти драйвера более-менее, жить можно. Теперь вообще, можно сказать, нормально всё :-)

mr ★★ ()
Ответ на: Re: NVIDIA 1.0-8756 от KRoN73

Re: NVIDIA 1.0-8756

>Идти куда-то, что-то качать
Облинились понимашь :) Понятное дело сказать apt-get upgrade или аналог проще, ну дык закрытый пока драйвер-то, да и развиваться ему еще есть куда так что можно свежачек и с сайта качнуть :)

call ()
Ответ на: Re: NVIDIA 1.0-8756 от call

Re: NVIDIA 1.0-8756

Ктонить встречался с таким поведением n6600: MB A8N-E + AMD64 3200+ + N6600 если пользоваться дровами которые идут в gentoo uni install 64 2006.0 или FB (Gentoo(идро default), FC4(идро 2.6.14-7 ванила)) то n6600 греется вплоть до зависания - если установить дрова с сайта поризводителя то все ок, под виндой все ок - хотелось выяснить причину - и хде n6600 ведет себя также

anonymous ()
Ответ на: Re: NVIDIA 1.0-8756 от Annymous

Re: NVIDIA 1.0-8756

Согласен. Чем популярней линукс становится тем больше закрытых драйверов появляется, с этим ничего не поделаешь. А в свете того что даже полностью открытые драйверы в ядро принимаются после пары лет существования все выглядит еще мрачнее.

Вот и приходится танцы с бубном устраивать после каждого обновления ядра. То ndiswrapper перестает работать, то nvidia/ati, то модем...

Блин, ну так сложно хотя бы в .h файлах не менять структуру? Я, например, могу поправить в драйверах несовместимости с более новым ядром, ну а пользователи что будут делать?? Правильно, держать свои новые компьютеры подальше от линукса..

McGray ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.