LINUX.ORG.RU

Gaim 0.69 is out!


0

0

Вышла новая версия Gaim. Это Instant Messenger (IM) клиент под Gtk2, поддерживающий множество различных пртоколов.

Changelog пока не опубликован, но исходные тексты уже доступны.

>>> Подробности



Проверено: green

Re: Gaim 0.69 is out!

Это конечно радует но нафиг он нужен без rusconv плагина ?

anonymous ()

Re: Gaim 0.69 is out!

Да вообще-то нужен ..... Он у меня как jabber client для локального jabber сервера стоит ... помогает ... ;))) он же на gtk , т.е. qt как для psi ему не надо . ;)

А что такой виликий plugin вообще для него существовал когда-то? Кстати, у меня сейчас версия 0.68, так большенство icq сообщений приходит на русском .... есть конечно которые и в каракузямбулах приходят, но это меньшенство, и тока от тех кто mirand`ой пользуется ...

anonymous ()
Ответ на: Re: Gaim 0.69 is out! от anonymous

Re: Re: Gaim 0.69 is out!

Не только с миранды. У него траблы и с 2002 аськой, соответственно с более ранними. У меня из контакт листа где-то 50% кирилица не проходит.
А так клиент хороший, особенно поддержка множественных учетных записей, но не для кириллицы к сожалению :-\\\

uranium ()

Re: Gaim 0.69 is out!

Блин вы о чем он нормально по руски шперхает и никаких проблем с ним нету, в последних версиях разработчики отказались от русконверта так как включили в исходники поддержку руского языка.

anonymous ()

Re: Gaim 0.69 is out!

Ok. И как ее (эту поддержку) заюзать ? Лично у меня ничерта не получилось - в настройках этого нет, rusconv не заводиться - так как они похоже формат плагинов поменяли, новой версии rusconv похоже не будет... Че делать-то ? Давай объясняй !!!

anonymous ()
Ответ на: Re: Gaim 0.69 is out! от anonymous

Re: Re: Gaim 0.69 is out!

Последнему ананимусу: Придешь ко мне в оффис, скажешь, где я не прав.
З.Ы.: Умничать всегда легко, считая других идиотами (особенно на расстоянии интернета).

uranium ()
Ответ на: Re: Re: Gaim 0.69 is out! от uranium

Re: Re: Re: Gaim 0.69 is out!

Извиняюсь, предпоследнему :-) Пока напечатал сообщение, кто-то добавил свое.

uranium ()
Ответ на: Re: Gaim 0.69 is out! от AVL2

Re: Re: Gaim 0.69 is out!

2 AVL2:
-- Для работы с русским берите gaim с ...

Я так понимаю, это версия от альта? У меня как раз стоит и альт, и сизиф, и все равно проблема перекодирования сообщений кириллицей с аськи.

uranium ()

Re: Gaim 0.69 is out!

A podderjka WindowMaker'a u nego est'?

fagot ★★★★★ ()

Re: Gaim 0.69 is out!

Все на джаббер - аську в историю :-)

Deleted ()

Re: Gaim 0.69 is out!

Нет. пока в сизифе & Co этой версии нет.
В сизифе вообще, насколько я знаю, 0.65 еще.

AVL2 ★★★★★ ()

Re: Gaim 0.69 is out!

люди, пользуйте SIM, и будет вам щастье. Он ГОРАЗДО удобнее гаим. Из минусов только qt :)

anonymous ()
Ответ на: Re: Gaim 0.69 is out! от anonymous

Re: Re: Gaim 0.69 is out!

-- люди, пользуйте SIM, и будет вам щастье. Он ГОРАЗДО удобнее гаим

А кофеварка удобнее утюга для приготовления борща.
Сначала разберись, что к чему, а уж потом разбрасывай умные мысли.

uranium ()

Re: Gaim 0.69 is out!

2 AVL2: 
-- Для работы с русским берите gaim с ...
Ой мама, я ща помру! смотрите, люди на этот патч! :)
---------------- 8< ---------------------------------------
@@ -372,7 +372,7 @@
                utf8 = g_strndup(text, textlen);
                break;
        case AIM_IMFLAGS_ISO_8859_1:
-               utf8 = g_convert(text, textlen, "UTF-8", "ISO-8859-1", NULL, NULL, NULL);
+               utf8 = g_convert(text, textlen, "UTF-8", "CP1251", NULL, NULL, NULL);
                break;
        case AIM_IMFLAGS_UNICODE:
---------------- 8< ---------------------------------------

Дада. Рулез.
Если кому-то нужен патченый gaim - он лежит в contribs/9/ у asplinux.
ftp.asplinux.ru:/pub/contribs/9/SRPMS/gaim-0.68-1asp.src.rpm
Патч из этого пакета подходит и для 0.68

BoBuk ()

Re: Gaim 0.69 is out!

Русский перевод там просто ужасен.

zenkov ★★ ()

Re: Gaim 0.69 is out!

Когда я делал свой патч, то смотрел в пакет асп.
Он с русским один хрен не работает.
Да и патч из него на 0.69 не кладется.

AVL2 ★★★★★ ()

Re: Gaim 0.69 is out!

>2AVL2: а че из cvs? 0.68 не умеет?
перевод там новый
да и глючил у меня 0.68 чего то с созданием аккаунта в джаббере.

AVL2 ★★★★★ ()

Re: Gaim 0.69 is out!

2AVL2

Что-то с этим патчем русский посылается неправильно, а приходит правильно. У вас случаем не CP1251 стоит в переменных locale? У меня koi8-r.

qleap ()

Re: Gaim 0.69 is out!

>Ой мама, я ща помру! смотрите, люди на этот патч! :)

Ну вообще то написано в комментах - мелкий хак, а не полноценный патч.
Поэтому в основной ветке его и нет.
Но дело свое делает и не мешает. А если есть полноценное решение (хотя мне как то его не представляется) - почему бы не отправить его на gaim.sf.net?




AVL2 ★★★★★ ()

Re: Gaim 0.69 is out!

>Что-то с этим патчем русский посылается неправильно, а приходит
>правильно. У вас случаем не CP1251 стоит в переменных locale? У меня
>koi8-r.

koi8-r
Это вообще не имеет значения, потому как gaim всегда работает в юникоде и все перекодировки исключительно utf8<>cp1251.


AVL2 ★★★★★ ()

Re: Gaim 0.69 is out!

>Это вообще не имеет значения, потому как gaim всегда работает

>в юникоде и все перекодировки исключительно utf8<>cp1251.

Это мне известно, меня больше занимает вопрос, почему то, что я посылаю приходит в какой-то кроказябре... Что ж - будем думать

qleap ()

Re: Gaim 0.69 is out!

afaik, поскольку gaim работает исключительно с utf8, то проблем с отправкой мессажей на русском нет, все они приходят нормально, а вот с приемомо голяк, и виноват в этом не gaim а виндовые аськи. + gaim поддерживает плюгины написанные на перле.

borisych ★★★★★ ()

Re: Gaim 0.69 is out!

#!/usr/bin/perl -w
GAIM::register("Recoder KOI - Win", "0.0.1", "goodbye", "");

GAIM::add_event_handler("event_im_recv", "on_im_receiving");

sub goodbye {
}

sub on_im_receiving {
  $conn_ind = @_[0];
  $who_uin = @_[1];
  $msg = @_[2];
  $translated = win_koi( $msg );
  GAIM::write_to_conv($who_uin,1,"$translated","$who_uin");
  return(1);
}

sub win_koi {
        local $_ = shift;
        tr/?ижсйемцьыгузтшбюопнкдфщъвялхрэач?ИЖСЙЕМЦЬЫГУЗТШБЮОПНКДФЩЪВЯЛХРЭАЧ/ЁЙЦУКЕНГШЩ
ЗХЪФЫВАПРОЛДЖЭЯЧСМИТЬБЮёйцукенгшщзхъфывапролджэячсмитьбю/
                if( defined( $_ ) );
        return $_;
}

borisych ★★★★★ ()
Ответ на: Re: Gaim 0.69 is out! от borisych

Re: Re: Gaim 0.69 is out!

2 borisych:
-- и виноват в этом не gaim а виндовые аськи

Виноват gaim, и тут даже говорить не об чем. Раз назвался груздем(работа с icq), то полезай в кузов(работай с ними на все 100%).

З.Ы.: Но это уже другая история. Это болезнь почти 99% софта под линукс. Не излечится - жить не будет.

uranium ()

Re: Gaim 0.69 is out!

2borisych:

>afaik, поскольку gaim работает исключительно с utf8, то проблем
> с отправкой мессажей на русском нет, все они приходят
> нормально, а вот с приемомо голяк, и виноват в этом не gaim а
> виндовые аськи. + gaim поддерживает плюгины написанные на
> перле.

Ну после наложения патча AVL2, приходят все сообщения
нормально, а вот до адресатов miranda и иже с ними, которые не
поддерживают юникодные сообщения, почему-то приходят именно в
юникоде. Уж не знаю, почему у AVL2 все работает... :-/

qleap ()

Re: Чип для плееров с поддержкой открытого аудиоформата Ogg Vorbis

Не берите патч BoBuk'а. Он кривой! Честно-честно :)

Bacek ()

Re: Gaim 0.69 is out!

Все это хорошо но Yahoo протокол поменяли и gaim теперь его не поддерживает...:(

anonymous ()

Re: Gaim 0.69 is out!

народ, юзающий openbox - как gaim в опенбоксовый трэй-бар запихать? плагин этого-самого трэй-бара включён, в гноме иконка видна, а в openbox-е нет. а SIM в трэй садится, но вешает window manager при нажатии CTRL-SPACE. и openbox вешает, и gnome...

anonymous ()

Re: Gaim 0.69 is out!

А вот неразобравшись и спорите! GAIM нормально принимает русский из новых Win ICQ, если те передают текст в UTF. Это видно у каждого контакта в вашем листе. Поэтому rusconv уже и устарел.

У других же стоит кодировка "Trillian", например. Даже виндовая ICQ с ними имеет такие же глюки, так как 'unknown' = 'iso8859-1'. Вот что на самом деле нужно было сделать, так это настраиваемый default charset в плагине icq.

anonymous ()

Re: Gaim 0.69 is out!

2AVL: Не надо рассказывать сказок насчет "в asplinux не работает". Работает, надо было просто зайти в настройки ICQ аккаунта и выбрать кодировку. К вопросу - пропихнуть _нормальное_ решение не удастся. На фразу "старые icq клиенты не поддерживают UTF" sean отзывается фразой "потому что старые клиенты сломаны". Читайте например тут: http://sourceforge.net/tracker/index.php?func=detail&aid=732159&group...

2bacek: дада. мой патч сломан. твоими исправлениями в нем :-P

BoBuk ()

Re: Gaim 0.69 is out!

<i>Вот что на самом деле нужно было сделать, так это настраиваемый default charset в плагине icq.</i>

Вот что на самом деле и делает мой и bacek'a патч.

BoBuk ()

Re: Gaim 0.69 is out!

Нашлось решение проблемы, но настройка дефолтного charsetа не помешала бы конечно :) Приблизительно так же, как сделано в IRC-плагине.
Before sending IMs, oscar_encoding_check(tmpmsg) is
called. If the outgoing IM contains non-ASCII and
non-ISO-8859-1 chars, GAIM sends Unicode IM.

But if the receiver (esp. CJK-users) uses old icq
clients (such as icq2000/2001), the Unicode IMs will
not be seen.

Suggestion: add a check after
oscar_encoding_check(tmpmsg), if the buddy is not
capable of receiving Unicode IMs, (AIM_CAPS_ICQUTF8 is
not set) fallback to ISO-8859-1 or ASCII.

in oscar.c, around line 4368:
args.flags |= oscar_encoding_check(tmpmsg);
+ if ((args.flags & AIM_IMFLAGS_UNICODE) &&
!(bi->caps & AIM_CAPS_ICQUTF8)) {
+ gaim_debug(GAIM_DEBUG_INFO, "oscar",
+ "Buddy may not be able to receive Unicode IM. ISO-8859-1 enforced.\n");
+ args.flags &= ~AIM_IMFLAGS_UNICODE;


+ args.flags |= AIM_IMFLAGS_ISO_8859_1;
+ }

После наложения этого и AVL2ского патча все работает (по-крайней мере с русским)

qleap ()

Re: Gaim 0.69 is out!

2qleap
Спасибо.
Счас внесу ваше исправление.


На мой взгляд как раз делать кучу натсроек в контактах нет смысла. Все равно же нет ничего этого в виндовых аськах да и в мейнстрим опять таки по любому не примут. Стало быть патч должен быть маленьким и максимально приложимым к обновленным версиям.

AVL2 ★★★★★ ()
Ответ на: Re: Gaim 0.69 is out! от BoBuk

Re: Re: Gaim 0.69 is out!

-- На фразу "старые icq клиенты не поддерживают UTF" sean отзывается фразой "потому что старые клиенты сломаны". Читайте например тут: http://sourceforge.net/tracker/index.php?func=detail&aid=732159&group...

Мудаки... Что тут еще сказать. Разве что ляликс - сакс вместе со всеми его поделками.

anonymous ()

Re: Gaim 0.69 is out!

Мудаки те, кто до сих пор utf не поддерживает, а не авторы Гайма. Давить айсуку с ламерандой!!!!!!!!!!!

anonymous ()

Re: Gaim 0.69 is out!

Нет, не мудаки. В остальном они очень адекватные люди. Просто проблемы работы со старыми клиентами их не очень волнуют.

BoBuk ()
Ответ на: Re: Gaim 0.69 is out! от anonymous

Re: Re: Gaim 0.69 is out!

-- Мудаки те, кто до сих пор utf не поддерживает,

Может и не мудаки, но подход несерьезный :-\ Это мягко говоря. Давить аську или не давить, это другой вопрос. Но, если тебе нужно общаться с человеком, у которого старая аська, то есть два варианта - первый (линуксовый), это кричать, мол ты мудак, поставь себе новую аську или джаббер. И второй, нормальный - выбросить нафиг кривой gaim, и поставить то, что понимает совбеседника нормально.

uranium ()

Re: Gaim 0.69 is out!

>> люди, пользуйте SIM, и будет вам щастье. Он ГОРАЗДО удобнее гаим

>А кофеварка удобнее утюга для приготовления борща.
>Сначала разберись, что к чему, а уж потом разбрасывай умные мысли.
По-моему, он всё правильно сказал. В чём такое принципиальное отличие GAIM от SIM'а, кроме того, что один gtk-шный, а второй - qt-шный (не вдаваясь в подробности что лучше:))?

anonymous ()

Re: Gaim 0.69 is out!

2 anonymous (*) (2003-09-26 23:42:49.899818) Тем, что gaim поддерживает много протоколов. SIM v0.8 - один. Различие на самом деле не одно, но это, на мой взляд, - самое существенное.

оффтопик: сегодня начал пользоваться связкой psi+jabber - тащщуссь :)

steam ()

Re: Gaim 0.69 is out!

2steam: как обстоят дела в ПСИ с русским, при пересылке сообщений на jabber и icq win32 клиенты?

anonymous ()

Re: Gaim 0.69 is out!

Самое главное, что у 0.69 должна появиться поддержка SSL в Jabber.

Cybem ★★ ()

Re: Gaim 0.69 is out!

в SIM 0.9 SSL в Jabber есть, только что проверил

anonymous ()

Re: Gaim 0.69 is out!

2: anonymous (*) (2003-09-27 00:37:49.138137)
Очень хорошо обстоят. Только что проверял - всё ходит абсолютно без проблем.

steam ()

Re: Gaim 0.69 is out!

Мля яху мессенджер не пашет :(((((((((

anonymous ()

Re: Gaim 0.69 is out!

2Bacek с твои патчем собрал, падает через некоторое время

(gaim:30974): Glib-CRITICAL **: file gconvert.c line:500 (g_convert) assertion `from_codeset != NULL' filed

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.