LINUX.ORG.RU

Релиз Funtoo Linux 1.4

 , , ,


0

2

Долго ли, коротко, Daniel Robbins представил очередной релиз, встречаем, Funtoo Linux 1.4.

Особенности:

  • в основе meta-repo срез Gentoo Linux от 21.06.2019 г. (с бэк-портами исправлений безопасности);
  • базовая система: gcc-9.2.0, binutils-2.32, glibc-2.29, openrc-0.41;
  • debian-sources-lts-4.19.37;
  • обновления в подсистеме OpenGL: libglvnd (альтернатива eselect opengl), mesa-19.1 (vulkan support), nvidia-drivers-430.26;
  • Gnome 3.32, KDE Plasma 5.16;
  • в качестве альтернативы «ручной» установке параметров видеоподсистемы через USE и VIDEO_CARDS набор Funtoo Graphics Mix-Ins: gfxcard-amdgpu, gfxcard-ancient-ati, gfxcard-intel, gfxcard-nouveau, gfxcard-nvidia, gfxcard-older-ati, fxcard-radeon - Mix-ins;
  • LXC 3.0.4, LXD 3.14 с поддержкой GPU acceleration в контейнерах, говорят что даже Steam можно запустить;
  • perl-5.28, python-3.7, oracle-jre-bin-1.8.0.202;
  • и вишенка на торт - dev-lang/dart-2.3.2.

Ссылки:

И ещё полезного:

И чтобы предупредить вопросы «А что это за очередной клон Gentoo?…»:

P.S. Несмотря на то, что релиз для тестов был доступен с июня, а фактически состоялся в середине августа, продолжается работа над документацией по установке, в части внесения актуальных изменений.

>>> Release Notes

★★★★★

Проверено: jollheef ()

Ответ на: комментарий от LongLiveUbuntu

Даниэль выкинул поддержку multilib на мороз. Внезапно, оказалось, что Steam требует 32-битные библиотеки для запуска игр, пришлось городить такой костылище.

Понятно. Фунту решил последовать за модными трендами заданными гей-осью. Мудаки.

trynoval ()
Ответ на: комментарий от trynoval

последовать за модными трендами... Мудаки

Multilib support — the ability for 64-bit versions of Funtoo Linux to run legacy 32-bit applications — has been deprecated, so that Funtoo Linux for 64-bit CPUs is now 64-bit only — what we used to offer as a separate «pure64» build. This was done because 32-bit support was originally created as a stop-gap measure 15 years ago to allow for a seamless transition to 64-bit computing, and we believe the time has come to shed this ongoing maintenance burden and focus efforts that have historically been spent on 32-bit compatibility to other areas.
We realize that this may create inconvenience for some users. There are some workarounds that will work for most situations. One is to create a 32-bit chroot environment for the odd 32-bit application that you may still need to run.

Что здесь мудацкого и где следование за модой?

vvn_black ★★★★★ ()
Последнее исправление: vvn_black (всего исправлений: 1)
Ответ на: комментарий от vvn_black

Выкидывание i386 которым до сих пор люди пользуются. С эппл всё понятно - у них бизнес модель такая. Дистрибутивам же которые такое делают видимо не нужны пользователи.

trynoval ()
Ответ на: комментарий от trynoval

Выкидывание i386 которым до сих пор люди пользуются.

Кто и что откуда выкинул?

Я тебе переведу, потому что что-то у тебя с пониманием, как бы это ещё попроще сделать, год назад убрали поддержку запуска устаревших 32-разрядных приложений из x86_64 сборок, но при этом предложили как минимум два решения, для тех кому это важно.

А это список поддерживаемых архитектур для x86_32, которые выкидывать никто не собирается:

../
atom_32/                                  04-Sep-2019 05:29
generic_32/                               04-Sep-2019 05:14
i686/                                     04-Sep-2019 05:00
pentium4/                                 04-Sep-2019 04:42
vvn_black ★★★★★ ()
Последнее исправление: vvn_black (всего исправлений: 1)

что лучше: гента или фунта?

cetjs2 ★★★★★ ()
Ответ на: комментарий от cetjs2

Фунта, это гента надо которой кто-то уже поработал надфилем вместо тебя. Если кажется, что удачно, тогда фунта лучше, а если нет, то и гента ничего.

vvn_black ★★★★★ ()
Ответ на: комментарий от vvn_black

Так я не понял: могу я подключить 32 битную архитектуру в x86_64 ОС? И использовать штатную фичу AMD64 архитектуры - нативный запуск 32 битных приложений. Или авторы Фунту говорят нам досвидания, потому что 32бита «устарели»?

trynoval ()
Ответ на: комментарий от trynoval

Делаешь чрут в систему с поддержкой 32 бит либ и запускаешь 32 битую прожку

anonymous ()
Ответ на: комментарий от anonymous

Некоторые программы 32 битные и запускают 64 битные и наоборот. Или части в разных разрядностях. Не айс как-то.

anonymous ()
Ответ на: комментарий от trynoval

Нет, не можешь. Сами 32 бита остались, но multilib как фичи больше нет.

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от vvn_black

Тоесть я прав, и Фунту последовали за модой.

Выбор конечно их, если не хотят нормально х86 поддерживать, хотя это штатная фича процессора.

Но пользователей у их «неустаревшего» дистрибутива теперь будет меньше.

trynoval ()
Ответ на: комментарий от LongLiveUbuntu

Ты кстати как, всё ещё с убунтой, или ник теперь анахроним как тату с именем бывшей?

trynoval ()
Ответ на: комментарий от trynoval

Тоесть я прав

Тебе 32 бита в 64-битной системе зачем? Вайн или стим? Т.е. чтобы использовать костыли, ты требуешь от мейнтейнеров поддерживать другие костыли?

Не проще 10-ку в дуалбут?

vvn_black ★★★★★ ()
Ответ на: комментарий от trynoval

Народ, тут лужа метанирует пузырями.

так вылезай уже

anonymous ()
Ответ на: комментарий от vvn_black

Тебе деление дробью зачем? Поровну хочешь всё поделить как в советском союзе? Ты требуешь математиков коммунизм поддерживать?

Вся суть веры в «прогресс» и следования за трендами.

trynoval ()
Ответ на: комментарий от vvn_black

Я, крядь, должен в чруте запускать ещё одну копию системы ради того, чтобы запустить нужную мне программу? Нахер такое надо.

LongLiveUbuntu ★★★★★ ()
Ответ на: комментарий от trynoval

Ты кстати как, всё ещё с убунтой, или ник теперь анахроним как тату с именем бывшей?

Убунта на ноутах, генту на десктопе (раньше была убунта, потом фанту)

LongLiveUbuntu ★★★★★ ()
Последнее исправление: LongLiveUbuntu (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.