LINUX.ORG.RU

Debian 7.0 «Wheezy» заморожен

 , ,


1

3

30 июня в списке рассылки Debian Devel Announce было объявлено о переходе текущей тестовой ветки Debian в состояние заморозки. Это означает, что все дальнейшие обновления пакетов должны ограничиваться исправлениями ошибок. Пакеты, для которых на момент заморозки были более новые версии в Sid, автоматически получили исключения и будут обновлены немного позже. Прочие обновления и добавление новых пакетов возможны лишь по согласованию с Release Team (командой, ответственной за подготовку нового выпуска дистрибутива).

Среди интересных нововведений можно отметить:

  • поддержку Multiarch;
  • пакеты, когда возможно, собираются с использованием опций компилятора, повышающих безопасность (http://wiki.debian.org/HardeningWalkthrough);
  • /tmp по умолчанию в tmpfs (окончательного решения пока нет).

Debian 7.0 будет включать:

  • ядро Linux 3.2.0 (LTS-ветка);
  • поддержку стандарта LSB 4.1;
  • компилятор GCC 4.7;
  • Python 2.7;
  • Perl 5.14;
  • среду рабочего стола GNOME 3.4;
  • среду рабочего стола KDE 4.8.4 (кроме приложений KDE PIM (4.4.11));
  • среду рабочего стола Xfce 4.8;
  • офисный пакет LibreOffice 3.5.4;
  • графический редактор GIMP 2.8;
  • веб-браузер Iceweasel 10.0 (ESR-ветка);
  • почтовый клиент Icedove 10.0 (ESR-ветка);
  • веб-сервер Apache 2.2.22;
  • PHP 5.4.4;
  • MySQL 5.5.24;
  • и многое другое.

>>> 5… 4… 3… 2… 1…

★★★★★

Проверено: DoctorSinus ()

Ответ на: комментарий от Reset

«Оскорбление участников дискуссии» в действии? Не пора ли отдохнуть, попариться в сандунах?

wheel ()
Ответ на: комментарий от Reset

«Смена мажорный релизов сопровождается свистопляской, ручным разруливанием зависимостей и правкой поломанных конфигов.»

lenny-2-squeeze Обновление прошло гладко.

anonymous ()
Ответ на: комментарий от mx__

посмотрел некоторые на вскидку доступные мне разные дебианы - все работает. Сквизи, ленни и какой там ветеран версии 3.0 с ядром 2.2 не заметили лишней секунды, хотя везде ntp, может быть, конфиги волшебные?

Pm7vLB ()
Ответ на: комментарий от Reset

Скорее всего что-то умалчиваешь.

Если обновлять стейбл на стейбл, то жизнь вполне хороша. Если к стейблу добавлять тестинг/сид, то приключения находятся легко. По впечатлениям от небольшого парка в разных вариантах (от «только stable» до sid) и с разным количеством ПО. Начал на 3.1.

sv75 ★★★★★ ()
Ответ на: комментарий от Pm7vLB

а вот на siduction да - выжирал время виртуалбоксный процесс, впрочем, это ж unstable

Pm7vLB ()
Ответ на: комментарий от abumbaher

вы не умный. точно вам говорю. поинтересовались бы хоть сначала... да, ЛОРовские регистранты хуже иных анонов. каникулы, опять же.

anonymous ()

GotF, отличное оформление и отличная новость!

renya ★★★★★ ()
Ответ на: комментарий от Komintern

втором конечно же, если ты ща начнешь с третьего.. то в любом случае потом столкнешься со втором ;) а пока кучи библиотек/фреймворков на 3ем нету.. то и смысла в нем не особо много

umren ★★★★★ ()
Ответ на: комментарий от Reset

Не верю

Не знаешь, молчи, это не предмет веры, а предмет опыта.

В каких-то тривиальных случах может быть оно само и обновляет, но такие случае очень редки

С 5.0 до 6.0 обновил рабочую станцию со сторонним совтом и KDE в качестве рабочего стола, делал по оф. руководству. Всё обновилось без потерь.

Дебиан --- единственный дистрибутив, могущий претендавать на безболезненное обновление мажорных версий.

Vudod ★★★★★ ()
Ответ на: комментарий от maxcom

о да, апдейт 15->16 несет в себе кучу граблей, чую еще полежим как будем обновлять

Может пора подумать о миграции на CentOS6/SL6 с перспективой перехода на дебиан? Всё-таки, пусть не так всё фичастно, но поспокойнее. Свои пакеты ведь и так и так собирать придется....

anonymous ()
Ответ на: комментарий от abumbaher

Я полагаю , весь этот огород, ради запуска говновайна на x86_64/Не нужно. Не по джидайски это.

Нет, это всего лишь удачное следствие. Кстати, очень полезное следствие в перспективе кроссплатформенной сборки через mingw. Еще одно следствие — можно будет собирать на 64-битной машине любые 32-битные пакеты без чрута и других извращений. А цель — сделать наконец полноценную многоархитектурность не хуже того, что почти 10 лет есть в rpm-ах.

Реальность пока еще далека от идеала, и всё не так радужно, как в RPM-ах, но движение идет именно в нужном направлении, и с куда более универсальным подходом (без костылей вроде «lib+lib64»).

anonymous ()
Ответ на: комментарий от f1xmAn

Ну я про то и говорю, малейшее изменение в столетнем говне мамонта это целое событие :)

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

Ну, ты злой. Говно мамонта занимает неплохие позиции на серверах, где ему в общем-то и место :-)

f1xmAn ★★★★★ ()
Ответ на: комментарий от f1xmAn

Ну и пусть занимает, оно от этого говном мамонта быть не перестаёт :)

ты злой

Да ладно, я добрейшей души человек :)

daemonpnz ★★★★★ ()

ух пхп уже 5.4.4. бегут то как.

ggrn ★★★★★ ()
Ответ на: комментарий от Komintern

Я прочитал тьюториал на официальном сайте, он был по третьему. Потом была пара сюрпризов от второго, типа range/xrange. У меня сейчас второй-третий месяц знакомства с питоном, разницы особой не вижу между ними. Думаю, без разницы, но с документом о миграции 2->3 всё равно рано или поздно придётся ознакомиться.

i-rinat ★★★★★ ()
Ответ на: комментарий от Komintern

а на каком питоне сейчас стоит учиться писать?

Лучше на всех сразу. :) Eсли учиться, то начать имхо лучше со второго, но периодически посматривать на отличия в третьем, чтобы быть морально готовым, например, к исчезновению форматирования через %.

Вообще питон довольно нестабилен. Несмотря на то, что его можно теоретически использовать почти для всего, на практике его почти невозможно дебажить, и это сильно ограничивает его популярность.

anonymous ()
Ответ на: комментарий от Reset

Возможно, что я что-то забыл. Может и было еще что. Но факт есть факт - рабочая машина, без особых проблем прошедшая несколько релизов.

evilface ★★ ()
Ответ на: комментарий от sv75

У меня получился тогда путь Stable->Stable->Testing->Unstable, на второй стабильный я пришел, думая, что он еще тестируемый, он тогда только вышел, через пару месяцев обновился до тестируемого, а там почти сразу до Сида. И до сих пор все живое.

evilface ★★ ()
Ответ на: комментарий от Vudod

LFS? Кучку ПО обновить получилось - объявил сам себе о мажорной версии :-)

evilface ★★ ()

Уж слишком много времени у них уходит чтобы выпустить новую версию дистрибутива.

alpha4 ()

среду рабочего стола GNOME 3.4;

Ha ha!

Jayrome ★★★★★ ()

httpd

Почему везде Apache 2.2.x ветка используется, когда основной стабильной давно стала 2.4.x?

CSRedRat ()

Ликуют дебианщики, скоро будет у них новая криокамера.

anonymous ()

Debian не нужен!

anonymous ()
Ответ на: комментарий от anonymous

хм. неужели похапе дебажится лучше? но популярность вон какая.

Komintern ★★★★★ ()
Ответ на: комментарий от Komintern

хм. неужели похапе дебажится лучше? но популярность вон какая.

Ничем не лучше, а хуже за счёт структуры кода. Популярность php есть результат его специализации в сравнительно узкой области. На Питоне можно писать что угодна, на php теоретически тоже, но практически он годен только для веба.

Вообще дебажить Питон просто нужно уметь, проблема там встречается только внутри многопоточного кода, но такая проблема свойственна всем ЯП.

Vudod ★★★★★ ()
Ответ на: httpd от CSRedRat

Почему везде Apache 2.2.x ветка используется, когда основной стабильной давно стала 2.4.x?

Там не слабые изменения в конфигах, что при подходе Debian потребует переделки многих пакетов. В редхате будет проще, поскольку они практикуют поставку голого, не натроенного апача, насколько я помню.

И кстати стала она основной не так уж и давно, по меркам серьёзных проектов.

zloelamo ★★★★ ()

Не хочется как то переходить на третий гном... Xfce шустрый, простой, но чет не нравится мне...Интересно, как себя будет чувствовать Mate на Wheezy. Пробовал недавно Mate на свежем Mint13, ниче вроде. Было ощущение, что нахожусь во втором гноме.

zevilz ★★★ ()
Ответ на: комментарий от anonymous

В чем костыльность «lib+lib64»? Если у меня 64-битная система, но мне нужен запуск нескольких приложений, существующих только в 32-битном варианте - есть ia32-libs и lib32, есть LD_LIBRARY_PATH, и все чики-пики. Отдельно 32 бита, отдельно 64, никто никому не мешает, ничего не путается => все лежит на тех местах, где должно быть => система более стабильна.

Хотел бы услышать реальные приемущества от multiarch, честно говоря очень удивился, когда увидел ее в сквизи.

leg0las ★★★★★ ()
Ответ на: httpd от CSRedRat

Даже в моей генточке 2.4 помечен как хардмаскед. Рано еще, вот в следующем релизе пускай и запилят. И да, больше чем уверен, что 2.4 соберут в backports.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

multiarch

для разработчиков, в основном. Бывает необходимость собрать что-то не только под x86, а ещё и под mips, arm, sparc и другие странные сочетания букв.

debian под mips сейчас собирается на mips машинах. А это несколько медленно. К тому же их мало, а так их можно задействовать для тестов, собирая на более распространённых и быстрых x86.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

Ради разработчиков запилен multiarch?

Тогда куда ставятся либы скажем у Qt? в 64-битной системе без мультиарча они пойдут в /usr/lib -> /usr/lib64 нативные и в /usr/lib32 32-битные.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las
> dpkg -L libqtcore4 | grep /usr/lib
/usr/lib
/usr/lib/x86_64-linux-gnu
/usr/lib/x86_64-linux-gnu/qt4
/usr/lib/x86_64-linux-gnu/qt4/plugins
/usr/lib/x86_64-linux-gnu/qt4/plugins/codecs
/usr/lib/x86_64-linux-gnu/qt4/plugins/codecs/libqcncodecs.so
/usr/lib/x86_64-linux-gnu/qt4/plugins/codecs/libqjpcodecs.so
/usr/lib/x86_64-linux-gnu/qt4/plugins/codecs/libqkrcodecs.so
/usr/lib/x86_64-linux-gnu/qt4/plugins/codecs/libqtwcodecs.so
/usr/lib/x86_64-linux-gnu/libQtCLucene.so.4.8.2
/usr/lib/x86_64-linux-gnu/libQtCore.so.4.8.2
/usr/lib/x86_64-linux-gnu/libQtCore.so.4.8
/usr/lib/x86_64-linux-gnu/libQtCore.so.4
/usr/lib/x86_64-linux-gnu/libQtCLucene.so.4.8
/usr/lib/x86_64-linux-gnu/libQtCLucene.so.4
GotF ★★★★★ ()
Ответ на: комментарий от i-rinat

для разработчиков, в основном.

Как бы есть ещё куча 32-битного софта, которому мало ia32-libs. Ну и последний никогда не отличался актуальностью.

GotF ★★★★★ ()
Ответ на: комментарий от gag

Хотя позавчера 12.6 в sid обновили и с ним 1.12 должен работать, его так

Успокойся, не работает, крэшится х сервер. Приходится ставить из стейбла.

turtle_bazon ★★★★ ()
Ответ на: комментарий от GotF

Благодарю.

Только все равно не понимаю решение - раньше к примеру для того, чтобы поставить вайн нужно было поставить ia32libs, теперь - произвести нехитрые изменения для dpkg, sources.list, стянуть с полсотни пакетов с i386 репы - как по мне явное усложнение. И да, я столкнулся с тем, что этот мультиарч не так то просто убрать (dpkg-чего-то там выдавал ошибку, баг нашел в багзилле). Такие дела.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

для того, чтобы поставить вайн нужно было поставить ia32libs

Для wine в репах amd64 это по-прежнему так.

теперь - произвести нехитрые изменения для dpkg, sources.list, стянуть с полсотни пакетов с i386 репы

Это если ставишь wine:i386. Кстати, он новее по версии.

И да, я столкнулся с тем, что этот мультиарч не так то просто убрать

А зачем? Просто не добавляй «чужие» архитектуры и всё.

GotF ★★★★★ ()
Ответ на: комментарий от GotF

Для wine в репах amd64 это по-прежнему так.

Не так, неделю назад ковырял - как я понял есть вайн для амд64, но он поддерживает только WINEARCH=amd64 (или как-то так), для 32-битного нужно проделать все вышеописаные манипуляции и ставить wine:i386

Кстати, он новее по версии

Да, 1.4, видел:-) Порадовали, а то протушхий 1.0 сколько можно было держать?)

А зачем? Просто не добавляй «чужие» архитектуры и всё.

Должна быть возможность и добавить, и убрать. Ну если по хорошему.

leg0las ★★★★★ ()
Ответ на: комментарий от GotF

sources.list

И таки да, в sources.list менять ничего не нужно, только dpkg --add-architecture и обновить списки пакетов.

GotF ★★★★★ ()
Ответ на: комментарий от leg0las

неделю назад ковырял - как я понял есть вайн для амд64, но он поддерживает только WINEARCH=amd64

Даже не знаю, у меня как-то нормально игры работали. Все 32-битные, понятное дело.

Должна быть возможность и добавить, и убрать.

Я и добавлял, и удалял архитектуры — проблем не было %)

GotF ★★★★★ ()
Ответ на: комментарий от GotF
# apt-cache depends wine
wine
 |Зависит: <wine-bin>
  Зависит: wine64-bin
# apt-cache depends wine64-bin
wine64-bin
  Конфликтует: <wine-bin>

Два пакета, суммарно тянут на 60 кбайт. Вот такой он вайн в оф. репе для амд64

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las
> apt-cache depends wine
wine
 |Depends: wine-bin
    wine-bin:i386
  Depends: wine64-bin
  Conflicts: wine:i386
> apt-cache depends wine-bin
wine-bin
  Depends: libc6-i386
  Depends: libwine-bin
 |Depends: x11-utils
    x11-utils:i386
 |Depends: xbase-clients
  Depends: <xcontrib>
  Depends: libwine-gecko-unstable
  Suggests: libwine-print
  Suggests: libwine-gl
  Conflicts: binfmt-support
  Conflicts: binfmt-support:i386
  Conflicts: <wine-gecko-1.0.0>
  Conflicts: <wine-gecko-1.0.0:i386>
  Replaces: libwine
  Replaces: libwine:i386
  Replaces: wine
  Replaces: wine:i386
  Replaces: wine-utils
  Replaces: <wine-utils:i386>
  Conflicts: wine-bin:i386
> apt-cache depends libwine-bin
libwine-bin
  Depends: lib32ncurses5
  Depends: lib32tinfo5
  Depends: libc6-i386
  Depends: libwine
  Replaces: wine-bin
  Replaces: wine-bin:i386
  Replaces: wine-utils
  Replaces: <wine-utils:i386>
  Conflicts: libwine-bin:i386
> apt-cache depends libwine
libwine
  Depends: ia32-libs
  Depends: lib32z1
  PreDepends: libc6-i386
  Suggests: wine-doc
  Replaces: libwine-gl
  Replaces: libwine-gl:i386
  Replaces: <libwine-twain>
  Replaces: <libwine-twain:i386>
  Replaces: wine
  Replaces: wine:i386
  Conflicts: libwine:i386

Wheezy.

GotF ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.