LINUX.ORG.RU

Debian 7.0 «Wheezy» заморожен

 , ,


1

3

30 июня в списке рассылки Debian Devel Announce было объявлено о переходе текущей тестовой ветки Debian в состояние заморозки. Это означает, что все дальнейшие обновления пакетов должны ограничиваться исправлениями ошибок. Пакеты, для которых на момент заморозки были более новые версии в Sid, автоматически получили исключения и будут обновлены немного позже. Прочие обновления и добавление новых пакетов возможны лишь по согласованию с Release Team (командой, ответственной за подготовку нового выпуска дистрибутива).

Среди интересных нововведений можно отметить:

  • поддержку Multiarch;
  • пакеты, когда возможно, собираются с использованием опций компилятора, повышающих безопасность (http://wiki.debian.org/HardeningWalkthrough);
  • /tmp по умолчанию в tmpfs (окончательного решения пока нет).

Debian 7.0 будет включать:

  • ядро Linux 3.2.0 (LTS-ветка);
  • поддержку стандарта LSB 4.1;
  • компилятор GCC 4.7;
  • Python 2.7;
  • Perl 5.14;
  • среду рабочего стола GNOME 3.4;
  • среду рабочего стола KDE 4.8.4 (кроме приложений KDE PIM (4.4.11));
  • среду рабочего стола Xfce 4.8;
  • офисный пакет LibreOffice 3.5.4;
  • графический редактор GIMP 2.8;
  • веб-браузер Iceweasel 10.0 (ESR-ветка);
  • почтовый клиент Icedove 10.0 (ESR-ветка);
  • веб-сервер Apache 2.2.22;
  • PHP 5.4.4;
  • MySQL 5.5.24;
  • и многое другое.

>>> 5… 4… 3… 2… 1…

★★★★★

Проверено: DoctorSinus ()

Ответ на: комментарий от Reset

Хотелось-бы чтобы это было не так, но, по крайней мере, при переходе 5.0->6.0 был знатный секас с разруливанием зависимостей. Apt выл и причатал, сносил пакеты десятками, чтобы на следующей итерации поставить их назад. Сейчас держу 7.0 testing и только это, вероятно, спасет меня.

void_ptr ★★★★ ()
Ответ на: комментарий от ghostmansd

Это при том, что Python 3 уже с 2008 года существует.

Это при том, что Python 3 тоже есть в дебиане:

http://packages.debian.org/wheezy/python3

Просто по умолчанию будет использоваться Python 2.7.

eugeno ★★★★★ ()
Ответ на: комментарий от leg0las

Ну само собой. Правда, у меня закрадываются сомнения, что в официальном репе сейчас именно так, потому что я вижу состояние ещё и своего репозитория, который может содержать то, что в официальном уже отсутствует (http://packages.debian.org/wheezy/amd64/wine-bin). То бишь у меня не зеркало, а кэш, поэтому не отражается удаление пакетов из официального репозитория.

GotF ★★★★★ ()
Последнее исправление: GotF (всего исправлений: 1)
Ответ на: комментарий от anonymous

Ну вот заморозили они версии пакетов - а если в каких-то обнаружатся какие-нибудь проблемы, как баги не характеризующиеся, что-нибудь типа дыр в функционале, а через месяц авторы выпустят исправление досадных неточностей?

Примеры проблем, которые не характеризуются как баги?

eugeno ★★★★★ ()
Ответ на: комментарий от GotF

А, вот оно что.

Но почему wine-bin выпилен из оф. репозитория? Это типа принудилово к «юзайте мультиарч»?

leg0las ★★★★★ ()
Ответ на: комментарий от umren

не нужно, есть ubuntu lts с более долгим сроком поддержки

Так говорят только убунтоиды, никогда не видевшие Debian Stable. Поставил я эту вашу lts, поплевался и снёс. Она даже суток аптайма не выдерживает, диск почему-то постоянно шуршит, оба ядра процессора постоянно чем-то нагружены. И батарея ноута держится в полтора раза меньше.

eugeno ★★★★★ ()
Ответ на: комментарий от leg0las

Да. Есть пакет wine64-bin со скриптом, кажется, который говорит, надо сделать так и так, и больше в нём ничего :)

Deleted ()
Ответ на: комментарий от umren

убунта - самый стабильный серверный дистр после шапки

Гы-гы, пеши исчо.

eugeno ★★★★★ ()
Ответ на: комментарий от Deleted

О как. а можно пруф или ман какой-нибудь по этому поводу? а то втыкать собраный пакет вайна под бубунту некошерно.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Это типа принудилово к «юзайте мультиарч»?

Очевидно, да :) Решение можно понять, ибо, как я уже говорил, с ia32-libs там всегда были напряги, а при наличии multiarch поддерживать эту кучу едва ли кто захочет. Конечно, есть неприятный момент в виде необходимости иметь списки пакетов для дополнительной архитектуры, но это можно пережить.

GotF ★★★★★ ()
Ответ на: комментарий от Reset

Смена мажорный релизов сопровождается свистопляской, ручным разруливанием зависимостей и правкой поломанных конфигов.

Если читать и следовать Release Notes, то обновление проходит гладко:

http://www.debian.org/releases/stable/amd64/release-notes/index.html

eugeno ★★★★★ ()
Ответ на: комментарий от sv75

Если к стейблу добавлять тестинг/сид, то приключения находятся легко.

Ну дык, кто ищет, тот всегда найдёт. Кто сказал, что с тестингом/анстейблом всё должно быть нормально? Возьми англо-русский словарь и посмотри, как эти слова переводятся. Разработчики не дают никаких гарантий по этим веткам.

eugeno ★★★★★ ()
Ответ на: комментарий от leg0las
#!/bin/sh

echo "This is the wine64-bin helper package, which does not provide wine itself,"
echo "but instead exists solely to provide the following information about"
echo "enabling multiarch on your system in order to be able to install and run"
echo "the 32-bit wine packages."
echo ""
echo "The following commands should be issued as root or via sudo in order to"
echo "enable multiarch (the last command installs 32-bit wine):"
echo ""
echo "  # dpkg --add-architecture i386"
echo "  # sed -i 's/deb\ /deb\ [arch=amd64,i386]\ /g' /etc/apt/sources.list"
echo "  # apt-get update"
echo "  # apt-get install wine-bin:i386"
echo ""
echo "Be very careful as spaces matter above.  For kfreebsd systems, replace i386"
echo "and amd64 with kfreebsd-i386 and kfreebsd-amd64.  Note that this package"
echo "(wine64-bin) will be removed in the process.  For more information on the"
echo "multiarch conversion, see:"
echo "http://wiki.debian.org/Multiarch/HOWTO"

Это содержится в /usr/bin/wine в пакете wine64-bin.

GotF ★★★★★ ()
Ответ на: комментарий от leg0las
: dpkg --extract wine64-bin_1.4.1-1_amd64.deb .

: cat usr/bin/wine
#!/bin/sh

echo "This is the wine64-bin helper package, which does not provide wine itself,"
echo "but instead exists solely to provide the following information about"
echo "enabling multiarch on your system in order to be able to install and run"
echo "the 32-bit wine packages."
echo ""
echo "The following commands should be issued as root or via sudo in order to"
echo "enable multiarch (the last command installs 32-bit wine):"
echo ""
echo "  # dpkg --add-architecture i386"
echo "  # sed -i 's/deb\ /deb\ [arch=amd64,i386]\ /g' /etc/apt/sources.list"
echo "  # apt-get update"
echo "  # apt-get install wine-bin:i386"
echo ""
echo "Be very careful as spaces matter above.  For kfreebsd systems, replace i386"
echo "and amd64 with kfreebsd-i386 and kfreebsd-amd64.  Note that this package"
echo "(wine64-bin) will be removed in the process.  For more information on the"
echo "multiarch conversion, see:"
echo "http://wiki.debian.org/Multiarch/HOWTO"
Deleted ()
Ответ на: комментарий от Komintern

а на каком питоне сейчас стоит учиться писать?

На обоих, но кодить по возможности на третьем, дабы не тормозить прогресс.

eugeno ★★★★★ ()
Ответ на: комментарий от eugeno

по stable тоже никто ничего не гарантирует

Reset ★★★★★ ()
Ответ на: комментарий от GotF

Печально. Разводить помойку пакетов с двумя архитектурами как-то не хочется, поэтому наверное оптимальным решением бует не ставить amd64 сборку дебиана (вдобавок года полтора-два назад ковырял ее - глючная была как по мне), а ставить старый добрый i386. PAE в любом случае уже есть by default, никаких заморочек с мультиарч, ну а для тех кто хочет оптимизаций под проц - велкам ту генту ворлд.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Запусти винду в виртуалке без инета… Даже спокойнее будет %)

Deleted ()
Ответ на: комментарий от leg0las

ставить старый добрый i386. PAE в любом случае уже есть by default

Зачем? Можно поставить 64-бит ядро в 32-бит систему.

tailgunner ★★★★★ ()
Ответ на: комментарий от Deleted

А как же всякие там 3D? как же мой любимый скурим и данмер 38-го левела?:-))))

Можно поставить 64-бит ядро в 32-бит систему.

Тоже кстати вариант, но не без подводных камней.

leg0las ★★★★★ ()
Ответ на: комментарий от eugeno

Представляешь, у них все не нужно, кроме убунты. Я интересную вещь заметил, пользователи других дистрибутивов к убунте довольно спокойно относятся, кто поругивает без фанатизма, кто вообще использует вместе со своим. У «чистокровных» же убунтоидов, не видевших ничего другого лишь одно мнение - убунта на десктопы, убунта сервер на сервера, все остальное сжечь.

evilface ★★ ()
Ответ на: комментарий от leg0las

>А как же всякие там 3D?

Эээ… не знаю, я там только визуальные новеллы пускаю (^ ^)

Deleted ()
Ответ на: комментарий от Deleted

Виртуалка тоже хорошо, но вайн для таких вещей лучше.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Разводить помойку пакетов с двумя архитектурами как-то не хочется

Не, помойка — это ia32-libs, когда тебе скопом вытряхивают в /usr/lib32 кучу старых и толком не проверенных либ, при этом многих нужных там может попросту не быть =) Multiarch как раз является более элегантным и универсальным решением.

вдобавок года полтора-два назад ковырял ее - глючная была как по мне

За два года на Lenny amd64 и около года на Squeeze не припомню каких-либо архитектуро-специфичных багов %)

GotF ★★★★★ ()
Ответ на: комментарий от Reset

читать портянку из 6 глав? издеваешься ?

Раз в два года можно и почитать. По мне так лучше, чем каждый день читать выхлопы пакмана, или молиться при обновлениях бубунты.

eugeno ★★★★★ ()
Ответ на: комментарий от evilface

Я интересную вещь заметил, пользователи других дистрибутивов к убунте довольно спокойно относятся

Доооо.

GotF ★★★★★ ()
Ответ на: комментарий от evilface

Видел я убунтусервер. load average over 50%, а cat /etc/debian_version мне сказало «Squeeze/Sid» (тогда еще сквиз был тестингом). Я сказал «спасибо, но мы как-то обойдемся дебианом», на что вскоре и была заменена бубунта. Не знаю чего там было, может карма, может руки, но с дебианом резко пропал load average и прочие сопутствующие радости.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Вайн слишком любит запускать свои ручёнки куда не следует…

Deleted ()
Ответ на: комментарий от Reset

по stable тоже никто ничего не гарантирует

Зато он реально стабилен, только редхет/центось может сравниться. И разработчики рекомендуют использоваться именно stable, всё остальное на свой страх и риск. А то в народе укоренилось мнение, что stable только для серверов, а для десктопа как минимум тестинг, а потом плачут, что тестинг оказывается нестабилен.

eugeno ★★★★★ ()
Ответ на: комментарий от GotF

Мультиарч для вайна вытряхнул мне 56 или 58 пакетов из i386. Да, в ia32libs часто старое, забагованое, но оно в 99% случаев просто работает.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Не сделаешь export WINEDLLOVERRIDES=winemenubuilder.exe=d готовься к открытию текстовый файлов в вайновом блокноте прямо в самом линуксе. Открывает весь корень через букву диска, ставит связи между вендовыми хомяками и документами и линуксовыми…

По крайней мере отключается и то ладно. Но учитывая, что первое они считают фичей, то в адекватности разрабов у меня большие сомнения.

Deleted ()
Ответ на: комментарий от Deleted

Про то, что блокнот лезет куда не просят, мы в курсе. Отрубаю в меню кде - просто опускаю вниз или вообще удаляю из списка. На десктопе не критично.

leg0las ★★★★★ ()
Ответ на: комментарий от Deleted

WINEDLLOVERRIDES=winemenubuilder.exe=d

Если так сделать, оно перестанет пихать desktop-файлы в ~/.local/share/applications/?

GotF ★★★★★ ()
Ответ на: комментарий от leg0las

Лол. Наоборот, на десктопе это выглядит как одна большая дыра. Впрочем, как и в остальных местах. Ну и оно всё туда вбрасывает, все ассоциации. Будешь все ассоциации перелопачивать? Извращенец :}

Deleted ()
Ответ на: комментарий от GotF

Да. Только старые удалить руками надо. А потом «update-mime-database ~/.local/share/mime», конечно.

Deleted ()
Последнее исправление: Mystra_x64 (всего исправлений: 1)
Ответ на: комментарий от Deleted

Мерси. Удалять их я уже привык. Кстати, проблем с ассоциациями у меня почему-то никогда не было.

GotF ★★★★★ ()

Кстати про multiarch. При попытке поставить wine:i386 мне предложило снести скайп, который зависил от ia32libs. Мило.

Pavval ★★★★★ ()
Ответ на: комментарий от Deleted

Все равно не вижу проблемы, т.к. она решается в 2-3 клика. Немножко раздражает, да, но делается в один раз при настройке кед.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

2-3 клика × количество программ, ассоциирующих себя с файлами. Причём в любой момент после установки программы под вайном это количество может увеличиться. Зачем закрывать глаза, когда можно решить проблему? :}

Deleted ()
Ответ на: комментарий от Pavval

>который зависил от ia32libs

Это не «мило» это фича. ia32libs всё.

Deleted ()
Ответ на: комментарий от Deleted

брбрбр. При чем тут кол-во установленых прог? речь вроде про то, что notepad.exe из состава вайна «подменяет» нативные редакторы, так? ну вот он один раз удаляется из списка.

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Все программы, которые ассоциируют себя с типом файлов так вылазят, не только блокнот.

Deleted ()
Ответ на: комментарий от Deleted

Ну почему, мне например удобно двойным кликом в кде открывать файлы .h3m в редакторе карт для героев. Не?

leg0las ★★★★★ ()
Ответ на: комментарий от Deleted

Это не «мило» это фича. ia32libs всё.

Мне не легче. Имеем или скайп, или вайн.

Pavval ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.