LINUX.ORG.RU

КДЕ 3.5.10 в Slackware 14.1

 ,


0

2

Раз уж появился скриншот с GNOME 2.30 - то и я решил выложить результат своей «работы». Почему-то все нынешние Live-образы уже не лезут на 700Мб болванку, да и в память лишние сотни мегабайт заталкивать не всегда хочется. Вот и собрал в своё время КДЕ 3.5.10 - под Slackware 13.37 + куча всего пересобрано - работает. А вот под Slackware 14.0/14.1 - вылетает конк при попытке подключится по https. Пересобирать ещё раз - лень, покамест. Ещё из неприятного - падает kompare. В образ влезла Мозилла - но она на 156 мб в виртуалке совсем неповоротливая (с zram). Закатал на маленькую (1 Гб) флэшку, но с немного более старым ядром. Всё-таки нынешние hybrid iso/usb образы не очень удобны - по-быстрому закинуть пару модулей, а то и просто всякое файло на флэшку не выйдет.

Единственное, чем замечателен LiveCD - это самосборным 3.19 с патченой overlayfs (на тот момент в ней ещё не было поддержки нескольких «нижних» уровней - патчики вошли в 4.0). Ну и linux-live-scripts под это дело были немного похаканы.

Надо будет посмотреть, заработает ли на ноуте старый kdebluetooth - раньше работал, а потом я обновил пакет с bluez (до 4.100+), и всё.

>>> Просмотр (1024x768, 261 Kb)

★★

Проверено: JB ()

Слака+ третекеды+ патченное ядро 3.19. Люто плюсую.

kernelgood ()

Думаю, как лучше сказать про такой энтузиазм при работе с (полу)мёртвым DE некромагия или некрофилия? Нет, просто как эксперемент, это круто, Just4Fun. Но работать в этом, серьёзно?

pmedved ()

как-то все это тошнотно смотрится.

splinter ★★★★★ ()

Насилие над трупом в презервативе....

Odalist ★★★★★ ()
Ответ на: комментарий от Odalist

Выразил мои мысли даже лучше, чем сделал бы я сам, плюсую.

DeadEye ★★★★★ ()
Ответ на: комментарий от pmedved

Почему в третекедах нельзя работать? Чем они хуже какого-нибудь lxde?

fenris ★★★★★ ()
Ответ на: комментарий от yuran

Спасибо, а то после скриншота ТСа глаза потекли.

Deleted ()
Ответ на: комментарий от fenris

В том-то и дело, что КДЕ лучше, вот им и обидно, что ДЕ десятилетней давности уделывает все их «лёхкие» недоДЕ по всем фронтам - и по ресурсам и по функционалу и по красоте.

Deleted ()
Ответ на: комментарий от bormant

Оно, кстати, после правки ссылок на исключенные версии библиотек и в Slackware-current (14.1+) взлетает :-)
http://i.imgur.com/ORiMTHQ.png

Но, безусловно, что-то должно падать, надо смотреть, можно ли отрихтовать до приемлемого состояния :-)

bormant ★★★★★ ()
Ответ на: комментарий от bormant

У меня падал конк , если им пройтись по https ссылкам несколько раз.

После запатчивания вот этой пачкой

kdelibs-3.5-openssl-1.0.0.patch
kdelibs-3.5.10-cve-2009-1725.patch.gz
kdelibs-3.5.10-62_fix_googlemaps_backport.diff
kdelibs-3.5.10-cve-2009-2537-select-length.patch.gz
kdelibs-3.5.10-63_fixed-layout-table.diff
kdelibs-3.5.10-khtml.patch
kdelibs-3.5.10-CVE-2009-2702.patch.gz
kdelibs-3.5.10-kjs-gcc44.patch
kdelibs-3.5.10-CVE-2013-2074.patch
kdelibs-3.5.10-oCERT-2009-015-xmlhttprequest.patch.gz
kdelibs-3.5.10-assert.patch.gz
kdelibs-gcc44.patch
kdelibs-3.5.10-charset-1.patch
kdelibs_ark_xz_lmza_support.diff
kdelibs-3.5.10-cups.patch
kdelibs_gcc45.patch
kdelibs-3.5.10-cve-2009-1698.patch.gz
kdelibs_inotify.patch
Всё вроде работает. Патчи с....

http://ponce.cc/testing/alekow/kde-3.5_slackware-13.37_v.2/source/kde-3.5.10_... https://github.com/PhantomX/slackbuilds/tree/master/kde/kdelibs3/patches

Andrew-R ★★ ()
Ответ на: комментарий от Andrew-R

А вот найти работающий с таким старым браузером хостинг картинок сегодня - уже бОльшая проблема. Это http://i.imgur.com/KrF8Zqo.png с Мозиллы отправлено.

часть пакетов в -current уже i586. Всё равно конечно их можно пересобрать - пока ещё. Но думается lzma в пакетах, да udev с компанией - уже даже для чисто консольного варианта использования реальных 486-ых тяжеловаты. Тут ставили на 8 мб вроде как - но я сам так не пробовал.

http://www.linuxquestions.org/questions/slackware-14/bugs-setpartitions-and-r...

Fix:
 /etc/rc.d/rc.udev (both in /isolinux/initrd.img and installed, have not looked at the pxe one)
 insert after line 107
 /sbin/udevadm control --children-max=2
 
 With the later fix and a suitably slimmed kernel, slack14 can be made to both install and boot in 8MB 

это я себе на вооружение взял.

Andrew-R ★★ ()

Нафига тебе кеды, если тринити есть? Кеды старые бажные, там секурити баги никто не фиксит

Xenius ★★★★★ ()
Ответ на: комментарий от yuran

Если такое поставить офисному планктону и сказать, что это новый шиндовс 10, то вряд ли планктон поверит в легенду.

beka ()

Если бы не невероятный дизайн, то всё было бы ничего.

Tactile ★★ ()

добрый день, Andrew-R!

как обстоят дела с кде3? сам интересуютсь как установить / где найти сборку для slacware14.1 64x, либо KDE3 либо TDE

спасибо

п.с. можно в личке пообзаться? (почта или скайп, как тут в личку писать не нашел)

sunjob ()
Ответ на: комментарий от sunjob

Вот, пока скомпилировались по-новой части

https://cloud.mail.ru/public/JXT4/mfFJfdtLX - qt3 slackbuild, с сырцами 3.3.8.D из которых патчами выдрано несовместимое и ненужное мне изменение (class qsplitter). Отсюда, и ещё три следующих коммита откатил:

https://git.trinitydesktop.org/cgit/qt3/commit/src/widgets/qsplitter.h?id=f97... (Expose some QSplitter private classes for added functionality in Trinity) - из-за них komapre из kdesdk валился при старте, и хуже - валил проги, пытающиеся использовать его kpart!

https://cloud.mail.ru/public/JU7D/CwTFfN6kM - kdelibs slackbuild с сырцами, там аккуратнее с опциями - у меня под i486 настроено, prefix=/usr (а не /opt/kde3!) Для сборки на старой openssl (<1.0.0) патч kdelibs-3.5-openssl-1.0.0.patch убираем!

https://cloud.mail.ru/public/8dSj/RLp6BfJwq - kdebase slackbuild БЕЗ сырцов, но с некоторыми патчами из ALT'а.

https://cloud.mail.ru/public/AceD/ftGj6ckVN - kdegraphics slackbuild, без сырцов. Если не будет собираться, ругаясь на poppler (из него с версии 0.17 выкинули qt3 backend) - то либо отключить сборку с ним, либо временно собрать старый poppler.

Andrew-R ★★ ()
Ответ на: комментарий от Andrew-R

фига себе

добрый день!

только что увидел !!! НОВОСТЬ !!! безумно благодарен !!!

п.с. не хочу показаться врединой, slackware-14.4 - интересует x64-версия, заранее безумно благодарен, если что то в этом направлении сделаете (и я постараюсь тоже сам поразбираться, как будет времени побольше)

ну... блин, вы даете!!! :о) огромный ВАМ поклон

sunjob ()
Ответ на: фига себе от sunjob

### update ### я правильно понимаю, что это KDE3 а не TDE3?

sunjob ()
Ответ на: комментарий от sunjob

возможно, я не совсем правильно понимаю, но там пакетов выложено совсем «с гулькин нос»:

tqt3-3.5.13-x86_64-inpito.tgz
qt3-3.3.8.d-x86_64-inpito.tgz
tqtinterface-3.5.13-x86_64-inpito.tgz
arts-3.5.13-x86_64-inpito.tgz
dbus-tqt-3.5.13-x86_64-inpito.tgz
dbus-1-tqt-3.5.13-x86_64-inpito.tgz
libart_lgpl-2.3.21-x86_64-inpito.tgz
kdelibs-3.5.13-x86_64-inpito.tgz
kdebase-3.5.13-x86_64-inpito.tgz
gtk-qt-engine-3.5.13-x86_64-inpito.tgz

поправте, если что

sunjob ()
Ответ на: комментарий от sunjob

ну и уточнение по поводу этих самых пакетов (т.е. это не те самые пакеты, которые нам нужны :о) автор пишет:

I will also leave my old packages here for a short time, from my Slackware 13.37 build. I plan to take them down around January of 2016.

p.s. видимо надо собирать самому...

sunjob ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.