LINUX.ORG.RU

Веб сервер на арч

 


0

1

чую они что то изменили в конфигах, недавно только все работало, кониги все те же, сервер запущен подо мной, сайты лежат в хоум директории

2019/12/31 23:46:21 [error] 798#798: *6 FastCGI sent in stderr: «Primary script unknown» while reading response header from upstream, client: 127.0.0.1, server: admin, request: «GET /adminer.php?username=root HTTP/1.1», upstream: «fastcgi://unix:/run/php-fpm/php-fpm.sock:», host:

server { listen 80; server_name admin; root /home/56/websites/admin; index index.php index.html index.htm; charset utf-8;

    location / {
        try_files $uri $uri/ =404;
    }

    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   /usr/share/nginx/html;
    }

    location ~ \.php$ {
        #fastcgi_pass 127.0.0.1:9000; (depending on your php-fpm socket configuration)
        fastcgi_pass unix:/run/php-fpm/php-fpm.sock;
        #fastcgi_index index.php;
        include fastcgi.conf;
    }

}

если запустить пхп из консоли в папке сайта то все работает(php -S localhost:8080)

можно конечно изучить документацию но ведь новый год как никак

На сколько я понимаю, проблема одна из:
* /run/php-fpm/php-fpm.sock не найден, или не доступен для чтения
* говоришь, сервер запущен под твоим пользователем? В fastcgi.conf есть какие-то настройки связанные с пользователем/UID и там другой пользователь?

urxvt ★★★★★ ()
Последнее исправление: urxvt (всего исправлений: 1)
Ответ на: комментарий от urxvt

fastcgi.conf я совсем не трогал, некоторое время назад точно все работало, ну и если запускать php -S localhost:8080 то все работает

fdvscasffgbd1 ()
Ответ на: комментарий от fdvscasffgbd1

Ну не знаю. Но судя по SO проблема где-то в правах доступа или недоступном ресурсе.

fastcgi.conf ты, все таки, не показал.

urxvt ★★★★★ ()
Ответ на: комментарий от urxvt
fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;
fastcgi_param  QUERY_STRING       $query_string;
fastcgi_param  REQUEST_METHOD     $request_method;
fastcgi_param  CONTENT_TYPE       $content_type;
fastcgi_param  CONTENT_LENGTH     $content_length;

fastcgi_param  SCRIPT_NAME        $fastcgi_script_name;
fastcgi_param  REQUEST_URI        $request_uri;
fastcgi_param  DOCUMENT_URI       $document_uri;
fastcgi_param  DOCUMENT_ROOT      $document_root;
fastcgi_param  SERVER_PROTOCOL    $server_protocol;
fastcgi_param  REQUEST_SCHEME     $scheme;
fastcgi_param  HTTPS              $https if_not_empty;

fastcgi_param  GATEWAY_INTERFACE  CGI/1.1;
fastcgi_param  SERVER_SOFTWARE    nginx/$nginx_version;

fastcgi_param  REMOTE_ADDR        $remote_addr;
fastcgi_param  REMOTE_PORT        $remote_port;
fastcgi_param  SERVER_ADDR        $server_addr;
fastcgi_param  SERVER_PORT        $server_port;
fastcgi_param  SERVER_NAME        $server_name;

# PHP only, required if PHP was built with --enable-force-cgi-redirect
fastcgi_param  REDIRECT_STATUS    200;

fdvscasffgbd1 ()
Ответ на: комментарий от urxvt

раньше таким образом все работало, а вот недавно перестало, если запустить nginx и php-fpm из под пользователя http(по умолчанию) и положить php файлы в /usr/share/nginx/html/ то опять таки все работает

fdvscasffgbd1 ()
Ответ на: комментарий от fdvscasffgbd1

в nginx.conf добавлял конфиги под сайты и там же + в конфиге пхп фпм изменял пользователя, чтобы из под домашнего пользователя работало все

fdvscasffgbd1 ()

При таких настройках должно работать нормально на арче.

/etc/nginx/nginx.conf

# ...
user nginx nginx
# ...

/etc/php/php-fpm.d/example.com.conf

[example.com]
user = web
group = web
listen.owner = nginx
listen.group = nginx

ls -la /home/

drwxr-xr-x  3 root root 4096 Nov 27 14:13 .
drwxr-xr-x 16 root root 4096 Dec 29 12:49 ..
drwxr-xr-x  7 web  web  4096 Nov 27 14:14 sites

Суть думаю понятна. Вместо nginx и web пропишешь своих пользователей / группы.

Sorcus ()
Ответ на: комментарий от Sorcus

в nginx.conf я добавлял себя и группу users(как вы и писали)

в www.conf как вы и писали в двух местах добавлял опять же себя и группу

в папке home все папки и файлы были под моим пользователем

и все работало нормально(раньше, месяца 2 примерно назад, потом я все это забросил а система все обновлялся, под новый год запувтил локальный сервер и увидел проблему), я даже ставил заново всю систему и сравнивал свои старые конфиги с теми что по умолчанию(почти все точно также, изменения минимальны) и заново запускал их под своим аккаунтом(менял на свой пользователь, чтобы исключить то что я сам что то намудрил)

теперь вот не работает, работает только если запускать нгинкс и пхп фпм под пользователем http(по умолчанию) и когда сайт лежит в папке /usr/share/nginx/html/

что то где то чуть чуть не хватает, какое то разрешение и опять же добавлю если запускать из домашней папки при помощи php -S localhost:8080 то при обращении туда все работает

я не очень силен в сисадминстве и прочем но все было более или менее понятно и логично и все работало

fdvscasffgbd1 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.