LINUX.ORG.RU
ФорумTalks

VAAPI и проприетарный драйвер AMD Catalyst

 , ,


0

1

Вчера пытался прикрутить аппаратное ускорение видео. Почему-то не работает. Поставил mplayer-vaapi, vainfo, xvba-va-driver.

Наткнулся на багрепорт на ланчпаде, тыц

Пока ждём и смотрим.

Хотел спросить: у кого-то нормально работает аппаратное ускорение видео с видеокартами ATi/AMD? А то я не смог завести ни на десктопе ни на ноуте.

★★★★

Хотел спросить: у кого-то нормально работает аппаратное ускорение видео с видеокартами ATi/AMD?

Очень долго мучался, но ничего не получилось. А хотел просто драйвер видеокарты поставить.

dada ★★★★★ ()
Ответ на: комментарий от dada

Просто драйвер поставить недолго. В ubuntu в кои-то веки даже из *.run собрать недолго. А вот с аппаратным ускорением видео впервые сталкиваюсь (раньше не смотрел hd, и было всё равно).

BTW, почему в ubuntu/debian неосилили сделать нормальный пакетный менеджер, который мог бы ставить локальные пакеты с учётом и разрешением зависимостей?

Полученные после --buildpkg пакеты приходится ставить через sudo dpkg -i, но т.к. оно требует dkms и ещё что-то, то установка фейлится. После этого приходится запускать apt-get install -f, потом заново dpkg -i. Что это за мракобесие такое?

ekzotech ★★★★ ()
Ответ на: комментарий от ekzotech

BTW, почему в ubuntu/debian неосилили сделать нормальный пакетный менеджер, который мог бы ставить локальные пакеты с учётом и разрешением зависимостей?

Потому что нормальные люди ставят локальные пакеты из локального же репозитория. А для неосиляторов и любителей ставить что-то левое на месте придумали gdebi.

GotF ★★★★★ ()
Ответ на: комментарий от ekzotech

Так пробовали?

> Полученные после --buildpkg пакеты приходится ставить через sudo dpkg -i, но т.к. оно требует dkms и ещё что-то, то установка фейлится. После этого приходится запускать apt-get install -f, потом заново dpkg -i. Что это за мракобесие такое?
Во-первых есть же инструкция по установке, во-вторых в репозитории Ubuntu/Kubuntu лежит fglrx 8.96 в то время как на сайте fglrx 8.951 (релиз 8.96 для других дистрибутивов лишь завтра). Можно было поставить версию из репозитория, и не собирать пакеты.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от Deleted

Выдаёт в консоли (дословно не помню) что типа система слишком медленная, возможные причины: кривой драйвер видео, криво работает аудиосистема, низкая скорость считывания. Предлагает ставить кэш 8192, но это ситуацию не меняет.

Вообще это ноут, но на десктопе ситуация такая же. На ноуте хард 5400, вроде должен нормально воспроизводить. Там всего-то 100 метровый файл длительностью 43 секунды (проверяю работоспособность на нём). Всё равно грузит проц на 80-100%.

ekzotech ★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Так пробовали?

Дык я по этому же мануалу и делал. vlc воспроизводит hd видео рывками, с заиканиями. Но у меня сильное подозрение, что косяк либо в драйвере, либо ещё где-то (багрепорт на libva). Кому-то помогает создание символической ссылки, но мне не помогло. Или не туда сделал.

Хм, ок, я попробую поставить из репозитория. Решил потыкать пока кубунту 12.04, в ней ещё не ставил драйвер; тогда поставлю с реп.

ekzotech ★★★★ ()
Ответ на: комментарий от GotF

Потому что нормальные люди ставят локальные пакеты из локального же репозитория.

И на каждом компе поднимать локальный репозиторий? Что за бред? Хотя видимо юникс-вей.

ekzotech ★★★★ ()
Ответ на: комментарий от GateKeeper

Здесь пришел grammar nazi и наговорил ТСу много грубостей.

А, да, извиняюсь. Это я по запарке случайно.

ekzotech ★★★★ ()
Ответ на: комментарий от ekzotech

Мне на нетбуке тоже выдает, что медленная система, но рапортует, что vaapi успешно включено и 720p играет не заикаясь. Дай полный лог mplayer.

Deleted ()
Ответ на: комментарий от Deleted

Дай полный лог mplayer.

Сейчас не дам, ноутбук не с собой.

У меня vaapi не работает, грузит проц. А smplayer тупо вываливается с ошибкой.

ekzotech ★★★★ ()
Ответ на: комментарий от pekmop1024

Вроде народ заводил на нём vaapi. Вчера где-то натыкался, кажется.

ekzotech ★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Хм. Та не ничо, просто старым себя чувствую :)

ekzotech ★★★★ ()

Работает.
1080p на интегрированном в процессор e350

grim ★★☆☆ ()
libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so 
libva: va_openDriver() returns -1

У меня после очередного обновления было такое - данный фаил лежал в другом месте. Починил симлинком.

KillTheCat ★★★★★ ()
Ответ на: комментарий от KillTheCat
~$ file /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so
/usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so: symbolic link to `/usr/lib/va/drivers/fglrx_drv_video.so'
~$ vainfo 
libva: VA-API version 0.32.0
libva: User requested driver 'fglrx'
libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/fglrx_drv_video.so
libva: va_openDriver() returns 0
vainfo: VA-API version: 0.32 (libva 1.0.15)
vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8
vainfo: Supported profile and entrypoints
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD

KillTheCat ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Разве? С чего вы взяли?

В выборе видеовыходов нету vaapi. Или его там и не должно быть?

Ну и потом, на вики videolan.org написано, что надо собирать из гита с ключом vaapi, поэтому сомневаюсь, что таки в ubuntu оно включено по умолчанию.

ekzotech ★★★★ ()
Ответ на: комментарий от ekzotech

Его там не должно быть. VA-API включается соответствующей галкой в настроках кодеков VLC. VLC в Ubuntu с поддержкой VA-API как минимум со времён релиза 11.10.

RussianNeuroMancer ★★★★★ ()
Ответ на: комментарий от RussianNeuroMancer

Хм. Тогда я ошибся, да.

В любом случае, конкретно в данный момент VA-API у меня в убунте не работает.

P.S. А ведь до релиза осталась неделя.

ekzotech ★★★★ ()
Ответ на: комментарий от ekzotech

Ну то, что пишет mplayer при открытии файла с -vo vaapi.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.