LINUX.ORG.RU
решено ФорумTalks

[ дебианопроблеммы] iceweasel удалила сама себя при обновлении.


0

1

Как вы наверное знаете , недавно был релиз 9 фаерфокса.

В моём стабильном дебиане , с прикрученными бекпортами оно тоже решило обновиться.

Но из-за сломанных зависимостей iceweasel удалила себя .

При попытке установить заново :

iceweasel Зависит: xulrunner-9.0 но пакет не будет установлен : xulrunner-9.0:

Зависит: libnss3-1d (>=3.13.1) но 3.12.10-1~bpo60+1 установлен

Я правильно понимаю , 9 не встанет без этого пакета ? тащить его из тестинга или есть другие варианты?

iceweasel удалила сама себя при обновлении.

Новая версия радикально решает проблему с потреблением памяти.
//Извините, не удержался.

dogbert ★★★★★ ()

>Но из-за сломанных зависимостей iceweasel удалила себя .

Ты перед установкой не читаешь, что тебе аптитуда пишет?

Deleted ()

Зависит: libnss3-1d (>=3.13.1)

Тебя не смущает отсутствие суффикса «~bpo»? Возможно, какой-то чудак криво собрал пакет.

Я правильно понимаю , 9 не встанет без этого пакета ?

Да.

тащить его из тестинга или есть другие варианты?

Возможно, следует удалить 3.12.10-1~bpo60+1. Покажи aptitude versions libnss3-1d

GotF ★★★★★ ()

И сфига ты не смотрел, что будет удалено??? И не говори о «стабильном дебиане» в таких тредах, если ты туда ставишь backports. А то у рядового прохожего создастся мнение, что это у дебиана проблемы, а не у кого-то с руками.

Pavval ★★★★★ ()
Ответ на: комментарий от Deleted

Ты перед установкой не читаешь, что тебе аптитуда пишет?

Ты же знаешь, это модно — ныть, что aptitude криво работает, потому что не осиливают прочесть даже стандартные сообщения, не то что просмотреть варианты разрешения зависимостей.

GotF ★★★★★ ()
Ответ на: комментарий от Ubuntu1204LTS

Да тебе вообще вредно аптом пользоваться. Чистым dpkg только, и то я бы поостерёгся тееб его давать...

Xellos ★★★★★ ()

Дебианопроблемы.

AX ★★★★★ ()
Ответ на: комментарий от Ubuntu1204LTS

>experimental

Весло точно с бэкпортов? Не вижу в них никаких новых вёсел.

Пакет iceweasel
lenny (oldstable) (web): веб-браузер, основанный на Mozilla 
3.0.6-3: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc 
lenny-backports (web): веб-браузер, основанный на Firefox 
3.5.16-11~bpo50+1 [backports]: alpha amd64 i386 ia64 mips mipsel powerpc s390 sparc 
3.5.16-10~bpo50+1 [backports]: armel 
squeeze (stable) (web): веб-браузер, основанный на Firefox 
3.5.16-11 [security]: amd64 armel i386 ia64 kfreebsd-amd64 kfreebsd-i386 mipsel powerpc s390 sparc 
3.5.16-10: mips 
wheezy (testing) (web): Web browser based on Firefox 
8.0-3+b1: amd64 armel i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 sparc 
sid (unstable) (web): Web browser based on Firefox 
9.0.1-1: amd64 armel armhf i386 ia64 kfreebsd-amd64 kfreebsd-i386 mips mipsel powerpc s390 sparc 
7.0.1-4: hurd-i386 
3.5.19-2 [debports]: powerpcspe 
3.5.18-1: alpha hppa 
2.0.0.12-1 [debports]: m68k 
experimental (web): Web browser based on Firefox 
10.0~b1-2: amd64 armel i386 kfreebsd-amd64 kfreebsd-i386 sparc 
4.0-3: alpha
Deleted ()
Ответ на: комментарий от Deleted

P.S. Вообще подключать к стейблу экспериментал это моветон.

Deleted ()
Ответ на: комментарий от Ubuntu1204LTS

Это не официальные бэкпорты :)

Deleted ()
Ответ на: комментарий от Ubuntu1204LTS

Но криворукие пользователи, не читающие предупреждений пакетного менеджера при обновлении, все еще не официальная часть дебиана.

Deleted ()
Ответ на: комментарий от GotF

Впрочем, в бэкпортах косяки случаются, несмотря на весь из себя официальный статус.

GotF ★★★★★ ()
Ответ на: комментарий от Ubuntu1204LTS

Вывод — в m.d.o так собрали — пиши письма в спортлот^W тем, кто его там собирает, т.к. основной багтрекер этим вряд ли займётся :}

Deleted ()
Ответ на: комментарий от Deleted

Консольщина же. Удобнее же ткнуть установить обновления в менеджере и всё. Я в шоке от такой подставы . Два года на альфах и беттах убунты сидел - и то такого не встречал . Беда пришла откуда не ждали.

Ubuntu1204LTS ()
Ответ на: комментарий от Ubuntu1204LTS

Вот всегда предупреждает, а ты особенный, да? И, разумеется, пользоваться нужно aptitude, а не всякими там.

Deleted ()

iceweasel удалила сама себя при обновлении

Вот это сервис! В новом году перехожу на дебиан.

kranky ★★★★★ ()
Ответ на: комментарий от Ubuntu1204LTS

Тебе нужно -ты пользуйся , я не против .

Охлол. Напомни, кто ТС: ты или я?

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.