LINUX.ORG.RU
решено ФорумTalks

[libreoffice 3.4.3] [Gentoo] Попоболь


0

1

Здравствуй ЛОР. Подскажите пожалуйста что это еще за новости такие?

EM libreoffice-bin

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

[ebuild  N    ] app-text/libpaper-1.1.23 
[ebuild  N    ] sci-libs/ufconfig-3.5.0  USE="-static-libs" 
[ebuild  N    ] dev-util/boost-build-1.46.1  USE="-examples -python" 
[ebuild  N    ] app-text/poppler-data-0.4.4 
[ebuild     U ] media-libs/libpng-1.5.5 [1.4.8-r1] USE="apng -static-libs" 
[ebuild  N    ] app-text/libwpd-0.9.3  USE="tools -doc -test" 
[ebuild  N    ] media-libs/gstreamer-0.10.35  USE="nls -introspection -test" 
[ebuild  N    ] app-dicts/myspell-ru-20060316 
[ebuild  N    ] media-libs/raptor-2.0.4  USE="curl unicode xml -debug -json -static-libs" 
[ebuild  N    ] net-libs/neon-0.29.6  USE="nls zlib -doc -expat -gnutls -kerberos -libproxy -pkcs11 -ssl -static-libs" LINGUAS="ru -cs -de -fr -ja -nn -pl -tr -zh_CN" 
[ebuild  N    ] sys-libs/db-4.8.30  USE="-doc -examples -java -nocxx -tcl -test" 
[ebuild  N    ] media-gfx/graphite2-1.0.3  USE="-perl -test" 
[ebuild  N    ] net-nds/openldap-2.4.24  USE="minimal ssl tcpd -berkdb -crypt -cxx -debug -experimental -gnutls -icu -iodbc -ipv6 -kerberos -odbc -overlays -perl -samba -sasl (-selinux) -slp -smbkrb5passwd -syslog" 
[ebuild  N    ] dev-db/unixODBC-2.3.0-r1  USE="minimal -odbcmanual -static-libs" 
[ebuild  N    ] sci-libs/colamd-2.7.1  USE="-static-libs" 
[ebuild  N    ] app-dicts/myspell-en-20081002 
[ebuild  N    ] sci-libs/fftw-3.2.2  USE="openmp sse sse2 threads (-altivec) -doc -fortran" 
[ebuild  N    ] app-admin/eselect-boost-0.3 
[ebuild  N    ] sys-process/time-1.7-r1 
[ebuild  N    ] dev-lang/orc-0.4.11  USE="-examples -static-libs" 
[ebuild  N    ] app-text/iso-codes-3.24.2 
[ebuild  N    ] media-fonts/urw-fonts-2.4.9  USE="-X" 
[ebuild  N    ] app-admin/eselect-mesa-0.0.10 
[ebuild  N    ] x11-misc/makedepend-1.0.3 
[ebuild  N    ] x11-libs/libdrm-2.4.26  USE="libkms -static-libs" VIDEO_CARDS="-intel -nouveau -radeon -vmware" 
[ebuild  N    ] app-text/hunspell-1.3.2-r1  USE="nls readline -ncurses -static-libs" LINGUAS="ru -af -bg -ca -cs -cy -da -de -el -en -eo -es -et -fo -fr -ga -gl -he -hr -hu -ia -id -it -ku -lt -lv -mk -ms -nb -nl -nn -pl -pt -ro -sk -sl -sv -sw -tn -uk -zu" 
[ebuild  N    ] media-libs/gst-plugins-base-0.10.35  USE="nls orc -introspection" 
[ebuild  N    ] app-text/libwps-0.2.3  USE="-debug -doc -static-libs" 
[ebuild  N    ] sci-mathematics/lpsolve-5.5.2.0  USE="-static-libs" 
[ebuild  N    ] app-text/libwpg-0.2.1  USE="-doc -static-libs" 
[ebuild  N    ] dev-libs/rasqal-0.9.27  USE="gmp mhash pcre -crypt -doc -static-libs -test -xml" 
[ebuild  N    ] sci-libs/hdf5-1.8.4-r1  USE="cxx threads zlib -examples -fortran -mpi -szip" 
[ebuild  N    ] dev-libs/boost-1.46.1-r1  USE="icu -debug -doc -eselect -mpi -python -static-libs -test -tools" 
[ebuild   R   ] app-text/poppler-0.16.7  USE="cairo cxx jpeg png utils* xpdf-headers -cjk -curl -debug -doc -exceptions -introspection -jpeg2k -lcms -qt4" 
[ebuild  N    ] media-libs/mesa-7.11  USE="classic egl nptl shared-glapi -bindist -debug -gallium -gbm -gles -llvm -motif -openvg -pax_kernel -pic (-selinux) -shared-dricore" VIDEO_CARDS="-intel -mach64 -mga -nouveau -r128 -radeon -savage -sis -tdfx -via -vmware" 
[ebuild  N    ] app-text/mythes-1.2.1  USE="-static-libs" 
[ebuild  N    ] media-libs/vigra-1.7.1-r1  USE="fftw hdf5 jpeg png tiff -doc -python -test" 
[ebuild  N    ] dev-libs/redland-1.0.14  USE="sqlite ssl xml -berkdb -iodbc -mysql -odbc -postgres -static-libs" 
[ebuild  N    ] dev-libs/hyphen-2.7.1 
[ebuild  N    ] virtual/opengl-7.0 
[ebuild  N    ] net-print/cups-1.4.8-r1  USE="jpeg png ssl threads -X -acl -dbus -debug -gnutls -java -kerberos -ldap -pam -perl -php -python -samba -slp -static-libs -tiff -xinetd" LINGUAS="ru -da -de -es -eu -fi -fr -id -it -ja -ko -nl -no -pl -pt -pt_BR -sv -zh -zh_TW" 
[ebuild  N    ] app-text/ghostscript-gpl-9.04-r4  USE="cups -X -bindist -dbus -djvu -gtk -idn -jpeg2k -static-libs" LINGUAS="-ja -ko -zh_CN -zh_TW" 
[ebuild     U ] app-office/libreoffice-bin-3.4.3.2-r1 [3.3.4] USE="(-aqua) -gnome -java -kde% (-kdeenablefinal) (-offlinehelp%)" LINGUAS="(-af%) (-ar%) (-as%) (-ast%) (-be_BY%) (-bg%) (-bn%) (-bo%) (-br%) (-brx%) (-bs%) (-ca%) (-ca_XV%) (-cs%) (-cy%) (-da%) (-de%) (-dgo%) (-dz%) (-el%) (-en%) (-en_GB%) (-en_ZA%) (-eo%) (-es%) (-et%) (-eu%) (-fa%) (-fi%) (-fr%) (-ga%) (-gl%) (-gu%) (-he%) (-hi%) (-hr%) (-hu%) (-id%) (-is%) (-it%) (-ja%) (-ka%) (-kk%) (-km%) (-kn%) (-ko%) (-kok%) (-ks%) (-ku%) (-lo%) (-lt%) (-lv%) (-mai%) (-mk%) (-ml%) (-mn%) (-mni%) (-mr%) (-my%) (-nb%) (-ne%) (-nl%) (-nn%) (-nr%) (-ns%) (-oc%) (-om%) (-or%) (-pa_IN%) (-pl%) (-pt%) (-pt_BR%) (-ro%) (-ru%*) (-rw%) (-sa_IN%) (-sat%) (-sd%) (-sh%) (-si%) (-sk%) (-sl%) (-sq%) (-sr%) (-ss%) (-st%) (-sv%) (-sw_TZ%) (-ta%) (-te%) (-tg%) (-th%) (-tn%) (-tr%) (-ts%) (-ug%) (-uk%) (-uz%) (-ve%) (-vi%) (-xh%) (-zh_CN%) (-zh_TW%) (-zu%)" 
[ebuild  N    ] app-office/libreoffice-l10n-3.4.3-r3 

Откуда вдруг столько новых зависимостей взялось? Что то глобально новое появилось или что?

Совсем нет желания конпелять весь этот хлам.

>Совсем нет желания конпелять весь этот хлам

Компиляет компилятор. А ты, как и другие гентушники, должен в это время тянуть блондинок.

Heretique ()
Ответ на: комментарий от Ghostwolf

Просто до 3.4.3 стояла 3.3.4 и ничего этого не просило если ставить бинарную либру. Что вдруг поменялось?

partyzan ★★★ ()

[ebuild U ] media-libs/libpng-1.5.5 [1.4.8-r1] USE=«apng -static-libs»

сперва с ентим libpng разберитесь, возможно придется больше хлама конпелять чем вы предполагаете

hizel ★★★★★ ()
Ответ на: комментарий от partyzan

Что, 1.5.x не совместим уже и с 1.4.x? Да, libpng-шники большие любители поломать все.

buddhist ★★★★★ ()
Ответ на: комментарий от partyzan

УМВР без symlinks

hizel@wnight:~/dev/lorsource$ qlist -Iv | grep png
media-libs/libpng-1.5.5
hizel@wnight:~/dev/lorsource$ qlist -Iv | grep office
app-office/libreoffice-3.4.3.2-r1
app-office/libreoffice-l10n-3.4.3-r3
hizel@wnight:~/dev/lorsource$ 

и да, почему этот топик в talks?

hizel ★★★★★ ()

таковы требования блоба
из сорсов меньше просит
но капс в любом случае тянет
и что-то с явой связанное

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

покажи лучше qlist libpng

qlist libpng
/usr/include/libpng14/pngconf.h
/usr/include/libpng14/png.h
/usr/share/doc/libpng-1.4.8-r1/ANNOUNCE.bz2
/usr/share/doc/libpng-1.4.8-r1/CHANGES.bz2
/usr/share/doc/libpng-1.4.8-r1/README.bz2
/usr/share/doc/libpng-1.4.8-r1/TODO.bz2
/usr/share/doc/libpng-1.4.8-r1/libpng-1.4.8.txt.bz2
/usr/share/man/man5/png.5.bz2
/usr/share/man/man3/libpng.3.bz2
/usr/share/man/man3/libpngpf.3.bz2
/usr/bin/libpng14-config
/usr/lib64/libpng14.so.14.8.0
/usr/lib64/libpng14.so
/usr/lib64/pkgconfig/libpng14.pc
/usr/lib64/libpng14.so.14
/usr/include/pngconf.h
/usr/include/png.h
/usr/bin/libpng-config
/usr/lib64/libpng.so
/usr/lib64/pkgconfig/libpng.pc
partyzan ★★★ ()
Ответ на: комментарий от megabaks

revdep-rebuild -i — -avD

обсуждалось же миллион раз

Не знаю, я делал revdep, но хромой 10-й версии и что то еще отказалось собираться и запускаться после libpng15.

partyzan ★★★ ()
Ответ на: комментарий от partyzan

у тебя 14-я стоит
это я знаю
при установке 15-ой должна таки остаться 14-я либа одна
так что врядли что сломается

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>и 10-ый хромой - это жуткая некрофилия

Знаю, но новые версии еще хуже некрофилии. Пойду пересобирать libpng и firefox.

А зачем либре libdrm, mesa и прочие пакеты? Видать либру сделали одним большим куском без возможности что то выкинуть если ставить бинарную версию.

partyzan ★★★ ()
Ответ на: комментарий от partyzan

>А зачем либре libdrm, mesa и прочие пакеты?
это не ему надо

megabaks ★★★★ ()
Ответ на: комментарий от megabaks

>совсем того? о_О 17.0.917.0 - всё нормально

Мы уже как то с тобой обсуждали это. Не думаю что снова нужно обсуждать это придя опять к непониманию. Новые версии хромого жрут много памяти, тормозят и вообще его можно уже закапывать, он свое отжил. Так попсовое увлечение прошло и он стал ненужен.

//Я не троль, это мое личное мнение. И оно естественно различается с твоим и мнениями других.

partyzan ★★★ ()
Ответ на: комментарий от partyzan

> Новые версии хромого жрут много памяти, тормозят

Новые версии хромого жрут много памяти, поэтому не тормозят


fixed

stevejobs ★★★★☆ ()
Ответ на: комментарий от partyzan

>Новые версии хромого жрут много памяти, тормозят
4.2
с памятью как и раньше
тормозов нет

megabaks ★★★★ ()
Ответ на: комментарий от partyzan

Не за что. Я сам сначала ох..л, потом погуглил в багзилле и всё понял. После этого кстати сам размер либры на винте гораздо меньше стал занимать:

-rw-r--r--  6 root root 104M Окт 20 17:42 libreoffice-bin-3.4.3.2-r1.tbz2
-rw-r--r--  9 root root 149M Окт 13 13:30 libreoffice-bin-3.4.3-r2.tbz2

xorik ★★★★★ ()

Это обычное поведение Gentoo. Однажды я решил пересобрать программу, которая у меня уже была. И она тоже потянула с собой кучу зависимостей в виде новых библиотек, хотя эта программа уже была установлена и работала.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от partyzan

На форуме генты и eselect news list инструкция по обновлению.

mkam ()
Ответ на: комментарий от megabaks

не надо мне врать - я сам это проходил

Скажи это лучше deadbeef. Он забыл посоветоваться с тобой и при пересборке вываливает

/x86_64-pc-linux-gnu/bin/ld: cannot find -lpng14

А все остальное нормально пересобирается.

partyzan ★★★ ()
Ответ на: комментарий от partyzan

у меня прямо сейчас работает говядина
в системе только 15
ЧЯДНТ?
повторить про revdep-rebuild -i ?
или заставить прочитать про снос либы?
или напомнить про то, что 14-я останется при обновке до 15?

megabaks ★★★★ ()

echo '=app-office/libreoffice-bin-3.4.3.2-r1' >> /etc/portage/package.mask
А в новой версии может пофиксят.

ymuv ★★★★ ()
Ответ на: комментарий от ymuv

Я замаскировал, когда оно у меня CUPS потянуло

Вот и я посидел подумал, и не увидев юза -cups решил, что все же я не такой мегаоффисманагер и мне вполне сойдет функционал абиворда. Либру выпилил, не столько за cups сколько за ненужностью.

partyzan ★★★ ()
Ответ на: комментарий от partyzan

А как абиворд работает с файлами .docx и с картинками в их? Просто обязательно найдется умник, который пришлет .docx. А в либре пол-года назад были проблемы, типа картинки/текст съезжают. А при сохранении в .doc наблюдалось тоже самое. (понял только тогда, когда понес на распечатку.)

ymuv ★★★★ ()
Ответ на: комментарий от partyzan

Извиняюсь, может и открывает у меня абиворд libpng15 поломан просто и вообще ничего не открывает ;)

partyzan ★★★ ()

ухты ёлки. ну и bloatware

thunar ★★★★★ ()
Ответ на: комментарий от partyzan

> libreoffice-bin

проверь на сырцовой либре

x0r ★★★★★ ()
Ответ на: комментарий от megabaks

Все стало в королевстве хорошо после того как воспользовался гайлом по миграции на libpng15.

find /usr/ -name '*.la' -exec grep png14 {} +

Удалил все найденные .la и все нормально собралось.

partyzan ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.