LINUX.ORG.RU

Что-то хочет установить мне gsettings-desktop-schemas-3.4.2

 


0

0

Купил в Steam игру Terraria, чтобы играть в нативную Linux-версию. Устанавливаю в Gentoo mono. Как называется пакет искать лень, пишу чтобы установил tomboy: эта программа на mono, и наверняка установит не только сам mono, но и кучу плагинов, которые может попросить и игра.

Calculating dependencies... done!
[ebuild  N     ] dev-libs/gobject-introspection-common-1.32.1  1,095 kB
[ebuild  N     ] dev-libs/nettle-2.5  USE="gmp" 1,088 kB
[ebuild     U  ] dev-libs/glib-2.32.4-r1 [2.28.8] USE="xattr -debug -doc (-fam) (-selinux) -static-libs* -systemtap% -test -utils% (-introspection%)" 6,043 kB
[ebuild     U  ] dev-util/pkgconfig-0.27.1 [0.26] USE="-hardened -internal-glib%" 1,864 kB
[ebuild  N     ] gnome-base/libbonobo-2.24.3  USE="-debug -doc -examples -test" 1,324 kB
[ebuild     U  ] net-libs/gnutls-2.12.20 [2.10.5] USE="cxx lzo nettle%* nls zlib -bindist -doc -examples -guile -pkcs11% -static-libs% -test" 7,062 kB
[ebuild  N     ] gnome-base/gnome-mime-data-2.18.0  USE="-debug" 593 kB
[ebuild  N     ] app-text/enchant-1.6.0  USE="aspell hunspell -static-libs -zemberek" 593 kB
[ebuild  N     ] app-text/gtkspell-2.0.16  USE="-doc" 344 kB
[ebuild     U  ] dev-libs/gobject-introspection-1.32.1 [0.10.8] USE="-doc -doctool% -test" 0 kB
[blocks b      ] <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)
[ebuild  N     ] gnome-base/gsettings-desktop-schemas-3.4.2  USE="introspection" 194 kB
[ebuild  N     ] dev-dotnet/libgdiplus-2.10.9  USE="cairo" 2,026 kB
[ebuild  N     ] dev-lang/mono-2.11.4  USE="-minimal -pax_kernel -xen" 40,351 kB
[ebuild  N     ] gnome-base/libgnomecanvas-2.30.3  USE="-doc -glade -test" 561 kB
[ebuild  N     ] dev-dotnet/gtk-sharp-gapi-2.12.10  USE="-debug" 1,601 kB
[ebuild  N     ] dev-dotnet/glib-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ] dev-dotnet/dbus-sharp-0.7.0-r1  125 kB
[ebuild  N     ] dev-dotnet/pango-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ] dev-dotnet/atk-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ] dev-dotnet/dbus-sharp-glib-0.5.0  94 kB
[ebuild  N     ] dev-dotnet/gdk-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ] dev-dotnet/gtk-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ] dev-dotnet/art-sharp-2.24.2  USE="-debug" 412 kB
[ebuild  N     ] dev-dotnet/mono-addins-0.6.2  USE="gtk" 330 kB
[ebuild  N     ] dev-dotnet/glade-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ] gnome-base/gnome-vfs-2.24.4-r1  USE="acl avahi ipv6 samba ssl -doc -fam -gnutls -kerberos -test" 1,847 kB
[ebuild  N     ] dev-dotnet/gnomevfs-sharp-2.24.2  USE="-debug" 0 kB
[ebuild  N     ] net-libs/libproxy-0.4.7  USE="networkmanager perl python -gnome -kde -mono -test" 89 kB
[ebuild  N     ] net-libs/glib-networking-2.32.3  USE="gnome libproxy ssl -smartcard -test" 325 kB
[ebuild     U  ] net-libs/libsoup-2.38.1 [2.32.2] USE="introspection* samba%* ssl -debug -doc -test" 607 kB
[ebuild  N     ] net-libs/libsoup-gnome-2.38.1  USE="introspection -debug -doc" 0 kB
[ebuild  N     ] gnome-base/gvfs-1.12.3-r1  USE="avahi bluetooth bluray cdda fuse http samba udev -afp -archive -doc -gdu -gnome-keyring -gphoto2 -ios -udisks" 1,332 kB
[ebuild  N     ] gnome-base/libgnome-2.32.1-r1  USE="-branding -debug -doc" 1,735 kB
[ebuild  N     ] gnome-base/libbonoboui-2.24.5  USE="-doc -examples -test" 954 kB
[ebuild  N     ] gnome-base/libgnomeui-2.24.5  USE="-doc -test" 1,407 kB
[ebuild  N     ] dev-dotnet/gnome-sharp-2.24.2  USE="-debug" 0 kB
[ebuild  N     ] dev-dotnet/gconf-sharp-2.24.2  USE="-debug" 0 kB
[ebuild  N     ] app-misc/tomboy-1.12.0  USE="-eds -test" 6,474 kB

Total: 38 packages (5 upgrades, 33 new), Size of downloads: 80,457 kB
Conflict: 1 block

Would you like to merge these packages? [Yes/No]

Отлично, все Gnome-зависимости от второго GNOME. (Кстати, где указывать в Gentoo, какая версия GNOME мне нужна?) Кроме:

[ebuild  N     ] gnome-base/gsettings-desktop-schemas-3.4.2  USE="introspection" 194 kB

Что это такое? Ещё не знаю. Открываю Changelog:

16 Oct 2011; Kacper Kowalik <xarthisius@gentoo.org>
gsettings-desktop-schemas-3.0.1.ebuild:
ppc/ppc64 stable wrt #385699

14 Oct 2011; Samuli Suominen <ssuominen@gentoo.org>
gsettings-desktop-schemas-3.0.1.ebuild:
amd64 stable wrt #385699

17 Aug 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
gsettings-desktop-schemas-3.0.1.ebuild:
keyword ~sparc-solaris

*gsettings-desktop-schemas-3.0.1 (14 Aug 2011)

14 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+gsettings-desktop-schemas-3.0.1.ebuild:
Bump to 3.0.1, from gnome overlay for GNOME 3

22 Mar 2011; Brent Baude <ranger@gentoo.org>
gsettings-desktop-schemas-0.1.1.ebuild:
Marking gsettings-desktop-schemas-0.1.1 ppc stable for bug 353436

21 Mar 2011; Kacper Kowalik <xarthisius@gentoo.org>
gsettings-desktop-schemas-0.1.1.ebuild:
ppc64 stable wrt #353436

12 Mar 2011; Raúl Porcel <armin76@gentoo.org>
gsettings-desktop-schemas-0.1.1.ebuild:
alpha/arm/ia64/sh/sparc stable wrt #353436

А вот компонентов GNOME 3 мне в системе не надо: я уже насмотрелся на это DE в бинарном дистрибутиве. У меня вопрос, какая из перечисленных для установки программ хочет gsettings-desktop-schemas? Как запретить его устанавливать?

Укажите ключик '-t' для emerge - увидите.

И да, 'man emerge' полезен.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kostik87
Calculating dependencies... done!
[ebuild  N     ] app-misc/tomboy-1.12.0  USE="-eds -test" 6,474 kB
[ebuild  N     ]  dev-dotnet/gconf-sharp-2.24.2  USE="-debug" 412 kB
[ebuild  N     ]   dev-dotnet/gnome-sharp-2.24.2  USE="-debug" 0 kB
[ebuild  N     ]    gnome-base/libgnomeui-2.24.5  USE="-doc -test" 1,407 kB
[ebuild  N     ]     gnome-base/libbonoboui-2.24.5  USE="-doc -examples -test" 954 kB
[ebuild  N     ]      gnome-base/libgnome-2.32.1-r1  USE="-branding -debug -doc" 1,735 kB
[ebuild  N     ]       gnome-base/gvfs-1.12.3-r1  USE="avahi bluetooth bluray cdda fuse http samba udev -afp -archive -doc -gdu -gnome-keyring -gphoto2 -ios -udisks" 1,332 kB
[ebuild  N     ]        net-libs/libsoup-gnome-2.38.1  USE="introspection -debug -doc" 607 kB
[ebuild     U  ]         net-libs/libsoup-2.38.1 [2.32.2] USE="introspection* samba%* ssl -debug -doc -test" 0 kB
[ebuild  N     ]          net-libs/glib-networking-2.32.3  USE="gnome libproxy ssl -smartcard -test" 325 kB
[ebuild  N     ]           net-libs/libproxy-0.4.7  USE="networkmanager perl python -gnome -kde -mono -test" 89 kB
[ebuild  N     ]    dev-dotnet/gnomevfs-sharp-2.24.2  USE="-debug" 0 kB
[ebuild  N     ]     gnome-base/gnome-vfs-2.24.4-r1  USE="acl avahi ipv6 samba ssl -doc -fam -gnutls -kerberos -test" 1,847 kB
[ebuild  N     ]   dev-dotnet/glade-sharp-2.12.10  USE="-debug" 1,601 kB
[ebuild  N     ]  dev-dotnet/mono-addins-0.6.2  USE="gtk" 330 kB
[ebuild  N     ]  dev-dotnet/dbus-sharp-glib-0.5.0  94 kB
[nomerge       ] dev-dotnet/gnome-sharp-2.24.2  USE="-debug"
[ebuild  N     ]  dev-dotnet/art-sharp-2.24.2  USE="-debug" 0 kB
[ebuild  N     ]   dev-dotnet/gtk-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ]    dev-dotnet/gdk-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ]    dev-dotnet/atk-sharp-2.12.10  USE="-debug" 0 kB
[nomerge       ] dev-dotnet/dbus-sharp-glib-0.5.0
[ebuild  N     ]  dev-dotnet/dbus-sharp-0.7.0-r1  125 kB
[nomerge       ] dev-dotnet/glade-sharp-2.12.10  USE="-debug"
[nomerge       ]  dev-dotnet/gdk-sharp-2.12.10  USE="-debug"
[ebuild  N     ]   dev-dotnet/pango-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ]    dev-dotnet/glib-sharp-2.12.10  USE="-debug" 0 kB
[ebuild  N     ]    dev-dotnet/gtk-sharp-gapi-2.12.10  USE="-debug" 0 kB
[ebuild  N     ]     dev-lang/mono-2.11.4  USE="-minimal -pax_kernel -xen" 40,351 kB
[ebuild  N     ]      dev-dotnet/libgdiplus-2.10.9  USE="cairo" 2,026 kB
[nomerge       ] gnome-base/libbonoboui-2.24.5  USE="-doc -examples -test"
[ebuild  N     ]  gnome-base/libgnomecanvas-2.30.3  USE="-doc -glade -test" 561 kB
[nomerge       ] net-libs/glib-networking-2.32.3  USE="gnome libproxy ssl -smartcard -test"
[ebuild  N     ]  gnome-base/gsettings-desktop-schemas-3.4.2  USE="introspection" 194 kB
[nomerge       ] sys-fs/cryptsetup-1.2.0-r1  USE="nls static (-selinux)"
[nomerge       ]  sys-fs/udev-171-r1  USE="acl extras rule_generator -action_modeswitch -build -debug -edd -floppy -gudev -hwdb -introspection -keymap (-selinux) -test"
[nomerge       ]   dev-libs/gobject-introspection-1.32.1 [0.10.8] USE="-doc -doctool% -test"
[nomerge       ]    dev-libs/gobject-introspection-common-1.32.1
[blocks b      ]     <dev-libs/gobject-introspection-1.32.0 ("<dev-libs/gobject-introspection-1.32.0" is blocking dev-libs/gobject-introspection-common-1.32.1)
[ebuild     U  ]      dev-libs/gobject-introspection-1.32.1 [0.10.8] USE="-doc -doctool% -test" 1,095 kB
[nomerge       ] gnome-base/libbonoboui-2.24.5  USE="-doc -examples -test"
[ebuild  N     ]  gnome-base/libbonobo-2.24.3  USE="-debug -doc -examples -test" 1,324 kB
[nomerge       ] app-misc/tomboy-1.12.0  USE="-eds -test"
[ebuild  N     ]  app-text/gtkspell-2.0.16  USE="-doc" 344 kB
[ebuild  N     ]   app-text/enchant-1.6.0  USE="aspell hunspell -static-libs -zemberek" 593 kB
[nomerge       ] gnome-base/libgnomeui-2.24.5  USE="-doc -test"
[nomerge       ]  gnome-base/gnome-vfs-2.24.4-r1  USE="acl avahi ipv6 samba ssl -doc -fam -gnutls -kerberos -test"
[ebuild  N     ]   gnome-base/gnome-mime-data-2.18.0  USE="-debug" 593 kB
[nomerge       ] net-ftp/filezilla-3.3.5.1  USE="dbus nls -test"
[ebuild     U  ]  net-libs/gnutls-2.12.20 [2.10.5] USE="cxx lzo nettle%* nls zlib -bindist -doc -examples -guile -pkcs11% -static-libs% -test" 7,062 kB
[nomerge       ] gnome-base/libgnomeui-2.24.5  USE="-doc -test"
[nomerge       ]  gnome-base/libgnome-2.32.1-r1  USE="-branding -debug -doc"
[nomerge       ]   gnome-base/gnome-vfs-2.24.4-r1  USE="acl avahi ipv6 samba ssl -doc -fam -gnutls -kerberos -test"
[nomerge       ]    virtual/pkgconfig-0
[ebuild     U  ]     dev-util/pkgconfig-0.27.1 [0.26] USE="-hardened -internal-glib%" 1,864 kB
[ebuild     U  ]      dev-libs/glib-2.32.4-r1 [2.28.8] USE="xattr -debug -doc (-fam) (-selinux) -static-libs* -systemtap% -test -utils% (-introspection%)" 6,043 kB
[nomerge       ] sys-fs/ntfsprogs-2.0.0-r3  USE="crypt fuse -debug -gnome -minimal"
[nomerge       ]  net-libs/gnutls-2.12.20 [2.10.5] USE="cxx lzo nettle%* nls zlib -bindist -doc -examples -guile -pkcs11% -static-libs% -test"
[ebuild  N     ]   dev-libs/nettle-2.5  USE="gmp" 1,088 kB
[ebuild  N     ] dev-libs/gobject-introspection-common-1.32.1  0 kB

Total: 38 packages (5 upgrades, 33 new), Size of downloads: 80,457 kB
Conflict: 1 block

Would you like to merge these packages? [Yes/No]

Надеюсь, здесь форматирование не поехало? Спасибо за ключ. Похоже, ничто не зависит от этой программы, это всего лишь бонус к glib-networking-2.32.3. Как думаешь, устанавливать? GTK3 не будет юзать?

ZenitharChampion ★★★★★ ()

Как называется пакет искать лень, пишу чтобы установил tomboy: эта программа на mono, и наверняка установит не только сам mono, но и кучу плагинов
Gentoo

Отличный выбор!

f1xmAn ★★★★★ ()
Ответ на: комментарий от kostik87

Ещё вопрос. Я так давно не обновлял систему, что она настроена на использование HAL. А так как в марте 2011 года HAL везде убрали, я откатывал коммиты отсюда и теперь мне придётся снова сделать это для gvfs. Не подскажешь, как проще всего перейти на udev и удалить HAL?

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от ZenitharChampion

ставь сразу systemd — они с удевом уже благополучно слились в экстазе. хал после этого сноси нафиг — он не нужен, считай.

AGUtilities ★★★ ()
Ответ на: комментарий от AGUtilities

Не, systemd мне не нужен. У меня нет ни его, ни PulseAudio. Предлагаешь просто удалить HAL, и система сама перестроится на использование Udisks и Udev?

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Собери без hal то что было собрано с ним.

Xenesz ★★★★ ()
Ответ на: комментарий от ZenitharChampion

нет не перенастроится. как сказали уже, нужно пересобирать без hal.

udev уже с марта в составе systemd — не отвертишся.

AGUtilities ★★★ ()
Ответ на: комментарий от AGUtilities

Евгений Додонов (который погиб в автокатастрофе) написал статью, в которой говорится следующее. PulseAudio можно отключить, не удаляя, но если вам ненавистен Леннарт Поттеринг и его поделия, эта статья поможет вам удалить поделия Леннарта Поттеринга начисто. http://dodonov.net/blog/2011/07/22/on-exorcisms-and-other-fun-specially-for-o... Мне очень повезло, что на компьютере, где хрипел звук, как раз установлена Mageia, а статья на примере Mandriva. Поэтому я смог проделать все эти команды и не просто отключить PulseAudio, а удалить. Подробнее о проблеме.

Дополнено: отправил и забыл дописать, зачем отправил. Там и про удаление Systemd есть, а не только про одну программу.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от Black_Shadow

Но никто же не возьмётся... Вон оверлей с KDE3 как был скопирован из старого portage, так и лежит в неизменном виде. И только если ломается компиляция кладут патчи. В то время как KDE:KDE3 в openSUSE полностью юзабелен, без HAL причём, а для остальных дистрибутивов Linux не менее юзабелен Trinity DE.

В данный момент ищу оверлей с HAL для Gentoo/FreeBSD. Я устал добавлять удалённые строчки для USE-флага HAL в новые версии ПО.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от ZenitharChampion

Я, кстати, во время выпиливания HAL'а просто сделал emerge -uvDNa @system @world, и у меня ничего не отвалилось.

Black_Shadow ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

вынужден признать что ты упрт. продолжать лезть через ухо даже когда ты узнал что метапакет для mono называется mono..

Thero ★★★★★ ()
Ответ на: комментарий от AGUtilities

распространяется да, и патчи позволяющие раздельную сборку не принимают, но не смотря на это можно иметь систему с udev, но без systemd, причём в генте это может любой знающий командный интерейс emerge.

qnikst ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

если ты ничего специального с завязкой на хал не делал (настройки каких-либо хитрых программ), то достаточно убрать хал из юзов, и пересобрать мир.

qnikst ★★★★★ ()
Ответ на: комментарий от Thero

> вынужден признать что ты упрт.

Луркосленг не нужен, а само мухоморье - руководство начинающего кулхацкера.

> продолжать лезть через ухо даже когда ты узнал что метапакет для mono называется mono..

Я уже установил всё, что предлагалось, поиграл и отписался в другой теме, что в нативной Terraria не работает звук.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от qnikst

Например k3b 1.05 не заработает без HAL, и Kpowersave. А кроме KDE 3 других DE На моём компьютере не установлено.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Да, перед этим ещё и пропатчил Wine, потому что Steam под Wine перестал запускаться после обновления. В версии 1.5.15 будет исправление.

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.