LINUX.ORG.RU
ФорумTalks

CentOS 7x old ?

 


0

1

Наверное правильнее было писать в админ или девелоп, но вроде это затрагивает всех.

Тут на другом ресурсе написали что вышли предварительные образы CentOS 9 Stream …

В обсуждении прочитал что софт CentOS очень старый и т.д. Мне вот стало интересно про какой софт идет речь ?

P.S. ну может ядро 5.12 и тянет какое новое редкое оборудование которое ядро из CentOS 7x не тянет, но я хз про это оборудование и потом все таки хотелось бы услышать за софт.

★★★★★

Мне вот стало интересно про какой софт идет речь ?

Тот, который по умолчанию в репозиториях:

Java 8, PHP 4?, Node.js 6, PostgreSQL 9, MariaDB 5 и т. д.

EXL ★★★★★ ()
Ответ на: комментарий от EXL

java-11 и 1.8.0 - в самом дистре. php-5.4.16 - в дистре.

nodejs14, postgresql13, mariadb105 - в sclo может даже новее уже есть …

И что ?

mx__ ★★★★★ ()
Ответ на: комментарий от Begemoth

Ок. Глянул тут по диагонали, все советы как самому пересобрать openssl новую, не сложно но да не в дистре.

Кроме openssl еще что есть ? Это да, не мало но хотелось бы еще что то знать.

P.S. Вот набрел : https://copr.fedorainfracloud.org/coprs/mlampe/mod_nss/

Description

A build of current mod_nss for el7. Uses the TLSv1.3-enabled NSS that ships with 7.7+ and therefore teaches el7’s venerable Apache TLSv1.3.

mx__ ★★★★★ ()
Последнее исправление: mx__ (всего исправлений: 2)
Ответ на: комментарий от mx__

И что ?

Что «и что»? Софт древний? Древний. Какой-нибудь WordPress уже рекомендует PHP 7 в последних версиях.

nodejs14, postgresql13, mariadb105 - в sclo может даже новее уже есть …

За софтом в sclo нужно ручками следить, обновление на следующую мажорную версию – проблематично, софт в sclo часто не является оттестированным и версии быстро забрасываются, деплой на софт из sclo переусложнён и заморочен, всякие там подгрузки переменных окружения перед запуском и т. д.

Админы и юзеры хотят инструмент проще и удобнее, поэтому sclo фактически выкинули и сделали всякие Podman’ы и прочие контейнеры в CentOS 8.

Когда говорят про древний софт в контексте CentOS имеют в виду именно то, про что я написал. Ибо если начинать новый проект под CentOS 7, нужно учитывать его древние версии пакетов или тебя ждёт свистопляска со сторонними плохоподдерживаемыми пакетами. А раз так, смысла в CentOS – нет.

EXL ★★★★★ ()
Последнее исправление: EXL (всего исправлений: 2)
Ответ на: комментарий от EXL

sclo это официальное зеркало шапки для продакшена если кто то не в курсе. И работает стабильно и без проблем. Личный опыт.

А кто не может осилить доку как его юзать тот ссзб, там примитивно все. Для админов sclo проще модулей если кто не в курсе, потому что я в одном окружении могу юзать кучу софта под разные версии ЯП а не плодить доп. оверхед в виде контейнеров. Про сборку sclo ничего сказать не могу.

mx__ ★★★★★ ()
Последнее исправление: mx__ (всего исправлений: 1)

софт CentOS очень старый

В семёрке либы glibc и libstdc++ протухли давно. Например, новый VS Code не запускается, точнее запускается, но в режиме блокнота т.к. дополнения расчитаны на более свежие версии.

cocucka ★★★★★ ()
Ответ на: комментарий от mx__

sclo это официальное зеркало шапки для продакшена если кто то не в курсе.

Все в курсе.

И работает стабильно и без проблем. Личный опыт.

У меня личный опыт отличается от твоего.

А кто не может осилить доку как его юзать тот ссзб, там примитивно все. Для админов sclo проще модулей если кто не в курсе, потому что я в одном окружении могу юзать кучу софта под разные версии ЯП а не плодить доп. оверхед в виде контейнеров.

Твоё же обсуждение 4 года назад: Fedora Toolbox (комментарий)

Переносим его на сегодняшнюю действительность и видим что ставка в CentOS 8 и CentOS 9 Steam сделана на AppStream и podman, а не на SCL.

Время CentOS 7 подошло к концу.

EXL ★★★★★ ()
Ответ на: комментарий от EXL

Да я не особо спорю, просто хотел узнать конкретику. По сути окромя openssl и нет ничего. Проблема то дутая …

Тут вот понадобился golang и rust так для 7х они самые последнии, поди даже в убунту такого нет…

ansible я юзаю 2.9.21, zoneminder 1.36.5 тоже самый последний … wireguard, дрова nvidia самые последнии.

Не точно - проблема дутая.

mx__ ★★★★★ ()
Ответ на: комментарий от EXL

Ну вот разрабы бузят :( Все кто на 8-ки требуют в модулях rust-1.53 а им где возьму ? 1.53 только для 7ки есть.

mx__ ★★★★★ ()
Ответ на: комментарий от Shulman

Firma 1С считает что кому и CentOS 6 кобыла

Т.е. фирма 1С считает, что сервера можно разворачивать на дистрибутивах давно снятых с поддержки?

Aleksandra ()
Ответ на: комментарий от mx__

естественно из flatpak

И code тоже? Если да, то неудивительно, что работает.

У меня code из реп мелкомягких, сборка для rhel7/centos7 и оно не работает без подсовывания новой libstdc++.

cocucka ★★★★★ ()
Ответ на: комментарий от cocucka

Ну я про коде и писал : 1.57.1-1623936438 https://flathub.org/apps/details/com.visualstudio.code

Вообще если судить по silverblue (ветка федора) то там весь софт, окромя системы, в основном из flatpak ставится, так что эта штука должна быть уже более менее стабильна.

А мс code уже не собирает под 7ку.

mx__ ★★★★★ ()
Последнее исправление: mx__ (всего исправлений: 1)
Ответ на: комментарий от mx__

А мс code уже не собирает под 7ку.

Да, только что проверил пакет и он под rhel8 собран. Ну да и хрен с ним, у меня всё равно свежий gcc кастомный, с его либами и запускаю.

З.Ы. Я вообще уже помойку развёл на рабочей тачке за последний год. Что-то в флетпаке стоит, что-то просто в систему поставлено, что-то пересобрано мной и ещё докером разбавлено.

cocucka ★★★★★ ()
Последнее исправление: cocucka (всего исправлений: 1)

Конечно древний, но всё зависит от того, как и где его использовать. Например, в моем случае весь нужный софт в свежих версиях есть - либо в репозиториях авторов софта, либо в основных сторонних репозиториях - без проблем гоняем сервера с последними версиями php, nginx и nodejs, и всё это замечательно работает.

Другое дело, что на каждый случай требуется некое ручное решение, и поэтому на десктопе я его использовать не стал бы - количество софта, которое захочется иметь свежим, очень большое.

aix27249 ()
Ответ на: комментарий от aix27249

Все бы хотелось конкретики … а то опять :(

Повторяюсь : пока кроме opessl небыло ничего конкретного. Хотя вон даже есть rpm под апач с tls-1.3 так что даже тут …

mx__ ★★★★★ ()

В обсуждении прочитал что софт CentOS очень старый и т.д. Мне вот стало интересно про какой софт идет речь ?

Любой. Там любой софт старый (мы же про сервер говорим). Она вышла в 2012 году.

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

Это ведь не значит, что они с 2012 года софт не обновляли. В первые 5 лет жизненного цикла они очень даже обновляют мажорные версии софта, что иногда приводит к проблемам.

bigbit ★★★★★ ()
Последнее исправление: bigbit (всего исправлений: 1)

Делов-то — пробежался по оф.репам и глянул нужный тебе софт, если не годится, то пробежался по неофициальным, если чего нет, то гуглишь собирается ли нужная версия, всё.

Всё что знаю про десктоп, это гном 28, ШГ — отстой, софта чуть больше, чем для 8 в сторонних репах, ядро 3.*, но поменять не проблема (elrepo).

papin-aziat ★★★★ ()
Ответ на: комментарий от mx__

Php 5.4 там тоже очень свежий. Да я знаю про костыль software collection…

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

Ну я юзаю nagios мне хватает … zabbix в свое время для несколько тысяч устройств показался мне слишком тяжелый …

Опять же zabbix новый в смысле дыр или каких еще фич ? Ну я хз.

mx__ ★★★★★ ()

Поэтому на серверах нужно юзать Убунточку.

windows10 ★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)