LINUX.ORG.RU
ФорумTalks

Под что собирать?

 ,


0

1

Есть ли единый Default Linux, под который все собирают своё ПО, чтобы оно потом у всех работало? Раньше под CentOS 6 собирал, но сейчас у него кончилась поддержка. P.S. FatELF-ы и прочите флатпаки не предлагать.

Чё ты как маленький. Собирай статику — статику во flatpack — flatpack в Docker-образ — Docker-образ в виртуалку — распространяй *.img — переносимость!

Если серьёзно, то собирай сам под те дистры, которые тебя волнуют. Придут тысячи пользователей требовать под BolgenOS — начнёшь собирать и под него или найдёшь желающих сделать это для тебя.

ilammy ★★★ ()
Ответ на: комментарий от reprimand

То есть получается, что, даже собирая под Fedora 32, можно ограничить совместимость бинарников, например, с Glibc 2.3 или 2.11?

ZenitharChampion ★★★★★ ()

Есть ли единый Default Linux

RHEL

чтобы оно потом у всех работало?

Flatpak. Snap без проблем работает только на бубунте. Appimage без проблем работает только в полнолуние на перекрестке четырех дорог.

qtm ★★ ()
Последнее исправление: qtm (всего исправлений: 1)

Если собирать статически и через devtoolset, то, по идее, почти везде должно заработать.

snizovtsev ★★★★ ()
Последнее исправление: snizovtsev (всего исправлений: 1)
Ответ на: комментарий от einhander

Rpm ну такое себе в плане переносимости

Там можно сделать зависимости на имена библиотек. RPM можно устанавливать в Debian и производных.

X512 ★★ ()

Использовать ISO/IEC 23360. Стандартнее некуда.

einhander ★★★★★ ()
Ответ на: комментарий от X512

Там можно...

Но никто не делает. Зачастую rpm от какого-нибудь suse не захотят ставится на fedora и наоборот. То что rpm можно ставить в deb системы я знаю.

einhander ★★★★★ ()
Последнее исправление: einhander (всего исправлений: 1)

А тебе зачем?

Если самый ленивый вариант, то делаешь жирный (что плевать на зависимости, суй всё что можно) DEB для Ubuntu 18.04 и старше, а остальное неважно.

Ну а если охота возиться, то тут простор огромный.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 2)

собирают своё ПО

Если это будет не репозиторий, из которого можно обновляться, то от этих deb, rpm и пр. толку никакого нет. Если планируешь делать репы, то под Убунту, Федору и tar.gz (чтобы можно было просто распаковать и запустить).

Im_not_a_robot ★★★★★ ()
Ответ на: комментарий от ilammy

самый проигрышный вариант, какой можно было предложить.

crypt ★★★★★ ()

делаешь статическую сборку с низкой версией glibc (у них обратная совместимость). потом упаковываешь в https://makeself.io/, инсталируешь куда-нибудь в /opt/ChampionSoftware/bin/Zenithar

ярлыки для десктопа закидываешь с полными путями.

crypt ★★★★★ ()
Последнее исправление: crypt (всего исправлений: 4)
Ответ на: комментарий от ilammy

Придут тысячи пользователей требовать под BolgenOS — начнёшь собирать и под него или найдёшь желающих сделать это для тебя.

вот это я и называю ленивый разработчик. терпеть таких не могу в мире опенсорс (привет, gimp!). «мы типа тут софт пишем, а вы нас всякой фигней не доставайте». в итоге юзеры размазаны по дистрибутивам, а прикладной софт ставится только на определенные версии, определенных систем и нигде больше не работает. а потом такие «ой, линукс не популярен! ой, софт под него не окупает себя! ой, давайте сосредоточимся на виндовой версии!»

crypt ★★★★★ ()
Последнее исправление: crypt (всего исправлений: 2)

чтобы оно потом у всех работало?

Manjaro / Archlinux, просто зависимости все с собой таскать и не надеяться на дистрибутив. Примерно как в Heroes 3 для Linux делали.

fsb4000 ★★★★★ ()
Ответ на: комментарий от crypt

gimp! ой, давайте сосредоточимся на виндовой версии!

Это точно не про GIMP. Там прям чувствуется, что уровень чуть ли скомпилировали под Windows, а проверять даже лень.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от fsb4000

чтобы оно потом у всех работало?

Manjaro / Archlinux

интересно, что должно быть в голове, чтобы это написать? у всех арч и манжаро?

crypt ★★★★★ ()
Ответ на: комментарий от crypt

прикладной софт ставится только на определенные версии, определенных систем и нигде больше не работает

Интересно, как это у меня на генте и арче всё работало, это я такой везучий?

fernandos ★★ ()
Ответ на: комментарий от fornlr

Это точно не про GIMP.

у них виндовой юзер базы больше половины. просто им настолько поср*ть на своих юзеров, что они даже этим не заморачиваются.

crypt ★★★★★ ()
Ответ на: комментарий от einhander

Но никто не делает.

В том и дело, что если не предпринимать специальных усилий, то программы под Линукс будут работать только в дистрибутиве сборки не сильно отличающейся версии. А если постараться, собрать кросс-дистрибутивный RPM можно.

X512 ★★ ()
Ответ на: комментарий от fernandos

Точно нет. Уж лучше .деб собрать, а в аур добавить простой пэкэджбилд.

да! да! разведите срач, какой дистр лучше! камон! один «умный» пришел и второй такой же его поддержал. реально, у линуксоидов с головой совсем все неважно.:(

crypt ★★★★★ ()
Последнее исправление: crypt (всего исправлений: 1)

А зойчем тебе единый дистр? Зоопарк - натуральные тесткейсы, проверка качества твоего ПО

TooPar ()
Ответ на: удаленный комментарий

Конкретные случаи? Отлично, вы же привели гимп в качестве примера, отлично.

прикладной софт ставится только на определенные версии, определенных систем и нигде больше не работает

https://repology.org/project/gimp/versions

Что же это за таинственные системы?

fernandos ★★ ()
Ответ на: комментарий от crypt

интересно, что должно быть в голове, чтобы это написать? у всех арч и манжаро?

Какая разница что у всех? Собранное на арче будет работать везде. Собирать для конкретного дистрибутива это бред.

Вот послушай Линуса:

https://youtu.be/Pzl1B7nB9Kc

«Nobody should waste their life targeting systems nobody uses».

и про то, что Steam делает всё правильно. Что игры в магазине Steam собираются под зависимости Steam, и забивают болт на дистрибутивные библиотеки.

А так приложения собранные gcc 11.1 с модулями на Manjaro запускаются и на Ubuntu 12.04 если зависимости с собой таскать, остаётся лишь зависимость от версии ядра Linux чтобы не была слишком старой, пока Linux 3.x достаточно…

fsb4000 ★★★★★ ()
Ответ на: комментарий от fsb4000

Собранное на арче будет работать везде. Собирать для конкретного дистрибутива это бред

Так может просто архив собрать, не под арч, а просто архив с бинарником.

fernandos ★★ ()
Ответ на: комментарий от fsb4000

Какая разница что у всех? Собранное на арче будет работать везде.

ты же вообще за бзд тролишь обычно. зачем начинаешь за систему, где ты явную хрень несешь. ну обоснуй с технической точки зрения, почему собранное под арч будет работать везде. есть какие-то причины?

crypt ★★★★★ ()
Ответ на: комментарий от fernandos

Так может просто архив собрать, не под арч, а просто архив с бинарником.

Ну это и имелось ввиду. Просто был выбран арч/манджара так как там новые версии библиотек.

fsb4000 ★★★★★ ()
Ответ на: комментарий от fernandos

Что же это за таинственные системы?

я на RHEL6 гимп 2.8 собирал уже с бампом гномовых компонентов.

crypt ★★★★★ ()
Ответ на: комментарий от fsb4000

Собранное на арче будет работать везде.

Ну это и имелось ввиду. Просто был выбран арч/манджара так как там новые версии библиотек.

У меня тут одно слово только возникло в мыслях, но на него пожаловаться могут 🤣

fornlr ★★★★★ ()

Есть ли единый Default Linux, под который все собирают своё ПО, чтобы оно потом у всех работало?

LSB.

Meyer ★★★★★ ()
Ответ на: комментарий от fernandos

Ну это и имелось ввиду. Просто был выбран арч/манджара так как там новые версии библиотек.

Обычно есть обратная совместимость, но наоборот редко. Я бы на старой (относительно) системе собирал.

fernandos fsb4000 вы два теоретика локал-хостов. я держал репы с деб и rpm на проектах регулярно. т.е. годами регулярно занимался сборкой ПО для stable веток, в то время, как софтоклепатели писали все на «арч/манджара так как там новые версии библиотек».

так вот скажу вам, что там такое минное поле, какое вам и не снилось. нету там толком никакой совместимости ни в одну сторону.

crypt ★★★★★ ()
Ответ на: комментарий от crypt

нету там толком никакой совместимости ни в одну сторону.

Ну продолжай думать как хочешь. И собирать 100500 пакетов под каждый дистрибутив. А я умею собирать на Manjaro так что оно будет запускаться везде.

fsb4000 ★★★★★ ()
Ответ на: комментарий от crypt

софтоклепатели писали все на «арч/манджара так как там новые версии библиотек»

Я и не говорю, что это хорошо. Если программа пишется на арче/манджаре, то у неё, возможно, нет поддержки старых систем. Если этой поддержки нет, то собирать её для старых систем будет сложно.

fernandos ★★ ()
Ответ на: комментарий от fernandos

Если этой поддержки нет, то собирать её для старых систем будет сложно.

а если пишется для старых, то ты точно также не сможешь ее собрать на новых, потому что новый компилятор больше не одобряет старое поведение или еще что-нибудь.

crypt ★★★★★ ()
Последнее исправление: crypt (всего исправлений: 1)
Ответ на: комментарий от eternal_sorrow

да я еще AP предлагал достать. говорю: дам тебе удаленный шел, попробуй собрать свой gimp. и с твоим паком та же лажа. не запуститься он на RHEL6. а по размеру явно будет больше, чем статик билд. пусть ТС сам решает.

crypt ★★★★★ ()
Ответ на: комментарий от fernandos

сейчас та же фигня с goldendict. под последний qt его не переписали, потому что некому, а qt4 уже удален из всех систем, как устаревший. вот как хочешь, так и инсталируй.

crypt ★★★★★ ()
Закрыто добавление комментариев для недавно зарегистрированных пользователей (со score < 50)