LINUX.ORG.RU

Собрал Tor Browser

 , , , ,


0

1

Upd: написал про проблемку

Привет. Собрал Tor Browser. Максимально идентично официальной сборке, только в более старом сборочном окружении, чтобы «захватить» годы выпусков нескольких старых дистрибутивов Linux, которыми я пользуюсь (например CentOS 6 и SLES 11, а вообще сборочное окружение CentOS 5). Брать тут: Соберу какую-нибудь фигню в виде универсального бинарника

Возникла проблемка. В Tor Browser 7.0 (который сейчас в альфа-версии) добавили условие: директория Browser/TorBrowser/Data должна иметь права 600. Ну, я делаю то что от меня просят, потом архивирую свою сборку и выкладываю в веб. А мне говорят «ничего не работает». Смотрю - права не сохранились. Так вот, как правильно заархивировать, чтобы:

1). Основные права сохранялись?
2). Расширенные права (zenithar:users) не сохранялись? У меня пока что наоборот. Архивировал так:

tar cf torbrowser.tar torbrowser
xz torbrowser.tar

Ты опять занимаешься костылянием нового под говно мамонта?

nexfwall ★★★★ ()
Ответ на: комментарий от nexfwall

99% прог так и собрано - я про проги для Windows. Собрал под старое - запускай где хочешь! Так что не только под говно мамонта. Я собрал с GTK 2.10 и проверил на 2.24.

// Надо-надо 64-битную версию: оказывается, разработчики вставили проверку на разрядность, и выдают окошко с рекомендацией скачать 64-бит. В течение 3 дней соберу.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)

Athlon XP

Steam

На нём играть-то почти не во что.

Myau ★★★★ ()
Ответ на: комментарий от Myau

Замечательно работают: Super Meat Boy, FEZ, Cogs, EDGE, Brutal legend, Faster Than Light, Hotline Miami, Crayon Physics Deluxe и прочий DRM-free с Humble Bundle. но я играю в основном в эмуляторы сеги и денди. С Геймпадом от Playstation трудно играть в 6-кнопочные игры...

ZenitharChampion ★★★★★ ()

Если любишь собирать, то открой для себя Gentoo

sudopacman ★★★★★ ()
Ответ на: комментарий от GNU-Ubuntu1204LTS

Один мой друг установил Ubuntu 15.10. Обжил её. После релиза Ubuntu 16.04 прошло два месяца, а друг не понимает: почему его система внезапно стала никому не нужна? Он всё чаще сталкивается с программами, которые собраны под 16.04, и не ниже.

Чего такого в его системе нет, что она не имеет права называться полноценным линуксом? Чего в этой «убийце виндов» недостаточно?

На самом деле достаточно всего, просто мейнейнеры - криворучки.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от GNU-Ubuntu1204LTS

Понимаешь в чём прикол. Вот декабрь 2015-го, вот ты ставишь Ubuntu 15.10. Безупречная система, убица виндов! Вот ты её кастомизируешь под себя, вот ставишь дополнительные программы. Проходит 4 месяца. И вот ты заходишь на сайт с новым эмулятором Nintendo Wii, а там - пакеты для Ubuntu 16.04. При попытке установить - никак. Решаешь вернуть хотя бы старые пакеты - но нет, PPA для Ubuntu 15.10 уже удалён!

Вчерашний «убийца виндусов» превратился в тыкву. И вот ты ищешь руководство по обновлению 15.10 до 16.04, вот что-то не до конца обновилось, вот ты сидишь без интернета и не знаешь как починить!

Я яростно дрочу на старый линукс, я считаю его более удобным, чем Windows и чем Linux наших дней. Меня огорчает, что я не могу установить линукс 2005 года, а потом современные программы в него - хотя с Windows XP я это могу. Да блин, даже линукс 2015 года уже нифига не «убийца виндов», а «неюзабельная система, в которой не всё запускается!»

При этом мне печально осознавать, что преград-то нет, что это искуственные трудности. Ну нет в Ubuntu 16.04 ничего такого, что позарез надо новым софтинам. Ни DRI4, ни Wayland, ни новой звуковой системы - ничего.

Есть два пути: 1). Установить в старый линукс - новый Glibc. Тогда новые версии гугл хрома, скайпа и какого-нибудь клона автокада запустятся без дополнительной настройки. Но есть и недостаток: как ты знаешь, я пользуюсь мегастабильным энтерпрайзным линуксом, и это действие лишает его энтерпрайзности. 2). Пересобрать новый софт под старый линукс. Но это не работает с проприетарщиной. Ах да, для проприетарщины же есть patchelf...

Я реализовал оба способа. Тут первым пунктом идёт Firefox, я проверил его на сегодняшнем Mint 18, в Ubuntu 9.10 и в какой-то мандриве - работает везде. Впрочем, у фаерфокса и официальные бинарники неплохие (сборочное окружение - CentOS 6). А последним пунктом идёт Glibc для CentOS 5, так как я один, а желающих запустить новую софтину под старый линукс - много.

Сейчас самая адекватная система, ИМХО, это CentOS 6. 1). Нормальный Гном2 2). Есть симпатичная гуишка для фаерволла - где ещё так? 3). Нет системГэ 4). Не сильно старая. Пожалуй, нет ни одной технологии, которой там нет: там есть DRI2, дающий нормальный ресайз в компизе. Xinput2, дающий Raw Input и мультитач. И USB3... Как следствие - обновил Glibc с 2.12 до 2.17, и работает тупо всё. Да-да, вообще всё: я ещё не нашёл ни одной проги, которая не заработала.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

а друг не понимает: почему его система внезапно стала никому не нужна?

потому что он поставил не LTS

Harald ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Я забыл сказать важную вещь. Пересборка под старый линукс не лишает прогу возможности запускаться в новом! Меня много хвалили за сборку PCSX2, так как официальная - какая-то наркоманская, требует такую версию libGLEW, которой нет ни в последней Devel ветке убунты, ни в LTS, и такую сборку WxWidgets, которая отсутствует в убунту вовсе!

Разработчики! Просто собирайте не в распоследней девел ветке вашего любимого дистра, а на один-два дистра старее! Тогда пользователи скажут спасибо!

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

в старых дистрах зависимости старые :)

и вообще, rolling-release и source-based рулят

Harald ★★★★★ ()
Ответ на: комментарий от Harald

Ну вот смотри, допустим программа давно не обновлялась, релиз в 2014 году. Захожу в репо Ubuntu 14.04 и 16.04, распаковываю и сравниваю. Ldd говорит, что сборка №1 хочет libgnutls.so.31, а сборка №2 - libgnutls.so.45. Собраны из одного исходника... Вывод: проге пофиг с чем линковаться :-)

И даже если не пофиг и версия 45 это нижняя планка, с которой работает прога - библиотеку можно положить с программой. Вот глянь мой лаунчер для Майнкрафта, он требует Qt 5.4 и некую библиотеку Quazip. И тем не менее, запускается практически в любом линуксе, даже времён Qt3.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 5)

Спустя всего лишь 8 месяцев собрал для 64 бит! И добавил вопросик.

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.