LINUX.ORG.RU

Подумал, что опенсорснули какую-то версию интеловского процессора и временно выпал в осадок.

А опенсорснулась ненужная пародия на Emacs для гейОС.

tailgunner ★★★★★ ()
Последнее исправление: tailgunner (всего исправлений: 1)
Ответ на: комментарий от Dantix

Саблайм тоже пародия на Emacs. Вообще, начиная с Emacs, все расширяемые редакторы - пародии на Emacs. Бывают неплохие (Multi-Edit), бывают хипстерско-ненужные (Sublime, Atom).

tailgunner ★★★★★ ()
Ответ на: На, просвящайся от Bad_ptr

С заменой телетайпов терминалами в начале 1970-х, получил популярность текстовый редактор TECO. Недостатком его было то, что он работал в командном режиме. Каждое действие (открыть файл, закрыть, сохранить, ввести текст и т. п.) осуществлялось соответствующей командой редактора, представляющей собой цепочку инструкций.

Ну вим же ☺

vurdalak ★★★★★ ()
Ответ на: комментарий от tailgunner

Я вообще сам вимом пользуюсь и он меня устраивает.

Dantix ★★ ()
Ответ на: комментарий от vertexua

Пока да, но обещают в течении пару месяцев запотеть билды под онтопик и ненужно

Dantix ★★ ()
Ответ на: комментарий от vurdalak

А сам Emacs — пародия на Vim.

Ты контрамот штоле сцуко?

tailgunner ★★★★★ ()
Ответ на: комментарий от int13h

Убрал, на самом деле, я забыл про процессоры этой серии.

Dantix ★★ ()

Кстати, написано-то ведь в основном на coffeescript. Добавьте в теги, пожалуйста.

Anatolik ★★ ()

У кого собралось?

script/build

npm WARN package.json github-url-from-git@1.1.1 No repository field.
Failed to download node { [Error: EXDEV, rename '/tmp/apm-node-11446-1150-1jmcibz/node-v0.10.26-linux-x64/bin/node']
errno: 52,
code: 'EXDEV',
path: '/tmp/apm-node-11446-1150-1jmcibz/node-v0.10.26-linux-x64/bin/node' }
npm ERR! atom-package-manager@0.45.0 install: `node ./script/download-node.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the atom-package-manager@0.45.0 install script.
npm ERR! This is most likely a problem with the atom-package-manager package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node ./script/download-node.js
npm ERR! You can get their info via:
npm ERR! npm owner ls atom-package-manager
npm ERR! There is likely additional logging output above.

npm ERR! System Linux 3.13.8-1-ARCH
npm ERR! command «node» «/home/data/svn/atom/build/node_modules/.bin/npm» "--userconfig=/home/data/svn/atom/.npmrc" «install» "--quiet"
npm ERR! cwd /home/data/svn/atom/apm
npm ERR! node -v v0.10.26
npm ERR! npm -v 1.4.10
npm ERR! code ELIFECYCLE
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /home/data/svn/atom/apm/npm-debug.log
npm ERR! not ok code 0


cat /home/data/svn/atom/apm/npm-debug.log
... Тут куча всякого поскипано
-------8<----------------
2988 silly gunzTarPerm extractEntry deps/libgit2/include/git2/status.h
2989 silly gunzTarPerm extractEntry deps/libgit2/include/git2/stdint.h
2990 silly gunzTarPerm extractEntry test/disabled/outdated-depth-integer/index.js
2991 silly gunzTarPerm extractEntry test/disabled/change-bin-2/package.json
2992 error error rolling back Error: ENOTEMPTY, rmdir '/home/data/svn/atom/apm/node_modules/atom-package-manager/node_modules/npm/html/doc'
2992 error error rolling back atom-package-manager@0.45.0 { [Error: ENOTEMPTY, rmdir '/home/data/svn/atom/apm/node_modules/atom-package-manager/node_modules/npm/html/doc']
2992 error error rolling back errno: 53,
2992 error error rolling back code: 'ENOTEMPTY',
2992 error error rolling back path: '/home/data/svn/atom/apm/node_modules/atom-package-manager/node_modules/npm/html/doc' }
2993 error runas@0.3.0 install: `node-gyp rebuild`
2993 error Exit status 1
2994 error Failed at the runas@0.3.0 install script.
2994 error This is most likely a problem with the runas package,
2994 error not with npm itself.
2994 error Tell the author that this fails on your system:
2994 error node-gyp rebuild
2994 error You can get their info via:
2994 error npm owner ls runas
2994 error There is likely additional logging output above.
2995 error System Linux 3.13.8-1-ARCH
2996 error command «node» «/home/data/svn/atom/build/node_modules/.bin/npm» "--userconfig=/home/data/svn/atom/.npmrc" «install» "--quiet"
2997 error cwd /home/data/svn/atom/apm
2998 error node -v v0.10.26
2999 error npm -v 1.4.10
3000 error code ELIFECYCLE
3001 verbose exit [ 1, true ]

Bad_ptr ★★★★ ()

А, тьфу, я уже подумал, что подразумевалось под открытием мелкого процессора... Ну зачем писать такие желтые заголовки?

Lilly ()
Ответ на: комментарий от Dantix

Макось достань сначала

ну не знаю. Там ведь инструкция сбора для линукса есть — значит должно собираться

Bad_ptr ★★★★ ()
Ответ на: комментарий от GblGbl

Для тру - это не про процессор

Спасибо, успел остановиться и не открыть ссылку

upcFrost ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.