LINUX.ORG.RU

FFmpeg | не работает -to при ремуксе VOB (MPEG-2)

 


0

1

https://ffmpeg.org/ffmpeg.html#toc-Main-options

-to position (input/output)
Stop writing the output or reading the input at position. position must be a time duration specification

ffmpeg -hide_banner -fflags +genpts -ss 02:37 -to 04:34 -i VTS_01_2.VOB -c copy output.vob

И не пашет, хотя с h264 работает. Пробовал ещё поставить -to перед output.vob, но тоже бесполезно. Чего такое, как сделать, чтобы работало? (-ss работает)

★★

Ответ на: комментарий от Ros

Мне почему то тоже качется что не -to а -t. И ещё не знаю что должны значить -hide_banner -fflags +genpts в том месте, где должны перечисляться входные файлы. ffmpeg как никак чувствителен к порядку команд.

kirill_rrr ★★★★★ ()

-to and -t are mutually exclusive and -t has priority.

используй "-t", и учти:

When used as an input option (before "-i"), limit the duration of data read from the input file.

попробуй опции указать в самом начале. Конкретно эти опции относятся к FFMPEG-UTILS , т.е. последовательность нужно учитывать при указании тех или иных кодеков и плюшек. В общем читай маны на утилиты, они там перечислены man ffmpeg-utils.

Gramozeka ★★ ()
Последнее исправление: Gramozeka (всего исправлений: 1)