LINUX.ORG.RU

Ubuntu 19.10 JACK не запускается

 , , ,


1

1

Всем привет!

Хороший человек @curufinwe посоветовал мне для табулатур и нот использовать линуксовый TuxGuitar в тандеме с FluidSynth (QSynth) через JACK. Но я совершенный новичок и не понимаю, как это все заставить работать.

Когда я запускаю qJackCtrl, в сообщениях вижу:

00:22:36.394 Statistics reset.
00:22:36.445 ALSA connection change.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
00:22:36.488 ALSA connection graph change.

В настройках у меня все дефолтно, отключена галка Enable D-Bus Interface / Enable Jack D-Bus interface. При нажатии на старт оно ругается на

Could not connect to JACK server as client.
- Overall operation failed.
- Server communication error.
Please check the messages window for more info.

и вываливает в messages:

00:24:21.326 JACK is starting...
00:24:21.327 /usr/bin/jackd -dalsa -dhw:0 -r44100 -p1024 -n2 -Xraw
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
00:24:21.396 JACK was started with PID=2881.
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
Cannot create RT messagebuffer thread: Operation not permitted (1)
Retrying messagebuffer thread without RT scheduling
Messagebuffer not realtime; consider enabling RT scheduling for user
no message buffer overruns
jackdmp 1.9.12
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2016 Grame.
Copyright 2016-2017 Filipe Coelho.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK server starting in realtime mode with priority 10
self-connect-mode is "Don't restrict self connect requests"
Cannot lock down 82280346 byte memory area (Cannot allocate memory)
audio_reservation_init
Acquire audio card Audio0
creating alsa driver ... hw:0|hw:0|1024|2|44100|0|0|nomon|swmeter|-|32bit
configuring for 44100Hz, period = 1024 frames (23.2 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 24bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 24bit little-endian
ALSA: use 2 periods for playback
Cannot create thread res = 1
Cannot use real-time scheduling (RR/10)(1: Operation not permitted)
AcquireSelfRealTime error
00:24:28.528 Could not connect to JACK server as client. - Overall operation failed. - Server communication error. Please check the messages window for more info.
JackPosixProcessSync::LockedTimedWait error usec = 5000000 err = Connection timed out
Driver is not running
Cannot create new client
Cannot read socket fd = 27 err = Success
CheckRes error
JackSocketClientChannel read fail
Cannot open qjackctl client
JackShmReadWritePtr1::~JackShmReadWritePtr1 - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
00:25:06.865 JACK is stopping...
Jack main caught signal 15

Видимо, тут ключевое «operation not permitted». В общем, научите - подскажите.

P.S. Встроенный в TuxGuitar секвенсор тоже не работает, играть играет но тишина в динамиках.


Ответ на: комментарий от jtad

Дичайше извиняюсь, но не смог найти .sh файл, однако

c0da@c0da-home:~$ tuxguitar -i
System Info:
-> OS-Name:           Linux
-> OS-Arch:           amd64
-> OS-Version:        5.3.0-29-generic
-> JVM-Name:          OpenJDK 64-Bit Server VM
-> JVM-Version:       11.0.6+10-post-Ubuntu-1ubuntu119.10.1
-> JVM-Vendor:        Ubuntu
-> Java-Version:      11.0.6
-> Java-Vendor:       Ubuntu
-> Java-Home:         /usr/lib/jvm/java-11-openjdk-amd64
-> Java-Class-Path:   :/usr/share/tuxguitar/:/usr/share/tuxguitar//tuxguitar.jar:/usr/share/java/itext.jar:/usr/share/java/swt4.jar:
-> Java-Library-Path: /usr/lib/jni
c0da@c0da-home:~$ tuxguitar 

(TuxGuitar:7419): Gtk-CRITICAL **: 01:21:59.909: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar
/dev/sequencer: No such file or directory

(TuxGuitar:7419): Gtk-CRITICAL **: 01:22:01.811: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

(TuxGuitar:7419): Gtk-CRITICAL **: 01:22:01.829: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

(TuxGuitar:7419): Gtk-CRITICAL **: 01:22:01.830: gtk_box_gadget_distribute: assertion 'size >= 0' failed in GtkScrollbar

(TuxGuitar:7419): Gtk-WARNING **: 01:22:01.842: Negative content height -1 (allocation 1, extents 1x1) while allocating gadget (node scrolledwindow, owner GtkScrolledWindow)

(TuxGuitar:7419): Gtk-WARNING **: 01:22:02.154: Negative content height -1 (allocation 1, extents 1x1) while allocating gadget (node scrolledwindow, owner GtkScrolledWindow)

В консоли вываливает ошибки. Я только что нагуглил, что нужно ставить Timidity еще к нему, может в этом дело. Но с другой стороны, если получится с Jack запустить и синтезатор внешний сделать, оно не так и нужно.

c0da ()

Тебе надо погуглить ubuntu jack enable realtime. Кстати, dpkg спрашивает при установке, но можно и руками. Там пару строк в одном файле.

anonymous ()

Кстати Tuxguitar, если не ошибаюсь, реального времени не требует. Так что, как вариант, просто отключи реальное время у Джека и тогда он стартанёт. Только через pasusspender запускай или как его там.

anonymous ()

Несколько вопросов

  1. В каких группах пользователь состоит? Дай выхлоп groups

  2. В TuxGuitar что выбрано в качестве «MIDI порт» и «MIDI секвенсор»?

  3. jack на какой карте ты пытаешься запустить - на встроенной или на GT-1?

  4. Какая модель встроенной карты?

curufinwe ★★★★★ ()
Ответ на: комментарий от curufinwe
c0da@c0da-home:~$ id -Gn
c0da adm cdrom sudo dip plugdev lpadmin lxd sambashare owlcloud_users

Последняя - это для домашнего NAS.

В Tux у меня так:

MIDI Sequencer: [1] Tux Guitar Sequencer [2] JACK Sequencer

MIDI Port: [1] MIDI Through Port 0 [14:0] [2] JACK Midi Port

Я же верно понимаю, что выбрав 1-1 должен быть встроенный звук, а 2-2 через JACK?

JACK я указал как Default список вот: https://imgur.com/rjwo8IB.png https://imgur.com/9l8IjyF.png

На GT-1 не пробовал (хотя даже запись не пробовал с нее еще в Ardour).

c0da@c0da-home:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: bytcrrt5640 [bytcr-rt5640], device 0: 3 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: bytcrrt5640 [bytcr-rt5640], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
c0da ()
Ответ на: комментарий от c0da

Во-первых, попробуй добавиться в группу audio. Уточни для убунты, она ли нужна для realtime audio в убунте, я могу ошибаться, но насколько я знаю в ней не-члены этой группы не имеют возможности использовать jack на полную. Скорее всего проблема в этом.

По поводу TuxGuitar. Естественно что звука нет, потому что в варианте 1-1 ты выводишь его в миди-порт, к которому не подключено ничего (на встроенной карте аппаратного midi синтезатора нет походу).

Поэтому в качестве Midi Port там должен быть выбран Gervill - это синтезатор Java машины. Если такого варианта нет - то тогда надо разбираться почему. Поскольку это связано с java, надо смотреть какая версия java стоит и какие доступны в убунте.

curufinwe ★★★★★ ()
Последнее исправление: curufinwe (всего исправлений: 1)
Ответ на: комментарий от c0da

Добавлся, ведет себя так же ..

  1. У тебя реалтайм не включен в /etc/security/limits.conf
  2. Если добавил себя в audio – релогин нужен, чтобы стать в этой группе.

Далее сделай

sudo nano /etc/security/limits.conf

и добавь туда

@audio   -  rtprio     95
@audio   -  memlock    unlimited

Ctrl+X, Y, Enter. И всё заработает.

Ну может в самом TuxGuitar ещё пару настроек.

kostyarin_ ★★ ()
Ответ на: комментарий от c0da

То есть, выходит, что моя встроенная звуковуха не умеет реалтайм? О_о

Может тебе просто входы-выходы нужно настроить. Поставь qjackctl и посмотри на соединения. Поменяй, если нужно.

kostyarin_ ★★ ()
Ответ на: комментарий от c0da

То есть, выходит, что моя встроенная звуковуха не умеет реалтайм? О_о

Вполне возможно, редко, но бывает. У тебя какая-то несколько экзотическая модель. Ты пробовал гуглить насчет опыта ее использования в линуксе у народа, про нее что-нибудь определенное пишут?

И - просто попробуй отключить realtime режим в настройках QJackCtl и запускаться. TuxGuitar и без него работать нормально должен. Этот режим больше нужен если используешь софтовый гитарный процессор, например. Но у тебя же аппаратный, так что можно и без этого.

Если не поможет - попробуй включить птичку «без блокировки памяти» (сорри, у меня русский интерфейс, не знаю как оно в англоязычном названо).

curufinwe ★★★★★ ()
Последнее исправление: curufinwe (всего исправлений: 2)