LINUX.ORG.RU

ГИМП 2.10.6 нужна версия пакета gimp-data-extras 2.0.4

 ,


0

1

РЕШЕНО https://www.opennet.ru/opennews/art.shtml?num=48913 «В gimp-data-extras вынесены скрипты Alpha-to-Logo, которые не были включены в ветку 2.10 из-за ненадлежащего качества графики (для установки скриптов достаточно скопировать файлы ».scm" из архива в каталог scripts GIMP)." - только скрипты переносить нужно было не в папку пользователя, а в /usr/share/gimp/2.0/scripts Дальше идёт уже никому не нужное описание неудачных попыток, которое я в ближайшие 6 часов не смогу удалить:

Здравствуйте! Xubuntu 18.04 XFCE ГИМП 2.10.6 В ГИМП нужна версия пакета gimp-data-extras 2.0.4, без которой не работает ряд важных для меня функций, таких, как «альфа-в лого».

Ситуация с пакетом описана разработчиком вот здесь: http://www.gimpusers.com/forums/gimp-user/20769-announce-gimp-data-extras-2-0...

Скачал, как рекомендуется, исходники с https://download.gimp.org/mirror/pub/gimp/extras/ и, как там рекомендуется, переименовал configure.in в configure.ac (не уверен, правда, что это именно пользователю рекомендация, а не сборщику пакетов какому-нибудь, но и без этого переименования тоже не сработало, см. ещё мои неудачные попытки, описанные на https://uroki-gimp.ru/forum/voprosy-po-urokam-na-sajte/sozdaem-nastoyashhij-n...)

Однако, не получается скомпилировать:

anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ sudo ./configure

[sudo] password for anykey:

checking for a BSD-compatible install... /usr/bin/install -c

checking whether build environment is sane... yes

checking for a thread-safe mkdir -p... /bin/mkdir -p

checking for gawk... gawk

checking whether make sets $(MAKE)... yes

checking whether make supports nested variables... yes

checking whether to enable maintainer-specific portions of Makefiles... no

checking for pkg-config... /usr/bin/pkg-config

checking pkg-config is at least version 0.9.0... yes

checking for gimp... no

configure: error: Package requirements (gimp-2.0) were not met:

No package 'gimp-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you

installed software in a non-standard prefix.

Alternatively, you may set the environment variables gimp_CFLAGS

and gimp_LIBS to avoid the need to call pkg-config.

See the pkg-config man page for more details.

anykey@anykey:~/DELO_TECHNIKI/GIMP_extensions/gimp-data-extras-2.0.4$ sudo ./configure && make && make install routine

checking for a BSD-compatible install... /usr/bin/install -c

checking whether build environment is sane... yes

checking for a thread-safe mkdir -p... /bin/mkdir -p

checking for gawk... gawk

checking whether make sets $(MAKE)... yes

checking whether make supports nested variables... yes

checking whether to enable maintainer-specific portions of Makefiles... no

checking for pkg-config... /usr/bin/pkg-config

checking pkg-config is at least version 0.9.0... yes

checking for gimp... no

configure: error: Package requirements (gimp-2.0) were not met:

No package 'gimp-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you

installed software in a non-standard prefix.

Alternatively, you may set the environment variables gimp_CFLAGS

and gimp_LIBS to avoid the need to call pkg-config.

See the pkg-config man page for more details.

В переименованном configure.ac поменял gimp2.0 на gimp2.8 (так поименована папка ГИМПа в системе) - не помогло, вернул как было.

Возможно, небезинтересно будет то, что Synaptic видит один GNU Image Manipulation Programm, а через «Установка приложений» виден дополнительно ещё и просто GIMP, причём один был установлен, второй нет; версии у обоих 2.10.6, но у них несколько разный дефолтный интерфейс и лого; второй экземпляр ГИМПа пути, уже прописанные ручками в первом, сходу не подхватил, пришлось дописывать.

Во втором нужной опции тоже нет, зависимостью новый пакет не подтянулся.

В данных источника GIMP вместо bionic указывал cosmic, но новой версии пакетов там тоже нету.

Спасите-помогите, пожалуйста!

только скрипты переносить нужно было не в папку пользователя, а в /usr/share/gimp/2.0/scripts

Нет, не нужно.

Однако, не получается скомпилировать:

Там нечего компилировать.

configure: error: Package requirements (gimp-2.0) were not met:

Нет пакета gimp-dev или как его там.

AP ★★★★★ ()