LINUX.ORG.RU
ФорумMobile

Несовместимость блютус-наушников и смартфона

 ,


0

1

Всем привет.

Наушники JBL Reflect Mini 2 отлично работали с Samsung A30s (Андроид 9, позже - 10), однако отказываются работать с Samsung A31 (Андроид 10).
У наушников Bluetooth 4.2, у обоих телефонов - 5.0 (судя по спекам - они совместимы).
Однако, на A31 при поиске BT девайсов они не обнаруживаются.
На реддите есть тема с аналогичной проблемой, однако, без решения. Там закончили обсуждение на том, что саппорт JBL подтвердил, что с десятым Андроидом работать не будет.

Не доверяю я реддиту и ответам техподдержки, поэтому подскажите, может кто сталкивался с подобным (возможно, с другими устройствами) и смог побороть?

Не доверяю я <…> ответам техподдержки

Ну если тебе разраб сказал что ты купил устаревшую парашу, то что ты от нас хочешь? На 30й самсе работает скорее всего потому что оно уже записало данные устройства и сопряглось. 80%, что если ты его удалишь - то потом не подключишь.

PPP328 ★★★★ ()
Ответ на: комментарий от mikeuser

Да, конечно. Я включаю режим сопряжения, их просто нет в списке найденных девайсов.
ПС: в списке заблокированных устройств их тоже нет.

anonymous_sapiens ★★★★★ ()
Последнее исправление: anonymous_sapiens (всего исправлений: 1)

саппорт JBL подтвердил, что с десятым Андроидом работать не будет.

Хрень какую-то они сотворили. Или их MAC попал в blacklist каким-то образом.

Посмотри в /system/etc/bluetooth/ записи с первыми тремя байтами через ":" MAC-адреса наушников. Там могут быть прописаны какие-то дополнительные параметры.

Radjah ★★★★★ ()
Последнее исправление: Radjah (всего исправлений: 1)
Ответ на: комментарий от Radjah

Блин, не рутнут телефон для такого. Эх, если нет решения обычными силами, придется купить другие наушники :(
Только неясно, где гарантия, что новые так же себя не поведут

anonymous_sapiens ★★★★★ ()
Ответ на: комментарий от anonymous_sapiens

Для просмотра конфигов BT root не нужен.

Только неясно, где гарантия, что новые так же себя не поведут

Все купленные гарнитуры SONY с 2012 года работают исправно у меня.

А гарнитуру твою точно ничего из окружения не перехватывает?

Radjah ★★★★★ ()
Ответ на: комментарий от Radjah

А гарнитуру твою точно ничего из окружения не перехватывает?

Да, поотключал все BT другие.
Просто непонятно, как так, почему они не совместимы. Вот выше товарищи (агрессивные) пишут, что это нормально. Хз, на мой вкус, не очень нормально, если заявлена обратная совместимость например.

anonymous_sapiens ★★★★★ ()
Ответ на: комментарий от PPP328

На 30й самсе работает скорее всего потому что оно уже записало данные устройства и сопряглось. 80%, что если ты его удалишь - то потом не подключишь. сопряглось

А в 10 Андроиде поменялся механизм сопряжения. Мда

tyamur ★★ ()