LINUX.ORG.RU

проблемы с установкой debian testing


0

1

Пишу в этот раздел, потому что есть установщик для testing, но я хочу понять чем он принципиально отличается от того что делаю я.

Debian Wheezy 7.1.0 Чистая установка, галочки на стандартных утилитах и окружении рабочего стола. aptitude update && aptitude upgrade - все обновлено

в sources.list прописываю testing:

deb http://mirror.yandex.ru/debian/ testing main contrib non-free
deb-src http://mirror.yandex.ru/debian/ testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

deb http://mirror.yandex.ru/debian/ testing-proposed-updates main contrib non-free
deb-src http://mirror.yandex.ru/debian/ testing-proposed-updates main contrib non-free

Делаю aptitude update && aptitude full-upgrade, получаю кучу сообщений о конфликтах, не знаю что делать дальше. Как правильно сделать апгрейд до testing? Знаю что можно apt-get, но разве это правильно (он же просто промолчит, а ошибки останутся)?

вывод aptitude (часть вырезал):

The following packages have unmet dependencies:
 libtext-charwidth-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libpurple0 : Depends: perlapi-5.14.2 which is a virtual package.
 libnet-ssleay-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libnet-dns-perl : Depends: perlapi-5.14.2 which is a virtual package.
                   Depends: libdigest-hmac-perl (>= 1) but it is not going to be installed.
                   Depends: libnet-ip-perl (>= 1.2) but it is not going to be installed.
                   Depends: libio-socket-inet6-perl but it is not going to be installed.
 libnet-dbus-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libclone-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libsocket-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libxml-parser-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libcairo-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libgtk2-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libhtml-parser-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libsub-name-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libuuid-perl : Depends: perlapi-5.14.2 which is a virtual package.
 liblocale-gettext-perl : PreDepends: perlapi-5.14.2 which is a virtual package.
 libio-pty-perl : Depends: perlapi-5.14.2 which is a virtual package.
 python3-uno : Conflicts: python-uno but 1:4.1.0-5 is to be installed.
 libxml-libxml-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libpango-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libtext-soundex-perl : Depends: perlapi-5.14.2 which is a virtual package.
 python-uno : Conflicts: python3-uno but 1:4.1.0-5 is to be installed.
 libsub-identify-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libglib-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libfile-fcntllock-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libperl5.14 : Depends: perl-base (= 5.14.2-21) but 5.18.1-2 is to be installed.
 libtext-iconv-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libperlio-gzip-perl : Depends: perlapi-5.14.2 which is a virtual package.
 libapt-pkg-perl : Depends: perlapi-5.14.2 which is a virtual package.
 liblist-moreutils-perl : Depends: perlapi-5.14.2 which is a virtual package.
 perlmagick : Depends: perlapi-5.14.2 which is a virtual package.
 libgjs0c : Breaks: libgjs0b but 1.32.0-5 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                                                                            
1)      aspell                                                                                                  
2)      aspell-en                                                                                               
3)      console-setup                                                                                           
4)      console-setup-linux                                                                                     
5)      debconf-i18n                                                                                            
6)      dictionaries-common                                                                                     
7)      empathy                                                                                                 
8)      enchant                                                                                                 
9)      eog                                                                                                     
10)     evolution                                                                                               
11)     evolution-data-server                                                                                   
12)     evolution-plugins                                                                                       
13)     gdm3                                                                                                    
14)     gedit                                                                                                   
15)     gedit-plugins                                                                                           
16)     gimp                                                          

Ответ на: комментарий от Excavator

оставил только

deb http://mirror.yandex.ru/debian/ testing main
deb-src http://mirror.yandex.ru/debian/ testing main

теперь пишет:

The following packages have unmet dependencies:
 python3-uno : Conflicts: python-uno but 1:4.1.0-5 is to be installed.
 python-uno : Conflicts: python3-uno but 1:4.1.0-5 is to be installed.
 libgjs0c : Breaks: libgjs0b but 1.32.0-5 is installed.
The following actions will resolve these dependencies:

      Remove the following packages:                                            
1)      eog                                                                     
2)      gedit                                                                   
3)      gedit-plugins                                                           
4)      gir1.2-peas-1.0                                                         
5)      gir1.2-rb-3.0                                                           
6)      gir1.2-totem-1.0                                                        
7)      gjs                                                                     
8)      gnome                                                                   
9)      gnome-core                                                              
10)     gnome-documents                                                         
11)     gnome-session                                                           
12)     gnome-shell                                                             
13)     gnome-shell-extensions                                                  
14)     gnome-sushi                                                             
15)     libpeas-1.0-0                                                           
16)     libtotem0                                                               
17)     rhythmbox                                                               
18)     rhythmbox-plugin-cdrecorder                                             
19)     rhythmbox-plugins                                                       
20)     task-gnome-desktop                                                      
21)     totem                                                                   
22)     totem-plugins                                                           
23)     unoconv                                                                 

      Keep the following packages at their current version:                     
24)     libgjs0c [Not Installed]                                                
25)     librhythmbox-core7 [Not Installed]                                      
26)     python3-uno [Not Installed]                                             

      Leave the following dependencies unresolved:                              
27)     gedit-common recommends gedit                                           
28)     gnome-control-center recommends gnome-session                           
29)     gnome-panel recommends gnome-session (>= 2.26)                          
30)     nautilus recommends gnome-sushi                                         
31)     rhythmbox-data recommends rhythmbox                                     
32)     task-desktop recommends task-gnome-desktop | task-kde-desktop | task-lxd
33)     task-gnome-desktop recommends gnome

fakeuser ()

Снеси сначала perlapi. И да, глобальные обновления лучше делать через apt-get.

eugeno ★★★★★ ()

Зачем вам тестируемый выпуск серверного дистрибутива, ставте Бубунту и все будет хорошо.

anonymous ()
Ответ на: комментарий от fakeuser

для больших обновлений лучше не использовать aptitude

apt-get upgrade && apt-get dist-upgrade

Excavator ()
Ответ на: комментарий от anonymous

У меня на одной из ВПСок работает Ubuntu Server, так вот эта дура при обновлениях тянет какой-то пакет для Firefox! И это серверная ОС! Да и десктопная тоже уже задолбала - каждый раз все более дебильные нововведения. Уже принципиально ей пользоваться больше не хочется. А в стабильном Дебиане через 3 минуты первоначальной настройки столкнулся с тем что версия libc6 2.13 и не поставить нужный по работе софт.

fakeuser ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.