LINUX.ORG.RU

wine32:i386 не устанавливается

 ,


0

1

содержание sources.list (система debian stretch, kde)

deb http://httpredir.debian.org/debian stretch main contrib non-free
deb-src http://httpredir.debian.org/debian stretch main contrib non-free

deb http://httpredir.debian.org/debian stretch-updates main contrib non-free
deb-src http://httpredir.debian.org/debian stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

делаю apt install wine32, выводит следующее:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine32:i386 : Depends: libwine:i386 (= 1.8.5-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Примерно месяц назад wine (32) стояла нормально, сейчас не хочет устанавливаться. В то же время apt install wine работает нормально, т.е. как я понимаю 64 битная устанавливается нормально.

★★

мультиарч подключен?

dpkg --add-architecture i386
apt update

LordTermor ★★ ()

Нашёл кажется причину. В системе установлена libfreetype6 версии 2.7, и новый libfontconfig1. Из-за этого не хочет установиться libwine:i386

apt install libwine:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libwine:i386 : Depends: libfontconfig1:i386 (>= 2.11) but it is not going to be installed
                Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
                Recommends: libasound2-plugins:i386 but it is not going to be installed
Это можно как-то исправить, кроме как удалив FreeType 2.7 и новый fontconfig?

devorg ★★ ()
Ответ на: комментарий от Deleted
apt-cache policy libwine:i386
libwine:i386:
  Installed: (none)
  Candidate: 1.8.5-1
  Version table:
     1.8.5-1 500
        500 http://httpredir.debian.org/debian stretch/main i386 Packages
devorg ★★ ()
apt-cache policy libfreetype6
libfreetype6:
  Installed: 2.7-0.1
  Candidate: 2.7-0.1
  Version table:
 *** 2.7-0.1 500
        500 http://download.opensuse.org/repositories/home:/stevepassert:/freetype-2.7/Debian_8.0  Packages
        100 /var/lib/dpkg/status
     2.6.3-3+b1 500
        500 http://httpredir.debian.org/debian stretch/main amd64 Packages
apt-cache policy libfontconfig1
libfontconfig1:
  Installed: 2.12.1-0.1
  Candidate: 2.12.1-0.1
  Version table:
 *** 2.12.1-0.1 500
        500 http://download.opensuse.org/repositories/home:/stevepassert:/freetype-2.7/Debian_8.0  Packages
        100 /var/lib/dpkg/status
     2.11.0-6.7 500
        500 http://httpredir.debian.org/debian stretch/main amd64 Packages
devorg ★★ ()
Ответ на: комментарий от devorg
apt-cache policy libfreetype6:i386
libfreetype6:i386:
  Installed: (none)
  Candidate: 2.7-0.1
  Version table:
     2.7-0.1 500
        500 http://download.opensuse.org/repositories/home:/stevepassert:/freetype-2.7/Debian_8.0  Packages
     2.6.3-3+b1 500
        500 http://httpredir.debian.org/debian stretch/main i386 Packages
apt-cache policy libfontconfig1:i386
libfontconfig1:i386:
  Installed: (none)
  Candidate: 2.12.1-0.1
  Version table:
     2.12.1-0.1 500
        500 http://download.opensuse.org/repositories/home:/stevepassert:/freetype-2.7/Debian_8.0  Packages
     2.11.0-6.7 500
        500 http://httpredir.debian.org/debian stretch/main i386 Packages
devorg ★★ ()

У меня всё установлено

deb http://httpredir.debian.org/debian stretch main contrib non-free
deb-src http://httpredir.debian.org/debian stretch main

deb http://httpredir.debian.org/debian stretch-updates main contrib non-free
deb-src http://httpredir.debian.org/debian stretch-updates main

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main

apt update apt dist-upgrade apt autoremove

и в последнее время надо следить за системой, могут меняться зависимости пакетов. Посмотри(aptitude или в synaptic) беспризорные пакеты(не связанные с репозитриями) и поудаляй. Заодно так можно неслабо разгрузить диск.

los_nikos ★★★★★ ()
Ответ на: комментарий от los_nikos

Он у ТС убран уже, судя по всему.
Пакеты от редактирования реп сами пока ещё не выпиливаются.

Deleted ()
Ответ на: комментарий от Deleted

но они будут считаться самостоятельно(локально) установленными, если я не путаю.

los_nikos ★★★★★ ()

Короче, запускаешь aptitude, нажимаешь на клаве u(update) и после этого глядишь в «Устаревшие и пакеты, созданные локально». В идеале там должно быть вообще пусто. Но тупым удалением всего там не отделаться - надо разгребать частями и заменять на пакеты debian stretch/testing. На опенсорсных драйверах Hearthstone(PlayOnLinux) в полный экран должен играться без рыпения, артефактов и тормозов. Steam(из репозиториев debian) ещё лучше должен работать, но с опенсорсными драйверами на последних версиях после обновлений клиента надо чистить каждый раз:

$ find $HOME/.steam/root/ubuntu12_32/steam-runtime/*/usr/lib/ \( -name "libstdc++.so.6" -o -name "libgpg-error.so.0"  -o -name "libxcb.so.1" -o -name "libgcc_s.so.1" \) -exec mv "{}" "{}.bak" \; -print

подключенные репозитории смотри в /etc/apt/sources.list.d/

los_nikos ★★★★★ ()
Последнее исправление: los_nikos (всего исправлений: 1 )
Ответ на: комментарий от los_nikos

Установил aptitude, запустил, открыл, посмотрел что там в «Obsolete and Locally Created Packages», ничего вроде не нашёл криминального, хотя фиг его знает, вот всё на скриншоте http://oi68.tinypic.com/98efrk.jpg.

По поводу команды: вывело вот что

find .steam/root/ubuntu12_32/steam-runtime/*/usr/lib/ \( -name "libstdc++.so.6" -o -name "libgpg-error.so.0"  -o -name "libxcb.so.1" -o -name "libgcc_s.so.1" \) -exec mv "{}" "{}.bak" \; -print
.steam/root/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libxcb.so.1
.steam/root/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libxcb.so.1

Нестандартные репозитарии:

deb http://download.opensuse.org/repositories/home:/stevepassert:/freetype-2.7/Debian_8.0/ /
Это новый freetype 2.7 и новый fontconfig, для debian.
deb [arch=amd64] https://repo.skype.com/deb stable main
Skype.
deb http://repository.spotify.com stable non-free
Spotify.

devorg ★★ ()
Ответ на: комментарий от los_nikos

Убрал, это ни на что не влияет. FreeType 2.7 из того репозитария всё равно уже стоит в системе. И удалять я её не хочу, вот в чём дело.

devorg ★★ ()
Ответ на: комментарий от Deleted

Если я так сделаю (libfreetype6=2.6.3-3+b1 libfontconfig1=2.11.0-6.7) то удалится freetype 2.7, мне это не нужно! А первая часть (libfreetype6:i386=2.6.3-3+b1 libfontconfig1:i386=2.11.0-6.7) не пашет, выводит опять кучу i386 зависимостей каких то...

apt install libfreetype6:i386=2.6.3-3+b1 libfontconfig1:i386=2.11.0-6.7
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libasound2-plugins : Depends: libavcodec57 (>= 7:3.0) but it is not going to be installed or
                               libavcodec-extra57 (>= 7:3.0) but it is not going to be installed
 libchromaprint1 : Depends: libavcodec57 (>= 7:3.1.3) but it is not going to be installed or
                            libavcodec-extra57 (>= 7:3.1.3) but it is not going to be installed
 libguvcview-2.0-2 : Depends: libavcodec57 (>= 7:3.0) but it is not going to be installed or
                              libavcodec-extra57 (>= 7:3.0) but it is not going to be installed
 libquicktime2 : Depends: libavcodec57 (>= 7:3.2.1) but it is not going to be installed or
                          libavcodec-extra57 (>= 7:3.2.1) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

devorg ★★ ()
Ответ на: комментарий от devorg

Нет, это всё надо чистить. У меня один пакет яндекс-браузера. Особенно старое ядро и эти libtxcбла-бла-c-ноликом-на-конце - в репах есть эти библиотеки без ноликов, а эти не дают им встать на их место по зависимостям(а без них Steam не работает). Все сторонние репозитории отключи пока, opensuse вообще удали - он тебе систему ломает. Остальные пакеты - всё что накопилось на них уже есть новые версии, но у тебя они до сих пор чего-то делают, значит чего-то некорректно обновилось и с большой вероятностью уже не обновляется. .

Эту «find» надо запускать когда всё работает и прошло обновление Steam в самом клиенте, уже после выхода из Steam. Он удаляет ненужные свободным драйверам библиотеки клиента Steam(если nvidia - пользуйся проприетарными).

Ну, если всё работает... я пошёл.

los_nikos ★★★★★ ()
Последнее исправление: los_nikos (всего исправлений: 1 )
Ответ на: комментарий от los_nikos

Удалил всё, это никак не повлияло. Два файла удалить не могу, от них зависят spotify и libfreetype6 2.7: libssl1.0.0, libpng12-0. Собственно я знаю что удалив freetype 2.7 у меня всё заработает, я об этом писал выше 2 дня назад. Вопрос в том как оставить freetype 2.7 и установить при этом wine32.

devorg ★★ ()
Ответ на: комментарий от devorg

ну я и говорю, в поиске есть соответствующий ppa: https://launchpad.net/~no1wantdthisname/ archive/ubuntu/ppa?field.series_filt...

Поисковик сразу выдал, не два дня искал... Но я не проверял. Yakkety и xenial обычно очень хорошо работают в stretch.

los_nikos ★★★★★ ()
Ответ на: комментарий от Deleted

Да ну его, потом не разберёшь чего надо поставить, имена не везде одинаковые у пакетов. aptitude и стим удаляет просто из-за неустановленного steam-devices, а ведь он есть в репозиториях, Лучше отдельно поставить. Но спасибо за ключик.

los_nikos ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.