LINUX.ORG.RU

Ответ на: комментарий от GotF

Очень сильно боюсь показаться глупым. Но спрошу. Я скачал оттуда linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb И что дальше с ним делать? пробую установить через Gdebi Package installer . И мне выдаёт эту ошибку Error: Dependency is not satisfiable: linux-base (>= 3~). Что делать?

Deleted ()
Ответ на: комментарий от neocrust

apt-get -f install

Ну и предварительно подключить backports, т.к. linux-base нужной версии только там.

GotF ★★★★★ ()
Ответ на: комментарий от neocrust

В /etc/apt/sources.list добавил запись deb http://www.backports.org/debian lenny-backports main contrib non-free
далее

test@debian:~$ su
Пароль: 
root@debian:/home/test# cd '/home/test/Загрузки'  && ls -l
итого 346120
-rw-r--r-- 1 test test  30604308 Фев 16 08:36 linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb
-rwxrwxrwx 1 test test 323458185 Фев 16 08:34 linux-image-2.6.39-bpo.2-amd64-dbg_2.6.39-3~bpo60+1_amd64.deb
root@debian:/home/test/Загрузки#


apt-get -f install ./linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb
Выведено оочень много строк. Примерно такого вида.
Заметьте, выбирается libghc-attoparsec-enumerator-prof для регулярного выражения .
Заметьте, выбирается libghc-attoparsec-text-dev для регулярного выражения .
Заметьте, выбирается libghc-attoparsec-dev-0.10.0.3-05700 для регулярного выражения .
Заметьте, выбирается libghc-attoparsec-text-doc для регулярного выражения .
Заметьте, выбирается libghc-attoparsec-text-prof для регулярного выражения .


Далее всё заканчивается примерно этим.
E: Выпуск 'linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb' для 'python-zope.app.folder' не найден
E: Выпуск 'linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb' для 'python-zope.app.securitypolicy' не найден
E: Выпуск 'linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb' для 'python-zope.app.testing' не найден
E: Выпуск 'linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb' для 'python-zope.app.zcmlfiles' не найден
E: Выпуск 'linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb' для 'python-zope.app.applicationcontrol' не найден
E: Выпуск 'linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb' для 'python-zope.app.zptpage' не найден
E: Выпуск 'linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb' для 'amd64-libs' не найден
E: Выпуск 'linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb' для 'linux-image-2.6.39-bpo.2-amd64' не найден



root@debian:/home/test/Загрузки# dpkg -i linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb
dpkg: относительно linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb, содержащего linux-image-2.6.39-bpo.2-amd64:
 linux-image-2.6.39-bpo.2-amd64 ломает initramfs-tools (<< 0.99~)
  initramfs-tools (версия 0.98.8) существует и установлен.
dpkg: не удалось обработать параметр linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb (--install):
 установка linux-image-2.6.39-bpo.2-amd64 сломает initramfs-tools, и
 деконфигурация не разрешена (--auto-deconfigure может помочь)
При обработке следующих пакетов произошли ошибки:
 linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb
root@debian:/home/test/Загрузки# 
Deleted ()
Ответ на: комментарий от GotF
root@debian:/home/test/Загрузки# apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 16 пакетов не обновлено.

Записал новый адрес в /etc/apt/sources.list но всё никак (

Deleted ()
Ответ на: комментарий от Deleted

Это надо делать после dpkg -i. Пакет ставить так:

dpkg --force-depends-version -i linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb

Кстати, обязательно именно 39-е? Сейчас в бэкпортах есть поддерживаемое 3.2.

GotF ★★★★★ ()
Ответ на: комментарий от GotF

Да, к сожалению нужно именно это ядро (((
Сейчас делаю :

root@debian:/home/test/Загрузки# dpkg --force-depends-version -i ./linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb
dpkg: относительно .../linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb, содержащего linux-image-2.6.39-bpo.2-amd64:
 linux-image-2.6.39-bpo.2-amd64 ломает initramfs-tools (<< 0.99~)
  initramfs-tools (версия 0.98.8) существует и установлен.
dpkg: не удалось обработать параметр ./linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb (--install):
 установка linux-image-2.6.39-bpo.2-amd64 сломает initramfs-tools, и
 деконфигурация не разрешена (--auto-deconfigure может помочь)
При обработке следующих пакетов произошли ошибки:
 ./linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb

Deleted ()
Ответ на: комментарий от Deleted

зачем ./ то? вы же выполняете команду в той же папке, где лежит пакет.

Делай раз:

dpkg --force-depends-version -i linux-image-2.6.39-bpo.2-amd64_2.6.39-3~bpo60+1_amd64.deb

Делай два:

apt-get -f install

ymn ★★★★★ ()
Ответ на: комментарий от Deleted
aptitude -t squeeze-backports install initramfs-tools linux-base

После этого ставь ядро (без --force-... должно поставиться) а «apt-get -f ...» уже не понадобится.

GotF ★★★★★ ()
Ответ на: комментарий от Deleted

а нет никаких способов попроще эти ядра установить???

[fat16] make -j4; make modules_install; cp arch/x86/boot/bzImage /boot/

anonymous ()
Ответ на: комментарий от Deleted

И ещё хочу узнать, что значат эти числа
К примеру ввожу uname -a ,мне выдаёт версию ядра, к примеру 2.6.32.36-228-scalaxy
И вот мне интересно число 228 что означает? да и scalaxy Если я буду собирать модуль скажем для 2.6.32.36-200-scalaxy он запустится на ядре 2.6.32.36-228-scalaxy ?

Deleted ()

тебе нужны бэкпорты (bpo это сокращение от backport). первая ссылка в гугле приведёт на нужный сайт, там есть все инструкции как подключить репозиторий. Можно и руками скачать и через dpkg вкрячить ведро, но тогда не будут прилетать обновления.

true_admin ★★★★★ ()
Ответ на: комментарий от Deleted

Аналогично и на другие дистрибутивы ядра ставить?

нет, эти «шаманства» дистрибутивозависимые.

А зачем тебе именно это ядро понадобилось?

true_admin ★★★★★ ()

устанавливай (компилируй) )))

ipwww ★★ ()
Ответ на: комментарий от true_admin

Это мне по работе нужно. Сам я никогда не нуждался в установке подобных ядер, всегда хватало стандартного обновления системы.
Вот снова проблема, но уже с ядром 2.6.32.36-228-scalaxy где взять такое? где искать? как понял это ubuntu , на сайте (http://archive.ubuntu.com/ubuntu/pool/main/l/linux/) есть ядра 2.6.32.36 но ни одного scalaxy . В чём вообще отличие generic , preempt, generic-pae, server ? Ну и самое основное..гдеж взять этот scalaxy ???

Deleted ()
Ответ на: комментарий от Deleted

Это мне по работе нужно

ну это понятно. Вопрос для чего. Но если это секрет то ладно.

true_admin ★★★★★ ()
Ответ на: комментарий от Deleted

Вот снова проблема, но уже с ядром 2.6.32.36-228-scalaxy где взять такое?

А если «погуглить» по слову «scalaxy», то можно найти сайт: https://www.scalaxy.ru/ .

В чём вообще отличие generic , preempt, generic-pae, server ?

В каждой редакции любого дистрибутива используется своя версия ядра, более новая, относительно предыдущих редакций. Разработчики дистрибутива осуществляют сборку ядра с некоторым набором опций ядра, для достижения различных целей, как правило это поддержка максимального набора оборудования, которое поддерживает эта версия ядра с патчами, которые наложили разработчики. Эту версию, к примеру для Ubuntu, можно назвать Generic.

Ядро с префиксом preempt скорее всего собрано с опцией CONFIG_PREEMPT, для снижения задержек в режиме реального времени работы операционной системы. Это ядро для системы реального времени.

Ядро с префиксом generic-pae существует только в 32 битной версии, т.к. в нём задействовано расширение Physical Address Extension при задействовании которого 32 битная система может адресовать больше 4 гигабайт оперативной памяти. 64 битная версия и так может работать с памятью больше 4 гигабайт.

Ну а в ядре с префиксом server задействованы опции не нужные на обычной Desktop системе и важные для применения в серверных системах, специализированные драйверы, специальные планировщики ввода/вывода, kvm (возможно) и прочее.

И всё же что вы такое хотите настроить, что вам требуются именно эти версии ядер. Предположу, что вы читайте кем-то написанное руководство, покажите. Скорее всего не обязательно использовать именно эти ядра, их скорее всего привели как пример., и уж тем более именно эти версии ядер.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

kostik87
Спасибо за пояснение.
Продолжу глупые вопросы, как получить исходники для этого ядра? (headers source) 2.6.39-bpo.2-amd64

Deleted ()
Ответ на: комментарий от Deleted

Linux headers - это не исходники ядра. Это лишь заголовочные файлы (<file>.h) и параметры, с которыми было собрано ядро, в частности ядро linux-image-2.6.39-bpo.2-amd64 вы сможете установить linux-headers, если у вас будет установлено это ядро.

Зачем вам нужно конкретно это ядро ?

kostik87 ★★★★★ ()
Ответ на: комментарий от anonymous

Хорошо, я ошибся, напишите правильный ответ, но ошибся я не сильно, т.к. эта опция позволяет прервать выполнение менять приоритет процесса, что позволит его раньше прервать (переключиться с него).

kostik87 ★★★★★ ()
Ответ на: комментарий от GotF

а чего это, серьёзно, в debian даже в тестинге ядро собрано без PREEMPT?

как они это оправдывают? не юзабельно же при заметной нагрузке на систему

anonymous ()
Ответ на: комментарий от kostik87

правильный ответ: CONFIG_PREEMPT включает вытесняемое ядро; те процесс может быть прерван шедулером, находясь в сисвызове; это увеличивает отзывчивость на десктопе

real-time это совсем другой вопрос; возможности для его реализации в стандартном ядре линукса нет; но есть отдельный патч, и соотв. опция в его конфиге: CONFIG_PREEMPT_RT_FULL

кстати, ядро с rt-патчем в дебиане есть а с обычным preempt нет, хз чо они курят

anonymous ()
Ответ на: комментарий от anonymous

Спасибо за уточнение. Насчёт того, что в обычном ядре нет поддержки жёсткого и мягкого реального времени я в курсе. Но «в живую» т.к. сказать не работал с такой системой и не настраивал. Только QNX.

kostik87 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.