LINUX.ORG.RU

Ошибка при сборке xfree86-4.8.0


0

1

При попытке собрать на OpenSUSE 11.2 вышеуказанное получаю ошибку

../../config/makedepend/makedepend: warning: /usr/include/gnu/stubs-32.h: non-portable whitespace encountered at line 7 ../../config/makedepend/makedepend: warning: ftapi.c (reading /usr/include/limits.h, line 125): cannot find include file «limits.h» not in /usr/lib/gcc/i586-suse-linux/4.4/include/limits.h ../../config/makedepend/makedepend: warning: ftapi.c (reading ./freetype/config/ftconfig.h), line 84: #error «Unsupported size of `int' type!» ../../config/makedepend/makedepend: warning: ftapi.c (reading ./freetype/config/ftconfig.h), line 94: #error «Unsupported size of `long' type!» make[3]: *** [depend] Исключение в операции с плавающей точкой make[3]: Leaving directory `/mnt/sources/XFree86-4.8.0/~build/lib/freetype2' make[2]: *** [depend] Ошибка 2 make[2]: Leaving directory `/mnt/sources/XFree86-4.8.0/~build/lib' make[1]: *** [depend] Ошибка 2

Помогите побороть :-(

Этот проект умер, нужно использовать x.org

xorik ★★★★★ ()
Ответ на: комментарий от xorik

+в бинарном дистрибутиве не принято собирать пакеты, их берут в пакетном менеджере

xorik ★★★★★ ()
Ответ на: комментарий от xorik

хорошо. пробую собрать x.org-server 1.7.1

выдает ошибки:

checking for XLIB... yes checking for GL... configure: error: Package requirements (glproto >= 1.4.9 gl >= 7.1.0) were not met:

скачал и установил glproto 1.4.10,ошибка та же. Что есть GL >=7.1.0? Это OpenGL ?

IlyamI ()
Ответ на: комментарий от IlyamI

Зачем компилировать софт, если это уже сделано создателями дистрибутива?

xorik ★★★★★ ()
Ответ на: комментарий от IlyamI

в отличие от xfree86, xorg стал модульным,
в config.log можно посмотреть что имелось ввиду под gl (скорее всего это меза, новый xorg-server не требует мезу для сборки)

Sylvia ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.