LINUX.ORG.RU

Проблема с LILO


0

0

У меня два винта. На одном висит вин, в загрузочном секторе висит GRUB, на другом висел Debian. Отдал винт с Debian'ом на растерзание Zenwalk'у. Поставился, поставил в загрузочную область своего диска LILO, запустился, все ок. Но не запускется винда. При ее выборе в меню LILO появляется Starting Windows и на этом все заканчивается. Пробовал сделать конфиг для GRUB'а по аналогии с тем, что был в Debian'е, но видимо руки кривые. Что посоветуете?

Заранее спасибо.


Re: Проблема с LILO

Например, восстановить загрузочные сектора Windows и повторно поставить  GRUB. 
GRUB может капризничать если в /boot/grub/device.map неправильно прописаны диски. 
Должно быть примерно следующее:

device.map:
(hd0)   /dev/hda
(hd1)   /dev/hdb

grub.conf:
# Boot automatically after 30 secs.
timeout 10
default 0
# For booting GNU/Linux
title  Linux
root (hd1,0)
kernel /boot/bzImage root=/dev/hdb1
initrd /boot/initramfs
# For booting Windows NT
title Windows NT
rootnoverify (hd0,0)
makeactive
chainloader +1

acheron ★★★★ ()
Ответ на: Re: Проблема с LILO от acheron

Re: Проблема с LILO

Уже пропобовал вручную настраивать GRUB, но всегда Error 15, хотя в правильности путей я не сомневаюсь (вроде бы))

А как восстановить загрузочные секторы Windows?

И все таки интересно почему LILO не хочет Windows запустить.

Ximik ()
Ответ на: Re: Проблема с LILO от Ximik

Re: Проблема с LILO

http://www.linux.org.ru/books/lor-faq/ , в первую очередь -- http://www.linux.org.ru/books/lor-faq/lorFAQ-17.html#ss17.9

> А как восстановить загрузочные секторы Windows?

Плохо помню, но вроде надо загрузиться в консоль восстановления и написать fixmbr и fixroot .

> почему LILO не хочет Windows запустить.

Помочь не могу, LILO почти не пользовался.

> всегда Error 15

"This error is returned if the specified file name cannot be found, but everything else (like the disk/partition info) is OK.

Попробуй в меню GRUB нажать c и в командном режиме вводить все те же команды, используя автодополнение по табу, а затем -- boot:

root (hd1,0)

kernel /boot/bzImage

initrd /boot/initramfs

boot

acheron ★★★★ ()
Ответ на: Re: Проблема с LILO от acheron

Re: Проблема с LILO

LILO не может загрузить винду с другого диска. Баг у нее такой как мне объяснили.

В общем проблему решил просто. Разозлился, снес дзэн и постаил старую добрую убунту )

Ximik ()
Ответ на: Re: Проблема с LILO от Ximik

Re: Проблема с LILO

У меня без проблем грузил. Винда на первом диске была, а мандрива на втором(два харда). И ЛИЛО стоял в МБР. Только вот подцепил третий хард и поставил федору 7. Ни виндов ни мандривы. Пока еще не разобрался.

biozz ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.