LINUX.ORG.RU

apt предлагает сделать даунгрейд браузеров

 ,


0

1

Всем привет!

Подправил sources.list, заменил bullseye на bookworm. Сделал apt-get update && apt-get dist-upgrade, обновил систему. Вроде все хорошо, но когда пытаюсь снова выполнить команду выше, apt предлагает мне сделать даунгрейд chromium и Firefox. Кто-нибудь сталкивался? они что, в bullsyeye новее? Всегда использую стабильную ветку.


а ты точно из дебъяновской репы хромиум тащищь ??
https://packages.debian.org/bullseye/chromium 114.0.5735.198-1~deb11u1
https://packages.debian.org/bookworm/chromium 114.0.5735.198-1~deb12u1

версии идентичны, но в книгочерве модификация (локальные патчи дебъяна) чутка побольше номером.

pfg ★★★★★
()
Ответ на: комментарий от pfg

Посмотрел версии.

root@devuan:/home/pete# apt list -a chromium
Вывод списка… Готово
chromium/stable-security 114.0.5735.198-1~deb12u1 i386
chromium/now 114.0.5735.90-2~deb12u1 i386 [установлен, локальный]
chromium/stable 113.0.5672.126-1 i386

root@devuan:/home/pete# apt list -a firefox-esr
Вывод списка… Готово
firefox-esr/stable-security,now 102.12.0esr-1~deb12u1 i386 [установлен]
firefox-esr/stable 102.11.0esr-1 i386

stable-security по какой-то причине предлагает более свежие пакеты, чем stable.

На всякий случай мой sources.list:

deb http://deb.debian.org/debian/ bookworm main contrib non-free non-free-firmware
deb-src http://deb.debian.org/debian/ bookworm main contrib non-free non-free-firmware

deb http://deb.debian.org/debian/ bookworm-updates main contrib non-free non-free-firmware
deb-src http://deb.debian.org/debian/ bookworm-updates main contrib non-free non-free-firmware

deb http://security.debian.org/debian-security/ bookworm-security/updates main contrib non-free non-free-firmware
deb-src http://security.debian.org/debian-security/ bookworm-security/updates main contrib non-free non-free-firmware

deb http://deb.debian.org/debian/ bookworm-backports main contrib non-free non-free-firmware
deb-src http://deb.debian.org/debian/ bookworm-backports main contrib non-free non-free-firmware

deb http://www.deb-multimedia.org bookworm main non-free
deb http://www.deb-multimedia.org bookworm-backports main

#deb https://dl.winehq.org/wine-builds/debian/ stable main
baobab
() автор топика
Ответ на: комментарий от baobab

stable-security по какой-то причине предлагает более свежие пакеты, чем stable.

А как по твоему мнению должно быть?

Вопрос в другом почему security репозиторий имеет приоритет ниже чем основной.

apt-cache policy chromium что говорит?

einhander ★★★★★
()
Ответ на: комментарий от einhander
# apt-cache policy chromium
chromium:
  Установлен: 114.0.5735.90-2~deb12u1
  Кандидат:   113.0.5672.126-1
  Таблица версий:
     114.0.5735.198-1~deb12u1 500
        500 http://security.debian.org/debian-security bookworm-security/updates/main i386 Packages
 *** 114.0.5735.90-2~deb12u1 100
        100 /var/lib/dpkg/status
     113.0.5672.126-1 1001
       1001 http://deb.debian.org/debian bookworm/main i386 Packages
baobab
() автор топика
Ответ на: комментарий от baobab

У тебя security репозиторий имеет меньший приоритет, чем основная репа, поэтому и хочет даунгрейдится.

Показывай теперь /etc/apt/preferences

У тебя хостнейм devuan, это апгрейженный до дебиана девуан?

einhander ★★★★★
()
Последнее исправление: einhander (всего исправлений: 2)
Ответ на: комментарий от baobab

У тебя слишком высокий приоритет основного репозитория. Значение больше 1000 означает, что версии из этого репозитория настолько важны, что их нужно устанавливать даже с даунгрейдом. Понизь приоритет до 500 (ищи, где он прописан где-то в глубинах /etc/apt).

TeopeTuK ★★★★
()

einhander, TeopeTuK Спасибо за помощь! Действительно, нашелся файлик

/etc/apt/preferenced.d/downgrade
со следующим содержимым:
Package: *
Pin: release a=stable
Pin-Priority: 1001
По-моему, я его создал несколько лет назад, когда после обновления иксы стали глючить, и нужно было сделать их даунгрейд.

Что касается системы, да, это бывший девуан. Я не стал ждать обнов и просто прописал дебиановские репы, хоть так и не рекомендуется делать. Мой локалхост в таком виде перенес уже где-то 3 или более апгрейда, а systemd так и не появился.

baobab
() автор топика