LINUX.ORG.RU

Установка Elementary 5.0, ошибка как в стоковой убунте.

 , , ,


0

1

Предисловие: Нужно поставить хорошую операционную систему, при этом свалить с windows, так как ноутбук некорректно ведет себя под ней, плюс я не пользуюсь им. Ноутбук редкостный и старый. Asus X53B. Выбор пал на ряд убунтовых. Не ставятся никакие с флешки, пошел гуглить ошибку: люди на ангоязычных форумах советовали записать на диск установщик.

Записал через xfburn с основой рабочей машины с elementary. Результат: первый диск ноутбук не прочитал нормально - I/O error(логично почему), нашел более целый. Второй прочитал нормально. G_UDEV_IS_DEVICE_FAILED. После загружаются некоторые модули и дальше примерно следующая картина: task (до бесконечности какая, допустим gpu-manager:821) blocked for more than 120 seconds. Тыц. Установка в UEFI

До этого была установка в Legacy. Загрузчик был чудесным образом пропущен, но ошибка та же самая... Прошу помощи Биос последний. Еще не пробывал установку со включенным IDE. Биос по настройкам минимален, и будто урезан.

Upd. Offtopic: пол года назад дело было заброшенно, т.к. убунта ставится не хотела и времени не было. Сейчас просто выкидывать старье не хочется, возможно есть смысл поставить что-то полегче, чем elementary... Но к сожалению ничего не грузится.

элементари не очень легкая, то что она позиционируется простой не делает ее легкой по потреблению ресурсов. последний биос не всегда самый лучший. если у тебя затык с деб-подобными дистрибами, попробуй сначала более старую убунту поставить и не с гномом, который по умолчанию. попробуй например lubuntu 14.04. если то же самые ошибки, то rpm дистрибы, федора или опенсусе. у них так же лучше выбрать не тяжелые де типа xfce. дальше последняя остановка в виде манджаро, если он тоже будет тупить то можно толкнуть ноут на авито, ну или поковырять фрибсд. так же можно откатить биос попробовать.

chenbr0 ()

UPD! Нарыл инфу, что на новых ROG-ах (игровые ноутбуки) такие же проблемы с установкой.

Вообщем.

https://smartechknowledge.blogspot.com/2018/05/dual-booting-windows-10-and-ub...

Дуалбутинг тут не причем. Система загрузилась после удаления quite splash и его замены на nomodeset. Не в максимальном разрешении естественно. Понятно, что придется решать проблемы с радеоном.

В логе проскачило: *ERROR* No UMS support in radeon module!

Люди решают это аргами в грабе, но не факт конечно что в этом только и дело. Нужно смотреть. В любом случае мысли по поводу проблемы не помешали бы... Спасибо

HiGuiz1 ()

Облом...

Елементари установился, запускается. Графическая оболочка не стартует. Если запускать систему без splash можно попасть в консольный логин экран. Все я уже впадаю в панику ...

HiGuiz1 ()
Ответ на: Облом... от HiGuiz1

don't panic! kernel ready

запускается. Графическая оболочка не стартует

наверное, «там» какие-то проблемы с видеокартой/драйверами на неё. логинься в консоль, сохраняй логи. смотри, что там за ошибки (и вообще)...

Удачи!

anymouze ()
Ответ на: don't panic! kernel ready от anymouze

Thanks pal! But...

Время просто не резиновое :(

Смогу ближе к 11 по мск скинуть логи (10 часов Прибалтика).

На дебиан скретч читаю, что гибридную графику надо будет заводить... Но прикол в том, что пакет гибридной графики в дебиан уже внедрён, что стало интересно. Правда он в бете, но всё же...

(Для общего развития стоит попытаться сперва завести дуалграфику в ubuntu-based дерьме...) Вообщем вот так вот. Интересная особенность: если использовать арг nomodeset, то система грузится в Лоу разрешении до локскрина, а после ввода пароля локскрина появляется заново, т.е. рабочее окружение не загружается.

(Нужно снимать логи и развивать свой мозг ламера)

HiGuiz1 ()
Ответ на: Thanks pal! But... от HiGuiz1

если использовать арг nomodeset, то система грузится в Лоу разрешении до локскрина, а после ввода пароля локскрина появляется заново

В домашнем каталоге юзера смотри .xsession-errors (и .xsession-errors.old), и конечно /var/log/messages (или через sudo dmesg>> ~/dmesg.log)

anymouze ()