LINUX.ORG.RU

Обновление Arch Linux на ядро 4.18.1 и черный экран

 , ,


0

1

Господа, кто уже обновлялся? Как прошло? У меня на ноутбуке со встроенной графикой Intel нормально. На десктопе AMD Vega 64, после обновы не грузится, лицезрею черный экран, при этом монитор говорит что сигнал вместо HDMI 4K воспринимает как DVI FullHD - очень интересный баг. Откатился пока на 4.17.14 - полет нормальный. Может кто ткнет пальцем, куда глядеть, что делать? На арче недавно совсем.

Ответ на: комментарий от BLIN4IK97

Арчер, ненавистник всего тяжелого, проприетарного!

Просто отпишусь об Нвидии, полёт нормальный...

Хмм, что-то не сходится

Deleted ()

Может кто ткнет пальцем, куда глядеть, что делать?

Переустановить драйвер видеоадаптера или откатиться на прежнее ядро.

Сейчас проверил переход на ядро 4.18.2 с ядра по умолчанию в Ubuntu (Arch Linux у меня нет и не может быть, так что извиняйте за недопроверку в нём). Мне это обновление ядра не нужно (предпочитаю стабильность), но решил убедиться, что проблема с драйверами не возникнет. Видеоадрайвер AMD у меня «проприетарный», с сайта AMD (там есть для Ubuntu и некоторых других дистрибутивов, но не для Arch Linux. Следовательно, любители Arch Linux как-то выкручиваются. Ну, это их проблема). Значит, у меня драйвер видеоадаптера должен был автоматически переустановиться потому, что установлен через dkms (стандартным скриптом установки). Ещё у меня Wi-Fi адаптер на микросхеме Realtek RTL8812AU (Tenda U12, купил для проверки его работы в Linux) с драйвером, установленным мной через dkms, продолжает работать. Но если бы драйвера после автоматической переустановки оказались бы несовместимы с новым ядром, пришлось бы их переустанавливать.

Проверить можно с помощью dkms status

Вот результат у меня:

amdgpu, 18.20-606296, 4.15.0-30-generic, x86_64: installed amdgpu, 18.20-606296, 4.15.0-32-generic, x86_64: installed rtl8812au, 5.2.20, 4.15.0-30-generic, x86_64: installed rtl8812au, 5.2.20, 4.15.0-32-generic, x86_64: installed rtl8812au, 5.2.20, 4.18.2-041802-generic, x86_64: installed

Драйвер для AMD для новой версии ядра не перечислен, но всё же работает. Похоже, переустановился с ошибкой. Сейчас попробую переустановить вручную. (Хотя на вид глюков нет, и разрешение 4K так и осталось).

Если у вас на dkms status будет сообщение, что нет такой команды, то значит dkms не установлено, и значит драйвер установлен не через dkms. Но раз он не работает, то в любом случае переустанавливать его.

Partisan ★★★★ ()
Ответ на: комментарий от Deleted

Ну не все же должны быть убер неадекватами.

anonymous ()

У меня к ноутбуку подключен монитор c разрешением 2560x1440 по hdmi. На этом мониторе в консоле после обновления до 4.18.1 разрешение уменьшилось, при этом на экране ноутбука всё нормально. Но иксы грузятся, в них проблем не наблюдаю, с разрешением там всё хорошо. Карта Intel HD 620 (хотя в ноуте есть ещё amd radeon r7 m445)

tm4ig ()
Последнее исправление: tm4ig (всего исправлений: 1)

dmesg / X log смотреть. ручками ядро собирать...

darkenshvein ★★★★★ ()
Ответ на: комментарий от q13

ТА ЕТО ХУАНГ НАБРАСЫВАЕТ НА ВЕНТИЛЯТОР

anonymous ()

Продолжай и дальше держать нас в курсе. И всё верно логи для слабаков!

init_6 ★★★★★ ()
Ответ на: комментарий от post-factum

УМВР, но у меня Интел.

интуиция подсказывает что у разработчиков линукса тоже только интел.

barberry ★★ ()
Ответ на: комментарий от RRR1993

Для чистоты эксперимента сейчас накатил чистый дистр, обновил, оболочку не стал ставить, проходит загрузку, попадает в терминал, показывает на секунду строку терминала с приглашением и бац, черный экран.

zasyadko ()
Ответ на: комментарий от Deleted

Ага, судя по этой теме, например. Тем хуже для фактов, как говорится.

anonymous ()

Совсем беда какая-то, думаю черт с ним, параллельно поставлю LTS ядро, воткнул, в кеды попасть не могу, останавливается загрузка после Reached target graphical interface :(

zasyadko ()
Ответ на: комментарий от greenman

Установлен, переставил для верности, результат тот же

zasyadko ()
Ответ на: комментарий от zasyadko

Что в логаз xorg-server, /var/log/Xorg.0.log? Что в выводе dmesg на новом ядре и на старом, котором всё работает?

anonymous ()
Ответ на: комментарий от zasyadko

Похоже, в 4.18 намудрили (могли и в lts бэкпортировать, бывает), не зря менее чем за неделю выпустили уже 4.18.3

4.18.3 уже в тестинг, может завтра в [core] переведут.

greenman ★★★★★ ()
Ответ на: комментарий от RRR1993

Сейчас на LTS ядре, tty пашет, лог xorg ругается мол: device(s) detected, but none match those in the config file. Fatal server error. No screens found. Вчерашнее рабочее ядро уже похерил. Самое свежее лежит сейчас, но на нём в tty не попасть.

zasyadko ()

Пока вернулся обратно на 4.17.14, работает. А я так ждал 4.18, обещали вегам новые дрова завезти... 4.14 LTS, кажется мне, и раньше не взлетал на моем железе. Будем наблюдать дальше за обновами, оставлю основную ветку и lts, потестим потом еще. Может быть новому ядру «не нравится» не только сама вега, но и то что их четыре. Подождем, посмотрим.

zasyadko ()
Ответ на: комментарий от Deleted

Ну так нвидия хороша благодоря CUDA, не будь её, взял бы радеон

BLIN4IK97 ()

Прилетело 4.18.3. Попробовал, результат тот же, изображения нет, в tty попасть не могу. Как бы в этой ситуации логи отловить?

zasyadko ()
Ответ на: комментарий от zasyadko

А если в опции загрузки добавить 3 (aka multiuser.target, т.е. загрузиться без графики; далее wgetpaste или аналог)

В принципе, логи можно посмотреть и после перезагрузки с рабочим ядром. /var/log/Xorg.0.log.old и sudo journalctl -b -1

либо

https://wiki.ubuntu.com/Kernel/Netconsole

https://wiki.archlinux.org/index.php/Netconsole

greenman ★★★★★ ()
Последнее исправление: greenman (всего исправлений: 1)

Достал логи Xorg'а с ядра 4.18.3. Может кто подскажет чего он болеет то так?

[    14.146] (--) Log file renamed from "/var/log/Xorg.pid-1115.log" to "/var/log/Xorg.0.log"
[    14.147] 
X.Org X Server 1.20.1
X Protocol Version 11, Revision 0
[    14.147] Build Operating System: Linux Arch Linux
[    14.147] Current Operating System: Linux fractal 4.18.3-arch1-1-ARCH #1 SMP PREEMPT Sat Aug 18 09:22:54 UTC 2018 x86_64
[    14.147] Kernel command line: initrd=\initramfs-linux.img root=/dev/nvme0n1p2 rw
[    14.147] Build Date: 09 August 2018  06:37:34PM
[    14.147]  
[    14.147] Current version of pixman: 0.34.0
[    14.147] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    14.147] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    14.147] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug 22 02:46:36 2018
[    14.147] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    14.147] (==) No Layout section.  Using the first Screen section.
[    14.147] (==) No screen section available. Using defaults.
[    14.147] (**) |-->Screen "Default Screen Section" (0)
[    14.147] (**) |   |-->Monitor "<default monitor>"
[    14.147] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    14.147] (==) Automatically adding devices
[    14.147] (==) Automatically enabling devices
[    14.147] (==) Automatically adding GPU devices
[    14.147] (==) Automatically binding GPU devices
[    14.147] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    14.147] (WW) The directory "/usr/share/fonts/misc" does not exist.
[    14.147] 	Entry deleted from font path.
[    14.147] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[    14.147] 	Entry deleted from font path.
[    14.147] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    14.147] 	Entry deleted from font path.
[    14.147] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[    14.147] 	Entry deleted from font path.
[    14.147] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[    14.147] 	Entry deleted from font path.
[    14.147] (==) FontPath set to:
	/usr/share/fonts/TTF
[    14.147] (==) ModulePath set to "/usr/lib/xorg/modules"
[    14.147] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    14.147] (II) Module ABI versions:
[    14.147] 	X.Org ANSI C Emulation: 0.4
[    14.147] 	X.Org Video Driver: 24.0
[    14.147] 	X.Org XInput driver : 24.1
[    14.147] 	X.Org Server Extension : 10.0
[    14.148] (++) using VT number 1

[    14.148] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    14.150] (II) xfree86: Adding drm device (/dev/dri/card0)
[    14.150] (II) xfree86: Adding drm device (/dev/dri/card1)
[    14.150] (II) xfree86: Adding drm device (/dev/dri/card2)
[    14.151] (II) xfree86: Adding drm device (/dev/dri/card3)
[    14.160] (--) PCI: (11@0:0:0) 1002:687f:1002:0b36 rev 192, Mem @ 0x1200000000/8589934592, 0x1100000000/2097152, 0xfad00000/524288, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
[    14.160] (--) PCI: (14@0:0:0) 1002:687f:1002:0b36 rev 192, Mem @ 0x1400000000/8589934592, 0x1600000000/2097152, 0xfab00000/524288, I/O @ 0x00001000/256, BIOS @ 0x????????/131072
[    14.160] (--) PCI: (68@0:0:0) 1002:687f:1002:0b36 rev 192, Mem @ 0x8800000000/8589934592, 0x8700000000/2097152, 0xbec00000/524288, I/O @ 0x00005000/256, BIOS @ 0x????????/131072
[    14.160] (--) PCI:*(71@0:0:0) 1002:687f:1002:0b36 rev 192, Mem @ 0x8a00000000/8589934592, 0x8c00000000/2097152, 0xbea00000/524288, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
[    14.160] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    14.160] (II) LoadModule: "glx"
[    14.160] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    14.161] (II) Module glx: vendor="X.Org Foundation"
[    14.161] 	compiled for 1.20.1, module version = 1.0.0
[    14.161] 	ABI class: X.Org Server Extension, version 10.0
[    14.161] (II) Applying OutputClass "AMDgpu" to /dev/dri/card3
[    14.161] 	loading driver: amdgpu
[    14.161] (II) Applying OutputClass "AMDgpu" to /dev/dri/card0
[    14.161] 	loading driver: amdgpu
[    14.161] (II) Applying OutputClass "AMDgpu" to /dev/dri/card1
[    14.161] 	loading driver: amdgpu
[    14.161] (II) Applying OutputClass "AMDgpu" to /dev/dri/card2
[    14.161] 	loading driver: amdgpu
[    14.161] (==) Matched amdgpu as autoconfigured driver 0
[    14.161] (==) Matched ati as autoconfigured driver 1
[    14.161] (==) Matched modesetting as autoconfigured driver 2
[    14.161] (==) Matched fbdev as autoconfigured driver 3
[    14.161] (==) Matched vesa as autoconfigured driver 4
[    14.161] (==) Assigned the driver to the xf86ConfigLayout
[    14.161] (II) LoadModule: "amdgpu"
[    14.161] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[    14.161] (II) Module amdgpu: vendor="X.Org Foundation"
[    14.161] 	compiled for 1.20.0, module version = 18.0.1
[    14.161] 	Module class: X.Org Video Driver
[    14.162] 	ABI class: X.Org Video Driver, version 24.0
[    14.162] (II) LoadModule: "ati"
[    14.162] (WW) Warning, couldn't open module ati
[    14.162] (EE) Failed to load module "ati" (module does not exist, 0)
[    14.162] (II) LoadModule: "modesetting"
[    14.162] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    14.162] (II) Module modesetting: vendor="X.Org Foundation"
[    14.162] 	compiled for 1.20.1, module version = 1.20.1
[    14.162] 	Module class: X.Org Video Driver
[    14.162] 	ABI class: X.Org Video Driver, version 24.0
[    14.162] (II) LoadModule: "fbdev"
[    14.162] (WW) Warning, couldn't open module fbdev
[    14.162] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    14.162] (II) LoadModule: "vesa"
[    14.162] (WW) Warning, couldn't open module vesa
[    14.162] (EE) Failed to load module "vesa" (module does not exist, 0)
zasyadko ()
Ответ на: комментарий от zasyadko

продолжение

[    14.162] (II) AMDGPU: Driver for AMD Radeon:
	All GPUs supported by the amdgpu kernel driver
[    14.162] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    14.162] (II) [KMS] Kernel modesetting enabled.
[    14.163] (WW) Falling back to old probe method for modesetting
[    14.163] (II) [KMS] Kernel modesetting enabled.
[    14.163] (II) [KMS] Kernel modesetting enabled.
[    14.163] (II) [KMS] Kernel modesetting enabled.
[    14.163] (II) AMDGPU(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    14.163] (==) AMDGPU(0): Depth 24, (--) framebuffer bpp 32
[    14.163] (II) AMDGPU(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    14.163] (==) AMDGPU(0): Default visual is TrueColor
[    14.163] (==) AMDGPU(0): RGB weight 888
[    14.163] (II) AMDGPU(0): Using 8 bits per RGB (8 bit DAC)
[    14.163] (--) AMDGPU(0): Chipset: "Radeon RX Vega" (ChipID = 0x687f)
[    14.163] (II) Loading sub module "fb"
[    14.163] (II) LoadModule: "fb"
[    14.163] (II) Loading /usr/lib/xorg/modules/libfb.so
[    14.163] (II) Module fb: vendor="X.Org Foundation"
[    14.163] 	compiled for 1.20.1, module version = 1.0.0
[    14.163] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    14.163] (II) Loading sub module "dri2"
[    14.163] (II) LoadModule: "dri2"
[    14.163] (II) Module "dri2" already built-in
[    14.198] (II) Loading sub module "glamoregl"
[    14.198] (II) LoadModule: "glamoregl"
[    14.198] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    14.201] (II) Module glamoregl: vendor="X.Org Foundation"
[    14.201] 	compiled for 1.20.1, module version = 1.0.1
[    14.201] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    14.207] (II) AMDGPU(0): glamor X acceleration enabled on Radeon RX Vega (VEGA10, DRM 3.26.0, 4.18.3-arch1-1-ARCH, LLVM 6.0.1)
[    14.207] (II) AMDGPU(0): glamor detected, initialising EGL layer.
[    14.207] (==) AMDGPU(0): TearFree property default: auto
[    14.207] (II) AMDGPU(0): KMS Pageflipping: enabled
[    14.207] (II) AMDGPU(0): Output DisplayPort-9 has no monitor section
[    14.207] (II) AMDGPU(0): Output DisplayPort-10 has no monitor section
[    14.207] (II) AMDGPU(0): Output DisplayPort-11 has no monitor section
[    14.210] (II) AMDGPU(0): Output HDMI-A-3 has no monitor section
[    14.210] (II) AMDGPU(0): EDID for output DisplayPort-9
[    14.210] (II) AMDGPU(0): EDID for output DisplayPort-10
[    14.210] (II) AMDGPU(0): EDID for output DisplayPort-11
[    14.215] (II) AMDGPU(0): EDID for output HDMI-A-3
[    14.215] (II) AMDGPU(0): Manufacturer: MST  Model: 30  Serial#: 1
[    14.215] (II) AMDGPU(0): Year: 2014  Week: 10
[    14.215] (II) AMDGPU(0): EDID Version: 1.3
[    14.215] (II) AMDGPU(0): Digital Display Input
[    14.215] (II) AMDGPU(0): Max Image Size [cm]: horiz.: 115  vert.: 65
[    14.215] (II) AMDGPU(0): Gamma: 2.20
[    14.215] (II) AMDGPU(0): No DPMS capabilities specified
[    14.215] (II) AMDGPU(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[    14.215] (II) AMDGPU(0): First detailed timing is preferred mode
[    14.215] (II) AMDGPU(0): redX: 0.640 redY: 0.340   greenX: 0.300 greenY: 0.690
[    14.215] (II) AMDGPU(0): blueX: 0.138 blueY: 0.038   whiteX: 0.282 whiteY: 0.297
[    14.215] (II) AMDGPU(0): Manufacturer's mask: 0
[    14.215] (II) AMDGPU(0): Supported standard timings:
[    14.215] (II) AMDGPU(0): #3: hsize: 2288  vsize 1430  refresh: 61  vid: 511
[    14.215] (II) AMDGPU(0): Supported detailed timing:
[    14.215] (II) AMDGPU(0): clock: 594.0 MHz   Image Size:  708 x 398 mm
[    14.215] (II) AMDGPU(0): h_active: 3840  h_sync: 4016  h_sync_end 4104 h_blank_end 4400 h_border: 0
[    14.215] (II) AMDGPU(0): v_active: 2160  v_sync: 2168  v_sync_end 2178 v_blanking: 2250 v_border: 0
[    14.215] (II) AMDGPU(0): Supported detailed timing:
[    14.215] (II) AMDGPU(0): clock: 148.5 MHz   Image Size:  708 x 398 mm
[    14.215] (II) AMDGPU(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
[    14.215] (II) AMDGPU(0): v_active: 1080  v_sync: 1084  v_sync_end 1089 v_blanking: 1125 v_border: 0
[    14.215] (II) AMDGPU(0): Monitor name: TV_MONITOR
[    14.215] (II) AMDGPU(0): Ranges: V min: 59 V max: 70 Hz, H min: 31 H max: 140 kHz, PixClock max 605 MHz
[    14.215] (II) AMDGPU(0): Supported detailed timing:
[    14.215] (II) AMDGPU(0): clock: 27.0 MHz   Image Size:  708 x 398 mm
[    14.215] (II) AMDGPU(0): h_active: 720  h_sync: 736  h_sync_end 798 h_blank_end 858 h_border: 0
[    14.215] (II) AMDGPU(0): v_active: 480  v_sync: 489  v_sync_end 495 v_blanking: 525 v_border: 0
[    14.215] (II) AMDGPU(0): Supported detailed timing:
[    14.215] (II) AMDGPU(0): clock: 27.0 MHz   Image Size:  708 x 398 mm
[    14.215] (II) AMDGPU(0): h_active: 1440  h_sync: 1478  h_sync_end 1602 h_blank_end 1716 h_border: 0
[    14.215] (II) AMDGPU(0): v_active: 240  v_sync: 244  v_sync_end 247 v_blanking: 262 v_border: 0
[    14.215] (II) AMDGPU(0): Number of EDID sections to follow: 1
[    14.215] (II) AMDGPU(0): EDID (in hex):
[    14.215] (II) AMDGPU(0): 	00ffffffffffff003674300001000000
[    14.215] (II) AMDGPU(0): 	0a180103807341780acf74a3574cb023
[    14.215] (II) AMDGPU(0): 	09484c000000010101ff01ffff010101
[    14.215] (II) AMDGPU(0): 	01010101012008e80030f2705a80b058
[    14.215] (II) AMDGPU(0): 	8a00c48e2100001e023a801871382d40
[    14.215] (II) AMDGPU(0): 	582c4500c48e2100001e000000fc0054
[    14.215] (II) AMDGPU(0): 	565f4d4f4e49544f520a2020000000fd
[    14.215] (II) AMDGPU(0): 	003b461f8c3c000a20202020202001c3
[    14.215] (II) AMDGPU(0): 	020357f25b058403011213141607901f
[    14.215] (II) AMDGPU(0): 	20225d5f6061626465665e6302061115
[    14.215] (II) AMDGPU(0): 	2609070711070683010000e200ff7203
[    14.215] (II) AMDGPU(0): 	0c003000784420c08401020304014100
[    14.215] (II) AMDGPU(0): 	0067d85dc401788007e305c301e50f00
[    14.215] (II) AMDGPU(0): 	801900e30605018c0ad08a20e02d1010
[    14.215] (II) AMDGPU(0): 	3e9600c48e210000188c0aa01451f016
[    14.215] (II) AMDGPU(0): 	00267c4300c48e2100009800000000f4
[    14.215] (--) AMDGPU(0): HDMI max TMDS frequency 340000KHz
[    14.215] (II) AMDGPU(0): No remaining probed modes for output HDMI-A-3
[    14.215] (II) AMDGPU(0): Output DisplayPort-9 disconnected
[    14.215] (II) AMDGPU(0): Output DisplayPort-10 disconnected
[    14.215] (II) AMDGPU(0): Output DisplayPort-11 disconnected
[    14.215] (II) AMDGPU(0): Output HDMI-A-3 connected
[    14.215] (WW) AMDGPU(0): Unable to find initial modes
[    14.215] (EE) AMDGPU(0): Output HDMI-A-3 enabled but has no modes
[    14.215] (II) AMDGPU(0): mem size init: gart size :1fe761000 vram size: s:1fe016000 visible:1fe016000
[    14.215] (==) AMDGPU(0): DPI set to (96, 96)
[    14.215] (==) AMDGPU(0): Using gamma correction (1.0, 1.0, 1.0)
[    14.215] (II) Loading sub module "ramdac"
[    14.215] (II) LoadModule: "ramdac"
[    14.215] (II) Module "ramdac" already built-in
[    14.215] (EE) AMDGPU(0): No modes.
[    14.215] (II) UnloadModule: "amdgpu"
[    14.215] (II) UnloadSubModule: "glamoregl"
[    14.215] (II) Unloading glamoregl
[    14.215] (II) UnloadSubModule: "fb"
[    14.215] (II) Unloading fb
[    14.215] (==) AMDGPU(G0): Depth 24, (--) framebuffer bpp 32
[    14.215] (II) AMDGPU(G0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    14.215] (==) AMDGPU(G0): Default visual is TrueColor
[    14.215] (==) AMDGPU(G0): RGB weight 888
[    14.215] (II) AMDGPU(G0): Using 8 bits per RGB (8 bit DAC)
[    14.215] (--) AMDGPU(G0): Chipset: "Radeon RX Vega" (ChipID = 0x687f)
[    14.215] (II) Loading sub module "fb"

zasyadko ()
Ответ на: комментарий от zasyadko

еще продолжение

[    14.215] (II) LoadModule: "fb"
[    14.215] (II) Loading /usr/lib/xorg/modules/libfb.so
[    14.216] (II) Module fb: vendor="X.Org Foundation"
[    14.216] 	compiled for 1.20.1, module version = 1.0.0
[    14.216] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    14.216] (II) Loading sub module "dri2"
[    14.216] (II) LoadModule: "dri2"
[    14.216] (II) Module "dri2" already built-in
[    14.221] (II) Loading sub module "glamoregl"
[    14.221] (II) LoadModule: "glamoregl"
[    14.221] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    14.221] (II) Module glamoregl: vendor="X.Org Foundation"
[    14.221] 	compiled for 1.20.1, module version = 1.0.1
[    14.221] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    14.225] (II) AMDGPU(G0): glamor X acceleration enabled on Radeon RX Vega (VEGA10, DRM 3.26.0, 4.18.3-arch1-1-ARCH, LLVM 6.0.1)
[    14.225] (II) AMDGPU(G0): glamor detected, initialising EGL layer.
[    14.225] (==) AMDGPU(G0): TearFree property default: auto
[    14.225] (II) AMDGPU(G0): Output DisplayPort-1-0 has no monitor section
[    14.225] (II) AMDGPU(G0): Output DisplayPort-1-1 has no monitor section
[    14.226] (II) AMDGPU(G0): Output DisplayPort-1-2 has no monitor section
[    14.226] (II) AMDGPU(G0): Output HDMI-A-1-0 has no monitor section
[    14.226] (II) AMDGPU(G0): EDID for output DisplayPort-1-0
[    14.226] (II) AMDGPU(G0): EDID for output DisplayPort-1-1
[    14.226] (II) AMDGPU(G0): EDID for output DisplayPort-1-2
[    14.226] (II) AMDGPU(G0): EDID for output HDMI-A-1-0
[    14.226] (II) AMDGPU(G0): mem size init: gart size :1fe761000 vram size: s:1fe016000 visible:1fe016000
[    14.226] (==) AMDGPU(G0): DPI set to (96, 96)
[    14.226] (==) AMDGPU(G0): Using gamma correction (1.0, 1.0, 1.0)
[    14.226] (II) Loading sub module "ramdac"
[    14.226] (II) LoadModule: "ramdac"
[    14.226] (II) Module "ramdac" already built-in
[    14.226] (==) AMDGPU(G1): Depth 24, (--) framebuffer bpp 32
[    14.226] (II) AMDGPU(G1): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    14.226] (==) AMDGPU(G1): Default visual is TrueColor
[    14.226] (==) AMDGPU(G1): RGB weight 888
[    14.226] (II) AMDGPU(G1): Using 8 bits per RGB (8 bit DAC)
[    14.226] (--) AMDGPU(G1): Chipset: "Radeon RX Vega" (ChipID = 0x687f)
[    14.226] (II) Loading sub module "fb"
[    14.226] (II) LoadModule: "fb"
[    14.226] (II) Loading /usr/lib/xorg/modules/libfb.so
[    14.226] (II) Module fb: vendor="X.Org Foundation"
[    14.226] 	compiled for 1.20.1, module version = 1.0.0
[    14.226] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    14.226] (II) Loading sub module "dri2"
[    14.226] (II) LoadModule: "dri2"
[    14.226] (II) Module "dri2" already built-in
[    14.231] (II) Loading sub module "glamoregl"
[    14.231] (II) LoadModule: "glamoregl"
[    14.231] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    14.231] (II) Module glamoregl: vendor="X.Org Foundation"
[    14.231] 	compiled for 1.20.1, module version = 1.0.1
[    14.231] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    14.234] (II) AMDGPU(G1): glamor X acceleration enabled on Radeon RX Vega (VEGA10, DRM 3.26.0, 4.18.3-arch1-1-ARCH, LLVM 6.0.1)
[    14.234] (II) AMDGPU(G1): glamor detected, initialising EGL layer.
[    14.234] (==) AMDGPU(G1): TearFree property default: auto
[    14.234] (II) AMDGPU(G1): Output DisplayPort-2-3 has no monitor section
[    14.234] (II) AMDGPU(G1): Output DisplayPort-2-4 has no monitor section
[    14.234] (II) AMDGPU(G1): Output DisplayPort-2-5 has no monitor section
[    14.234] (II) AMDGPU(G1): Output HDMI-A-2-1 has no monitor section
[    14.234] (II) AMDGPU(G1): EDID for output DisplayPort-2-3
[    14.234] (II) AMDGPU(G1): EDID for output DisplayPort-2-4
[    14.234] (II) AMDGPU(G1): EDID for output DisplayPort-2-5
[    14.234] (II) AMDGPU(G1): EDID for output HDMI-A-2-1
[    14.234] (II) AMDGPU(G1): mem size init: gart size :1fe761000 vram size: s:1fe016000 visible:1fe016000
[    14.234] (==) AMDGPU(G1): DPI set to (96, 96)
[    14.234] (==) AMDGPU(G1): Using gamma correction (1.0, 1.0, 1.0)
[    14.234] (II) Loading sub module "ramdac"
[    14.234] (II) LoadModule: "ramdac"
[    14.234] (II) Module "ramdac" already built-in
[    14.234] (==) AMDGPU(G2): Depth 24, (--) framebuffer bpp 32
[    14.234] (II) AMDGPU(G2): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    14.234] (==) AMDGPU(G2): Default visual is TrueColor
[    14.234] (==) AMDGPU(G2): RGB weight 888
[    14.234] (II) AMDGPU(G2): Using 8 bits per RGB (8 bit DAC)
[    14.234] (--) AMDGPU(G2): Chipset: "Radeon RX Vega" (ChipID = 0x687f)
[    14.234] (II) Loading sub module "fb"
[    14.234] (II) LoadModule: "fb"
[    14.234] (II) Loading /usr/lib/xorg/modules/libfb.so
[    14.234] (II) Module fb: vendor="X.Org Foundation"
[    14.234] 	compiled for 1.20.1, module version = 1.0.0
[    14.234] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    14.235] (II) Loading sub module "dri2"
[    14.235] (II) LoadModule: "dri2"
[    14.235] (II) Module "dri2" already built-in
[    14.238] (II) Loading sub module "glamoregl"
[    14.238] (II) LoadModule: "glamoregl"
[    14.238] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[    14.238] (II) Module glamoregl: vendor="X.Org Foundation"
[    14.238] 	compiled for 1.20.1, module version = 1.0.1
[    14.238] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    14.242] (II) AMDGPU(G2): glamor X acceleration enabled on Radeon RX Vega (VEGA10, DRM 3.26.0, 4.18.3-arch1-1-ARCH, LLVM 6.0.1)
[    14.242] (II) AMDGPU(G2): glamor detected, initialising EGL layer.
[    14.242] (==) AMDGPU(G2): TearFree property default: auto
[    14.242] (II) AMDGPU(G2): Output DisplayPort-3-6 has no monitor section
[    14.242] (II) AMDGPU(G2): Output DisplayPort-3-7 has no monitor section
[    14.242] (II) AMDGPU(G2): Output DisplayPort-3-8 has no monitor section
[    14.242] (II) AMDGPU(G2): Output HDMI-A-3-2 has no monitor section
[    14.242] (II) AMDGPU(G2): EDID for output DisplayPort-3-6
[    14.242] (II) AMDGPU(G2): EDID for output DisplayPort-3-7
[    14.242] (II) AMDGPU(G2): EDID for output DisplayPort-3-8
[    14.242] (II) AMDGPU(G2): EDID for output HDMI-A-3-2
[    14.242] (II) AMDGPU(G2): mem size init: gart size :1fe761000 vram size: s:1fe016000 visible:1fe016000
[    14.242] (==) AMDGPU(G2): DPI set to (96, 96)
[    14.242] (==) AMDGPU(G2): Using gamma correction (1.0, 1.0, 1.0)
[    14.242] (II) Loading sub module "ramdac"
[    14.242] (II) LoadModule: "ramdac"
[    14.242] (II) Module "ramdac" already built-in
[    14.242] (EE) Screen(s) found, but none have a usable configuration.
[    14.242] (EE) 
Fatal server error:
[    14.242] (EE) no screens found(EE) 
[    14.242] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    14.242] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    14.242] (EE) 
[    14.243] (EE) Server terminated with error (1). Closing log file.

zasyadko ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.