LINUX.ORG.RU

Где взять stage3-armv5tel-musl.tar.bz2?

 , , , ,


0

1

Разрабы glibc забили на поддержку старых ядер, а новое поставить невозможно. Мало того, бинари в свежих gentoo валятся с FATAL: kernel too old даже со старым glibc, потому использовать glibc не хочется.
При этом под musl бинари только для armv7.
Как мне получить armv5 систему работающую на старых ядрах?

★★★★★

Будь мужиком - собери сам через crossdev (c)

Pinkbyte ★★★★★ ()
Ответ на: комментарий от eternal_sorrow

ЕМНИП vapier - один из самых суровых разработчиков Gentoo, которых я знаю. В оригинале фраза, понятное дело, на английском.

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

пробовал, сборка падала с разными ошибками в очередной раз. Репортить лень, оно просто никогда не работало

mittorn ★★★★★ ()
Ответ на: комментарий от mittorn

Репортить лень, оно просто никогда не работало

А, ну так победим, чо. Может поэтому готовой сборки и нет. Классическое «низы не могут»(ты забил на репорт и не смог собрать сам) - «верхи не хотят»(никому кроме тебя сборка видать не нужна). Вот, например, в мэйллисте gentoo-mips усиленно выкладываются неофициальные сборки на разные сочетания битности/ABI от пользователей - значит это кому-то нужно.

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)

> Разрабы glibc забили на поддержку старых ядер

Когда я компилировал Glibc 2.17 в CentOS 5 с ядром 2.6.18, оказалось достаточным установить какие-то заголовочные файлы более новой версии. В комментариях в SPEC-файле от CentOS 7 дана подсказка так сделать.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от ZenitharChampion

Ну значит отрудили по дефолту. Я нисобрать ни запустить не могу, там банально бинари не запускаются, а старых stage3 нету

mittorn ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.