LINUX.ORG.RU

Проблема с запуском оболочки (kde)

 , ,


1

2

Уважаемые гуру, подскажите пожалуйста. При загрузке x-server-а падает ошибка: modprobe: error: could not insert 'nvidia': no such device

Пробовал пересобирать ядро через genkernel all и выполнял emerge @module-renuild не помогло.

Флаги:

VIDEO_CARDS="intel nvidia"
INPUT_DEVICES="evdev"

Объявления

Это проприетарный драйвер? Попробуйте удалить его, и поставить свободный.

ilipnitsky ★★★ ()
Ответ на: комментарий от LanSilot

а у тебя версия ведра, которое ты запускаешь, и версия ведра, для которого сконпелял драйвер, случаем не различаются?

Deleted ()
Ответ на: комментарий от sudopacman

Команда вернула следующее: Linux 4.4.6-gentoo #1 SMP Sat Aug 27 15:41:32 MSK 2016 x86_64 Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz GenuineIntel GNU/Linux Available kernel symlink targets: [1] linux-4.4.6-gentoo *

LanSilot ()
Ответ на: комментарий от sudopacman

Попробовал добавить nouveau в blacklist после чего все зависает на строке ttys0 at i/o 0x3f8, запустить получается только через опцию nomodeset

LanSilot ()
Ответ на: комментарий от LanSilot

может ты ядро как-то не так собрал? почитай в гентовики, как его надо собирать для блоба нвидии.

sudopacman ★★★★★ ()
Ответ на: комментарий от LanSilot

а ты вики читал? У тебя по второй ссылке

Kernel modules: nvidiafb, nouveau, nvidia

а вики говорит:

 Важно
Для процессоров архитектур x86 и AMD64, встроенный в ядро
framebuffer драйвер конфликтует с бинарным драйвером от nVidia.
При компиляции ядра для этих процессоров полностью отключите
поддержку этого драйвера:
Ядро Отключение поддержки встроенного в ядро драйвера кадрового
буфера

Device Drivers --->
    Graphics support --->
        Frame buffer Devices --->
            <*> Support for frame buffer devices --->
            < >   nVidia Framebuffer Support
            < >   nVidia Riva support

Теперь убедитесь, что драйвер nouveau отключен:
Ядро

Device Drivers  --->
    Graphics support  --->
      < > Nouveau (nVidia) cards

UPD. Ссыль на вики: https://wiki.gentoo.org/wiki/NVidia/nvidia-drivers/ru

Deleted ()
Последнее исправление: nepank (всего исправлений: 1)

Подытожу сказанное выше: не собирай nouveau и nvidiafb, если хочешь использовать проприетарный драйвер

genkernel --menuconfig, выключи соответствующие опции, собери и установи ядро заново(желательно удалить старые модули из /lib/modules) и попробуй еще раз

Pinkbyte ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Подытожу сказанное выше: не собирай nouveau и nvidiafb, если хочешь использовать проприетарный драйвер

 ➜ uname -a
Linux nemesis 4.7.2-bentoo #1 SMP Wed Aug 24 20:26:32 YEKT 2016 x86_64 Intel(R) Pentium(R) Dual CPU T3200 @ 2.00GHz GenuineIntel GNU/Linux

 ➜ cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-4.7.2-bentoo-1 root=/dev/sda2 ro rootfstype=ext4 init=/usr/lib/systemd/systemd nouveau.modeset=0 modprobe.blacklist=nouveau modprobe.blacklist=ttm modprobe.blacklist=drm_kms_helper modprobe.blacklist=drm systemd.setenv=GPUMOD=nvidia

 ➜ lsmod | grep nv
nvidia              10533986  47
drm                   343612  4 nvidia

➜ modinfo nvidia | grep filename
filename:       /lib/modules/4.7.2-bentoo/video/nvidia.ko

 ➜ modinfo nvidia | grep version
version:        340.96
vermagic:       4.7.2-bentoo SMP mod_unload modversions REFCOUNT GRSEC 

 ➜ modinfo nouveau | grep filename                                                                                                          
filename:       /lib/modules/4.7.2-bentoo/kernel/drivers/gpu/drm/nouveau/nouveau.ko

 ➜ grep EE Xorg.0.log 
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

 ➜ grep WW Xorg.0.log 
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    50.909] (WW) The directory "/usr/share/fonts/corefonts" does not exist.
[    51.362] (WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
[    51.362] (WW) "dri2" will not be loaded unless you've specified it to be loaded elsewhere.
[    55.755] (WW) Unresolved symbol: fbGetGCPrivateKey
[    56.019] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    58.448] (WW) NVIDIA(0): Option "TwinView" is not used
[    58.448] (WW) NVIDIA(0): Option "OnDemandVBlankInterrupts" is not used

Да Карл LanSilot это ^ особая уличная магия недоступная таким простым смертным как ты.

init_6 ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Отключил опции и пересобрал ядро. В результате при выполнении sddm включаются все три монитора, но на всех трёх чёрный экран

LanSilot ()
Ответ на: комментарий от LanSilot

Проблему помог решить SKonst, спасибо ему за это. В общем дело было вовсе не в x-server, а в sddm, надо было пользователя добавить в группы sddm и video. Всем, кто принял участие спасибо.

LanSilot ()
Ответ на: комментарий от LanSilot

У тебя, по всей видимости, надо указывать ещё и

VIDEO_CARDS="intel i965 nvidia"
но это напрямую к вопросу не относится.

pS ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.