LINUX.ORG.RU

[Archlinux]Не работает драйвер nvidia для GeForce 5500 FX


0

0

Собственно беда. Установил Арч. Дело дошло до установки дров на видео и все=) Видеокарточка Nvidia GeForce 5500 FX ставлю pacman -Syu nvidia nvidia-utils

все ок. Но при запуске Хов:

[ 1337.257] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so [ 1337.257] (II) Module nvidia: vendor=«NVIDIA Corporation» [ 1337.257] compiled for 4.0.2, module version = 1.0.0 [ 1337.257] Module class: X.Org Video Driver [ 1338.406] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your [ 1338.406] (EE) NVIDIA: system's kernel log for additional error messages. [ 1338.406] (II) UnloadModule: «nvidia» [ 1338.406] (II) Unloading /usr/lib/xorg/modules/drivers/nvidia_drv.so [ 1338.406] (EE) Failed to load module «nvidia» (module-specific error, 0) [ 1338.406] (EE) No drivers available. [ 1338.406] Fatal server error: [ 1338.406] no screens found [ 1338.406]

попытка

modprobe nvidia

говорит что

FATAL: Error inserting nvidia (/lib/modules/2.6.34-ARCH/kernel/drivers/video/nvidia.ko): No such device

Как я понимаю, драйвер nvidia не предназначен для Nvidia GeForce 5500 FX? Погуглив (Nvidia-173xx and -96xx drivers currently don't support the new Xorg release. We recommend using the xf86-video-nouveau driver package for now) Копать в сторону xf86-video-nouveau или xf86-video-nv? Просто интересно, почему GeForce FX 5500 уже не поддерживается драйвером nvidia? Или я слоупок?=)

★★★★★

Вообще, в 173 пока ещё добавляют поддержку новых иксов. Касательно открытых — народ рекомендует nouveau (говорят, вполне нормально тянет компиз и 2D), nv же вроде как потихоньку забрасывается.

dogbert ★★★★★ ()
Ответ на: комментарий от int13h

pkg0

( он без заранее собраных модулей, которые вам все равно не нужны )

Sylvia ★★★★★ ()
Ответ на: комментарий от daemonpnz

Простите! NVIDIA-Linux-x86-173.14.27-pkg0.run или NVIDIA-Linux-x86-173.14.27-pkg1.run?

int13h ★★★★★ ()
Ответ на: комментарий от daemonpnz
The package suffix ('-pkg#') is used to distinguish between packages
containing the same driver, but with different precompiled kernel interfaces.
The file with the highest package number is suitable for most installations.
daemonpnz ★★★★★ ()

5500 поддерживается модулем но модуль еще не поддерживается новым xorg. Впрочем похожие проблемы я наблюдал на своем стационарнике еще с прошлым релизом xorg-a, спасала нагугленая опция загрузки ядра nopat.

Archiater ()
Ответ на: комментарий от Archiater

«Простите, кто на ком стоял?» (С)

Повторяю, в opensuse 11.3, в которой xorg-server 1.8, nvidia fx5200 прекрасно работает с блобом и кушать не просит.

daemonpnz ★★★★★ ()
Ответ на: комментарий от Archiater

nopat это больше относится к вашему процессору и чипсету,
модуль к xorg отношения не имеет, это ядерный DRM ,
на стороне xorg-server работает nvidia_drv.so

для которого существует опция ( /etc/X11/xorg.conf в разделе ServerFlags )

Option «ignoreABI» " on"

можно использовать ее, с обновлением xorg-server 1.7 -> 1.8 для старшей серии драйверов NVidia она работала корректно, возможно что и для legacy будет, но не факт.

Sylvia ★★★★★ ()
Ответ на: комментарий от int13h

http://www.archlinux.org/packages/?q=nvidia-173xx

$ sudo pacman -S nvidia-173xx nvidia-173xx-utils
разрешение зависимостей...
проверка на взаимную несовместимость...
:: nvidia-173xx-utils и nvidia-utils конфликтуют (libgl). Удалить nvidia-utils? [y/N] y
:: nvidia-173xx и nvidia конфликтуют. Удалить nvidia? [y/N] y

Удалить (2): nvidia-utils-256.35-4 [58,21 MB]  nvidia-256.35-1 [10,64 MB]

Размер удаляемых файлов:   68,85 МБ

Цели (2): nvidia-173xx-utils-173.14.27-1 [4,74 MB]  nvidia-173xx-173.14.27-1 [1,55 MB]

Размер загружаемых файлов:   6,29 МБ
Размер устанавливаемых файлов:   31,37 МБ

Приступить к установке? [Y/n] y
:: Получение пакетов с extra...
^Cvidia-173xx-utils-173.14.27-1-i686                                    2,2M  452,4K/s 00:00:09 [#########################-------------------------------]  34%
Interrupt signal received

Правда?

madgnu ★★★★★ ()
Ответ на: http://www.archlinux.org/packages/?q=nvidia-173xx от madgnu

Да, прости, лохонулся я =) Все, приеду домой буду ставить пакет. Просто дома локальный реп свой, а я его давно не обновлял (с 1 июля). А пакет nvidia-173xx от 26 июля =) Всем спс!

int13h ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.