LINUX.ORG.RU

Ubuntu 11.10 + NVidia GT430 + kernel 3.3

 


0

1

Посмотрел:

$ apt-cache search vdpau
libvdpau-dev - Video Decode and Presentation API for Unix (development files)
libvdpau-doc - Video Decode and Presentation API for Unix (documentation)
libvdpau1 - Video Decode and Presentation API for Unix (libraries)
nvidia-173 - двоичный драйвер Xorg для NVIDIA, модуль ядра и библиотека VDPAU
nvidia-173-updates - двоичный драйвер Xorg для NVIDIA, модуль ядра и библиотека VDPAU
nvidia-96 - двоичный драйвер Xorg для NVIDIA, модуль ядра и библиотека VDPAU
nvidia-96-updates - двоичный драйвер Xorg для NVIDIA, модуль ядра и библиотека VDPAU
nvidia-current-updates - двоичный драйвер Xorg для NVIDIA, модуль ядра и библиотека VDPAU
vdpau-va-driver - VDPAU-based backend for VA API
nvidia-185-libvdpau - Transitional package for nvidia-185-libvdpau
nvidia-185-libvdpau-dev - Transitional package for nvidia-185-libvdpau-dev
nvidia-current - NVIDIA binary Xorg driver, kernel module and VDPAU library

Запустил:
$ sudo apt-get install nvidia-185-libvdpau
[sudo] password for pacify: 
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
  nvidia-current nvidia-settings
НОВЫЕ пакеты, которые будут установлены:
  nvidia-185-libvdpau nvidia-current nvidia-settings
обновлено 0, установлено 3 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Необходимо скачать 59,5 MБ архивов.
После данной операции, объём занятого дискового пространства возрастёт на 186 MB.
Хотите продолжить [Д/н]? y
Получено:1 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ oneiric/main nvidia-current amd64 295.33-0ubuntu1~oneiric~xup1 [58,6 MB]
Получено:2 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ oneiric/main nvidia-185-libvdpau amd64 270.41.19-0ubuntu1~xup [24,2 kB]         
Получено:3 http://ppa.launchpad.net/ubuntu-x-swat/x-updates/ubuntu/ oneiric/main nvidia-settings amd64 295.33-0ubuntu1~oneiric~xup1 [937 kB]        
Получено 59,5 MБ за 49с (1 198 kБ/c)                                                                                                                
Выбор ранее не выбранного пакета nvidia-current.
(Чтение базы данных ... на данный момент установлено 327522 файла и каталога.)
Распаковывается пакет nvidia-current (из файла .../nvidia-current_295.33-0ubuntu1~oneiric~xup1_amd64.deb)...
Выбор ранее не выбранного пакета nvidia-185-libvdpau.
Распаковывается пакет nvidia-185-libvdpau (из файла .../nvidia-185-libvdpau_270.41.19-0ubuntu1~xup_amd64.deb)...
Выбор ранее не выбранного пакета nvidia-settings.
Распаковывается пакет nvidia-settings (из файла .../nvidia-settings_295.33-0ubuntu1~oneiric~xup1_amd64.deb)...
Обрабатываются триггеры для man-db ...
Настраивается пакет nvidia-current (295.33-0ubuntu1~oneiric~xup1) ...
update-alternatives: используется `/usr/lib/nvidia-current/ld.so.conf' для предоставления `/etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf' (x86_64-linux-gnu_gl_conf) в автоматический режим.
update-alternatives: предупреждение: альтернатива /usr/lib/nvidia-current-updates/alt_ld.so.conf (часть группы ссылок i386-linux-gnu_gl_conf) не существует. Удаляется из списка альтернатив.
update-alternatives: предупреждение: /etc/alternatives/i386-linux-gnu_gl_conf has been changed (manually or by a script). Switching to manual updates only.
update-initramfs: deferring update (trigger activated)
Loading new nvidia-current-295.33 DKMS files...
First Installation: checking all kernels...
Building only for 3.3.0-999-generic
Building for architecture x86_64
Building initial module for 3.3.0-999-generic
Done.

nvidia_current:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.3.0-999-generic/updates/dkms/

depmod.......

DKMS: install Completed.
Настраивается пакет nvidia-settings (295.33-0ubuntu1~oneiric~xup1) ...
update-alternatives: предупреждение: альтернатива /usr/lib/nvidia-settings-updates/ld.so.conf (часть группы ссылок nvidia_settings_conf) не существует. Удаляется из списка альтернатив.
update-alternatives: предупреждение: /etc/alternatives/nvidia_settings_conf is dangling, it will be updated with best choice.
update-alternatives: используется `/usr/lib/nvidia-settings/ld.so.conf' для предоставления `/etc/ld.so.conf.d/nvidia_settings.conf' (nvidia_settings_conf) в автоматический режим.
Обрабатываются триггеры для gnome-menus ...
Обрабатываются триггеры для bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Настраивается пакет nvidia-185-libvdpau (270.41.19-0ubuntu1~xup) ...
Обрабатываются триггеры для initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.3.0-999-generic
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-2.fw for module r8169
W: Possible missing firmware /lib/firmware/rtl_nic/rtl8168f-1.fw for module r8169
Как видно, модуль успешно собрался. Пробовал собирать тоже самое «вручную» - не осилил.

★★★★★

Модули не загружаются:

[    24.264] (==) Matched nvidia as autoconfigured driver 0
[    24.264] (==) Matched nouveau as autoconfigured driver 1
[    24.264] (==) Matched nv as autoconfigured driver 2
[    24.264] (==) Matched vesa as autoconfigured driver 3
[    24.264] (==) Matched fbdev as autoconfigured driver 4
[    24.264] (==) Assigned the driver to the xf86ConfigLayout
[    24.264] (II) LoadModule: "nvidia"
[    24.264] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so
[    24.363] (II) Module nvidia: vendor="NVIDIA Corporation"
[    24.366]    compiled for 4.0.2, module version = 1.0.0
[    24.366]    Module class: X.Org Video Driver
[    24.511] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[    24.511] (EE) NVIDIA:     system's kernel log for additional error messages.
[    24.511] (II) UnloadModule: "nvidia"
[    24.511] (II) Unloading nvidia
[    24.511] (EE) Failed to load module "nvidia" (module-specific error, 0)
[    24.511] (II) LoadModule: "nouveau"
[    24.511] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[    24.512] (II) Module nouveau: vendor="X.Org Foundation"
[    24.512]    compiled for 1.10.1, module version = 0.0.16
[    24.512]    Module class: X.Org Video Driver
[    24.512]    ABI class: X.Org Video Driver, version 10.0
[    24.512] (II) LoadModule: "nv"
[    24.540] (WW) Warning, couldn't open module nv
[    24.540] (II) UnloadModule: "nv"
[    24.540] (II) Unloading nv
[    24.540] (EE) Failed to load module "nv" (module does not exist, 0)
[    24.540] (II) LoadModule: "vesa"
[    24.540] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    24.540] (II) Module vesa: vendor="X.Org Foundation"
[    24.540]    compiled for 1.10.2, module version = 2.3.0
[    24.540]    Module class: X.Org Video Driver
[    24.540]    ABI class: X.Org Video Driver, version 10.0
[    24.540] (II) LoadModule: "fbdev"
[    24.541] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    24.541] (II) Module fbdev: vendor="X.Org Foundation"
[    24.541]    compiled for 1.10.0, module version = 0.4.2
[    24.541]    ABI class: X.Org Video Driver, version 10.0
[    24.541] (II) NOUVEAU driver Date:   Thu Mar 24 02:13:12 2011 +1000
[    24.541] (II) NOUVEAU driver for NVIDIA chipset families :
[    24.541]    RIVA TNT        (NV04)
[    24.541]    RIVA TNT2       (NV05)
[    24.541]    GeForce 256     (NV10)
[    24.541]    GeForce 2       (NV11, NV15)
[    24.541]    GeForce 4MX     (NV17, NV18)
[    24.541]    GeForce 3       (NV20)
[    24.541]    GeForce 4Ti     (NV25, NV28)
[    24.541]    GeForce FX      (NV3x)
[    24.541]    GeForce 6       (NV4x)
[    24.541]    GeForce 7       (G7x)
[    24.541]    GeForce 8       (G8x)
[    24.541]    GeForce GTX 200 (NVA0)
[    24.541]    GeForce GTX 400 (NVC0)
[    24.541] (II) VESA: driver for VESA chipsets: vesa
[    24.541] (II) FBDEV: driver for framebuffer: fbdev
[    24.541] (++) using VT number 7

[    24.541] drmOpenDevice: node name is /dev/dri/card0
[    24.549] [drm] failed to load kernel module "nouveau"
[    24.549] (EE) [drm] failed to open device
[    24.549] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[    24.549] (WW) Falling back to old probe method for fbdev
[    24.549] (II) Loading sub module "fbdevhw"
[    24.549] (II) LoadModule: "fbdevhw"
[    24.549] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[    24.549] (II) Module fbdevhw: vendor="X.Org Foundation"
[    24.549]    compiled for 1.10.4, module version = 0.0.2
[    24.549]    ABI class: X.Org Video Driver, version 10.0
Почему?

pacify ★★★★★ ()
Ответ на: комментарий от anonymous

Зачем его удалять? Заблеклистить. Правильный nvidia-установщик его блеклистит просто, и всё работает.

om-nom-nimouse ★★ ()
Ответ на: комментарий от anonymous

Ты посмотри по логу - он пытается вначале грузить nvidia, затем - nouveau. Вопрос - почему успешно установленный под 3.3 подуль nvidia, не грузится?

pacify ★★★★★ ()
Ответ на: комментарий от pacify

Ты посмотри по логу - он пытается вначале грузить nvidia, затем - nouveau. Вопрос - почему успешно установленный под 3.3 подуль nvidia, не грузится?

lsmod в студию что ли.

А нову ядерный модуль у тебя к тому времени уже загружен. Ты его выгрузи, и сделай modprobe nvidia.ko ну и пускай иксы.

Ygor ★★★★★ ()
Ответ на: комментарий от Ygor
$ lsmod
Module                  Size  Used by
rfcomm                 47013  0 
bnep                   18190  2 
bluetooth             188048  10 rfcomm,bnep
kvm_amd                67858  0 
kvm                   410055  1 kvm_amd
dm_crypt               22908  0 
binfmt_misc            17498  1 
snd_hda_codec_hdmi     32111  4 
snd_hda_intel          33332  0 
snd_ca0106             44732  2 
snd_hda_codec         122839  2 snd_hda_codec_hdmi,snd_hda_intel
snd_ac97_codec        134241  1 snd_ca0106
snd_hwdep              13652  1 snd_hda_codec
ac97_bus               12766  1 snd_ac97_codec
snd_pcm                96984  5 snd_hda_codec_hdmi,snd_hda_intel,snd_ca0106,snd_hda_codec,snd_ac97_codec
snd_seq_midi           13324  0 
snd_rawmidi            30655  2 snd_ca0106,snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61538  2 snd_seq_midi,snd_seq_midi_event
snd_timer              29708  2 snd_pcm,snd_seq
snd_seq_device         14490  3 snd_seq_midi,snd_rawmidi,snd_seq
joydev                 17597  0 
sp5100_tco             13744  0 
i2c_piix4              13287  0 
snd                    78595  15 snd_hda_codec_hdmi,snd_hda_intel,snd_ca0106,snd_hda_codec,snd_ac97_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
edac_core              53411  0 
wacom                  48492  0 
soundcore              14996  1 snd
snd_page_alloc         18484  3 snd_hda_intel,snd_ca0106,snd_pcm
edac_mce_amd           23540  0 
k10temp                13119  0 
serio_raw              13211  0 
ppdev                  17180  0 
mac_hid                13205  0 
lp                     17789  0 
parport_pc             32734  1 
wmi                    19141  0 
parport                46360  3 ppdev,lp,parport_pc
uvesafb                29129  1 
usbhid                 46836  0 
hid                    99668  1 usbhid
firewire_ohci          40327  0 
firewire_core          63386  1 firewire_ohci
8139too                32127  0 
r8169                  57375  0 
8139cp                 27004  0 
crc_itu_t              12707  1 firewire_core
floppy                 73997  0 
pata_jmicron           12747  0 
pata_atiixp            13197  0 
pacify ★★★★★ ()
Ответ на: комментарий от Ygor
$ modprobe --list | grep nvidia
kernel/drivers/video/nvidia/nvidiafb.ko
kernel/drivers/net/ethernet/nvidia/forcedeth.ko
updates/dkms/nvidia_current.ko

$ find /lib/modules/ -iname '*nvidia*'
/lib/modules/3.0.0-12-generic/kernel/drivers/video/nvidia
/lib/modules/3.0.0-12-generic/kernel/drivers/video/nvidia/nvidiafb.ko
/lib/modules/3.0.0-17-generic/kernel/drivers/video/nvidia
/lib/modules/3.0.0-17-generic/kernel/drivers/video/nvidia/nvidiafb.ko
/lib/modules/3.3.0-999-generic/kernel/drivers/net/ethernet/nvidia
/lib/modules/3.3.0-999-generic/kernel/drivers/video/nvidia
/lib/modules/3.3.0-999-generic/kernel/drivers/video/nvidia/nvidiafb.ko
/lib/modules/3.3.0-999-generic/updates/dkms/nvidia_current.ko
/lib/modules/3.0.0-16-generic/kernel/drivers/video/nvidia
/lib/modules/3.0.0-16-generic/kernel/drivers/video/nvidia/nvidiafb.ko
pacify ★★★★★ ()
Ответ на: комментарий от pacify

Поддержка Fermi появилась гораздо позднее, нежели в 185.x.

Недавно, когда мне захотелось нового блоба на F16, пришлось разбираться со сборкой пакета из *.src.rpm. Таки осилил.

Думаю, Вам тоже не помешает подобный скилл ;)

carasin ★★★★★ ()

(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA: system's kernel log for additional error messages.

Лучей поноса тебе. Где логи?

devl547 ★★★★★ ()
Ответ на: комментарий от carasin

Кстати, а для чего хорошего эти карточки (GT430) можно использовать в фоновом режиме? Биткоины генерить?
И ещё - какие современные карточки с не очень высоким энергопотреблением наиболее эффективны по критерию цена/производительность?

pacify ★★★★★ ()
Ответ на: комментарий от devl547

Хм. А я и не знал, что nvidia генерит какой-то лог - не обратил
внимания. Думал, этим занимается Xorg/X Window исключительно.

pacify ★★★★★ ()
Ответ на: комментарий от pacify

В игры играть уже не вариант? Под wine'ом многое идёт. Я, например, жду выхода диаблы третьей ;]

carasin ★★★★★ ()
Ответ на: комментарий от pacify

Во все времена по соотношению цена/качество ценились карты x5y серии (ну, например, GTS 250, GT 550, etc.).

carasin ★★★★★ ()

зачем тебе именно 3.3, какие там преимущества относительно 3.2?

а вообще всегда ставил дрова через jockey - никогда никаких проблем не возникало.

Ford_Focus ★★★★★ ()
Ответ на: комментарий от Ford_Focus

зачем тебе именно 3.3, какие там преимущества относительно 3.2?

Чтобы заработал графический планшет
Wacom Bamboo Fun Pen&Touch Medium (CTH-670S-RUPL).

pacify ★★★★★ ()
Ответ на: комментарий от Ford_Focus

Кстати, в 3.3 опять поломали многое. В частности, драйверы. У меня, например, теперь нужен хак для uvcvideo, не то ноут виснет при обращении к /dev/video0. На этом форуме были темы и об ath9k (AR9285, но его постоянно ломают, уже неудивительно). В общем, ждём 3.4 ― там поддержку моего ноута обещались запилить в модуле samsung-laptop.ko.

А вообще, при переходе от 3.2 к 3.3 блоб не отваливался, по крайней мере 295.x (а может и 290.x ― не припомню уже, что там было).

carasin ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.