LINUX.ORG.RU

Slackware 13.37 проблема с mesa


0

1

Здравствуйте, есть проблема с графической картой gma 950 (Нетбук Toshiba nb 100 ), после набора glxgears появляется окно с шестёнками, которые через определённый период начинают застывать на небольшое время, а потом опять начинают кутиться, и это повторяется через каждые 1-1,5 сек. (аналогичное наблюдается в играх когда использую в качестве рендера OpenGL).. вот небольшое видео с шестерёнками для ознакомления http://ifolder.ru/26456635 (пробовал записать через recordMyDesktop, вещь оказалась тормознутая, особенно в моём нетбуке, записывала с тормозами, поэтому решил записать на камеру, а после сжал).

 
hikkikamori@toshiba:~$ uname -a
Linux toshiba 2.6.37.6-smp #2 SMP Sat Apr 9 23:39:07 CDT 2011 i686 Intel(R) Atom(TM) CPU N270   @ 1.60GHz GenuineIntel GNU/Linux

Значения выдаваемые после ввода glxgears - меня полностью устраивают

hikkikamori@toshiba:~$ glxgears
1586 frames in 5.0 seconds = 317.137 FPS
1851 frames in 5.0 seconds = 370.120 FPS
1863 frames in 5.0 seconds = 372.524 FPS
1897 frames in 5.0 seconds = 379.294 FPS
нужно лишь узнать откуда берётся эта тормознутость? :(

Вывод lspci:

root@toshiba:~# lspci 
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
02:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
В /var/log/Xorg.0.log ошибок нет. Вот мой xorg.conf
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/local"
	FontPath     "/usr/share/fonts/TTF"
	FontPath     "/usr/share/fonts/OTF"
	FontPath     "/usr/share/fonts/Type1"
	FontPath     "/usr/share/fonts/misc"
	FontPath     "/usr/share/fonts/CID"
	FontPath     "/usr/share/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/75dpi"
	FontPath     "/usr/share/fonts/100dpi"
	FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
	Load  "extmod"
	Load  "dbe"
	Load  "dri"
	Load  "glx"
	Load  "dri2"
	Load  "record"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option      "XkbModel" "pc105"
#	Option	    "XkbLayout" "us,ru(winkeys)"
#	Option      "XkbOptions"  "grp:ctrl_shift_toggle"
	Option	    "XkbRules" "xorg"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
	Modeline "1024x600_60.00"  48.96  1024 1064 1168 1312  600 601 604 622  -HSync +Vsync
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "AccelMethod"        	# [<str>]
        Option     "AccelMethod"	"UXA"
	#Option     "DRI"                	# [<bool>]
        Option     "DRI"		"True"
	Option     "DRI2"		"True"
	#Option     "ColorKey"           	# <i>
        #Option     "VideoKey"           	# <i>
        #Option     "FallbackDebug"      	# [<bool>]
        #Option     "Tiling"             	# [<bool>]
        Option     "Tiling"		"False"
	#Option     "LinearFramebuffer"  	# [<bool>]
        #Option     "Shadow"             	# [<bool>]
        Option     "SwapbuffersWait"	"False"
	#Option     "SwapbuffersWait"    	# [<bool>]
        #Option     "XvMC"               	# [<bool>]
        #Option     "XvPreferOverlay"    	# [<bool>]
        #Option     "DebugFlushBatches"  	# [<bool>]
        #Option     "DebugFlushCaches"   	# [<bool>]
        #Option     "DebugWait"          	# [<bool>]
        #Option     "HotPlug"            	# [<bool>]
        #Option     "RelaxedFencing"     	# [<bool>]
	Identifier  "Card0"
	Driver      "intel"
	Option	    "DPMS"
	VendorName  "Intel Corporation"
        BoardName   "Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller"
	BusID       "PCI:0:2:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	DefaultDepth 24
	SubSection "Display"
	Depth 24
	Modes "1024x600_60.00"
#		Viewport   0 0
#		Depth     1
	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     4
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     8
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     15
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     16
#	EndSubSection
#	SubSection "Display"
#		Viewport   0 0
#		Depth     24
#	EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
и ~/.drirc
<driconf>
      <device screen="0" driver="dri2">
          <application name="Default">
              <option name="vblank_mode" value="0" />
          </application>
      </device>
      <device screen="0" driver="i915">
          <application name="Default">
              <option name="force_s3tc_enable" value="false" />
              <option name="no_rast" value="false" />
              <option name="fthrottle_mode" value="2" />
              <option name="always_flush_cache" value="false" />
              <option name="stub_occlusion_query" value="false" />
              <option name="always_flush_batch" value="false" />
              <option name="bo_reuse" value="1" />
              <option name="texture_tiling" value="true" />
              <option name="early_z" value="false" />
              <option name="allow_large_textures" value="2" />
              <option name="fragment_shader" value="false" />
          </application>
      </device>
</driconf>
hikkikamori@toshiba:~$ glxinfo |grep renderer
OpenGL renderer string: Mesa DRI Intel(R) 945GME GEM 20090712 2009Q2 RC3 x86/MMX/SSE2
На данный момент у меня стоят Mesa-7.5, libdrm-2.4.23, xf86-video-intel-2.15.0

Дистрибутив Slackware 13.37 (x86)

Дополнение к сообщению

Сегодня просмотрел syslog, нашёл ещё немного гадостей



Oct 20 07:39:08 toshiba kernel: [25725.008051] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.
Oct 20 07:39:08 toshiba kernel: [25725.327061] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.
Oct 20 07:39:08 toshiba kernel: [25725.641048] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.
Oct 20 18:42:46 toshiba udevd[1665]: bind failed: Address already in use 
Oct 20 18:42:46 toshiba udevd[1665]: error binding control socket, seems udevd is already running 
Oct 20 18:42:46 toshiba kernel: [    0.312082] pnp 00:01: disabling [io  0x164e-0x164f] because it overlaps 0000:00:1c.1 BAR 7 [io  0x1000-0x1fff]
Oct 20 18:42:46 toshiba kernel: [    1.458022] pci 0000:00:1d.7: EHCI: BIOS handoff failed (BIOS bug?) 01010001
Oct 20 18:42:46 toshiba kernel: [    1.458474] Simple Boot Flag value 0x5 read from CMOS RAM was invalid
Oct 20 18:42:46 toshiba kernel: [    1.460461] highmem bounce pool size: 64 pages
Oct 20 18:42:46 toshiba kernel: [    1.469207] Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Oct 20 18:42:46 toshiba kernel: [    1.469914] DLM (built Apr  9 2011 23:32:52) installed
Oct 20 18:42:46 toshiba kernel: [    1.481516] OCFS2 User DLM kernel interface loaded
Oct 20 18:42:46 toshiba kernel: [    1.483680] GFS2 (built Apr  9 2011 23:33:12) installed
Oct 20 18:42:46 toshiba kernel: [    1.486699] ACPI Error: [CAPB] Namespace lookup failure, AE_ALREADY_EXISTS (20101013/dsfield-143)
Oct 20 18:42:46 toshiba kernel: [    1.486731] ACPI Error: Method parse/execution failed [\_SB_.PCI0._OSC] (Node f6023bb8), AE_ALREADY_EXISTS (20101013/psparse-537)
Oct 20 18:42:46 toshiba kernel: [    1.486956] ACPI Error: [CAPB] Namespace lookup failure, AE_ALREADY_EXISTS (20101013/dsfield-143)
Oct 20 18:42:46 toshiba kernel: [    1.486985] ACPI Error: Method parse/execution failed [\_SB_.PCI0._OSC] (Node f6023bb8), AE_ALREADY_EXISTS (20101013/psparse-537)
Oct 20 18:42:46 toshiba kernel: [    1.509032] Console: switching to colour frame buffer device 100x37
Oct 20 18:42:46 toshiba kernel: [    4.909560] Compaq SMART2 Driver (v 2.6.0)
Oct 20 18:42:46 toshiba kernel: [    4.973157] scsi: <fdomain> Detection failed (no card)
Oct 20 18:42:46 toshiba kernel: [    5.038134] Emulex LightPulse Fibre Channel SCSI driver 8.3.18
Oct 20 18:42:46 toshiba kernel: [    5.046948] Copyright(c) 2004-2009 Emulex.  All rights reserved.
Oct 20 18:42:46 toshiba kernel: [    5.087038] Failed initialization of WD-7000 SCSI card!
Oct 20 18:42:46 toshiba kernel: [    5.200852] GDT-HA: Storage RAID Controller Driver. Version: 3.05
Oct 20 18:42:46 toshiba kernel: [    5.210033] 3ware Storage Controller device driver for Linux v1.26.02.003.
Oct 20 18:42:46 toshiba kernel: [    5.219162] 3ware 9000 Storage Controller device driver for Linux v2.26.02.014.
Oct 20 18:42:46 toshiba kernel: [    6.435624] synth name on entry is: (null)
Oct 20 18:42:46 toshiba kernel: [    6.793750] registered taskstats version 1
Oct 20 18:42:46 toshiba kernel: [    6.884532] EXT3-fs (sda1): error: couldn't mount because of unsupported optional features (240)
Oct 20 18:42:46 toshiba kernel: [    6.893437] EXT2-fs (sda1): error: couldn't mount because of unsupported optional features (240)
Oct 20 18:42:46 toshiba kernel: [    6.932554] VFS: Mounted root (ext4 filesystem) readonly on device 8:1.
Oct 20 18:42:46 toshiba kernel: [   13.173080] fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
Oct 20 18:42:46 toshiba kernel: [   13.175941] Console: switching to colour dummy device 80x25
Oct 20 18:42:46 toshiba kernel: [   13.182085] [drm:intel_panel_get_max_backlight] *ERROR* fixme: max PWM is zero.
Oct 20 18:42:46 toshiba kernel: [   13.182100] Console: switching to colour frame buffer device 128x37
Oct 20 18:42:58 toshiba dhcpcd[1691]: timed out
Oct 20 18:42:58 toshiba dhcpcd[1691]: allowing 8 seconds for IPv4LL timeout
Oct 20 18:43:02 toshiba ntpd[1809]: bind(20) AF_INET6 fe80::21e:33ff:fe96:2d90%2#123 flags 0x11 failed: Cannot assign requested address
Oct 20 18:43:02 toshiba ntpd[1809]: unable to create socket on eth0 (4) for fe80::21e:33ff:fe96:2d90#123
Oct 20 18:43:03 toshiba ntpd[1809]: bind(21) AF_INET6 fe80::21e:33ff:fe96:2d90%2#123 flags 0x11 failed: Cannot assign requested address
Oct 20 18:43:03 toshiba ntpd[1809]: unable to create socket on eth0 (6) for fe80::21e:33ff:fe96:2d90#123
Oct 20 18:43:06 toshiba console-kit-daemon[1829]: WARNING: Failed to acquire org.freedesktop.ConsoleKit 
Oct 20 18:43:06 toshiba console-kit-daemon[1829]: WARNING: Could not acquire name; bailing out 
Вот это строчка
Oct 20 07:39:08 toshiba kernel: [25725.008051] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.
появляется во время работы «хранителя экрана». Возможно это как-то относится к кратковременному зависанию OpenGL? Ещё небольшое пояснение почему стоит такая старая меса, дело в том, что она единственная из всех мною перепробованных хоть как-то работает, остальные до того как не создал файл ~/.drirc вообще отображали в случае glxgears - только чёрный экран, после создания .drirc хоть и начали крутиться шестерёки, но с большими тормозами макс. выдавал 18 FPS

hikkikamori ()

Попробуй выбросить компьютер. Видео intel УГ не только из-за того, что оно медленное, их драйверы так же печально известны своими глюками. У меня на sandybridge на ядре 3.0 еще 2 дней без зависания ядра из-за видео небыло. С горя перещел на драйвер vesa/software rasterizer. Как вариант могу предложить пересобрать мезу с другими флагами, благо там их много, и взять самый свежий соответствующий kms-модуль ядра.

anonymous ()
Ответ на: комментарий от anonymous

Сейчас собирается новое ядро, если это не поможет, буду с мезой возиться дальше

hikkikamori ()
Ответ на: комментарий от ZenitharChampion

Да искал, долго, иначе сюда бы не писал.. много чего испробовал, мало чем помогло

hikkikamori ()
Ответ на: комментарий от andy03

Ага, всё перепробовал, почти всё что можно, ничего не помогает, сборка ядра то же не помогла :(

hikkikamori ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.