LINUX.ORG.RU

Тормоза Radeon HD 5870


0

1

Здравствуйте. Купил себе Radeon HD 5870 вместо nVidia GeForce 9600GT green для расчетов. На нвидии я мог играть в osu! со 500-600 fps и смотреть полноэкранное флеш видео, а с радеоном(использую fglrx) флеш на полный экран сильно тормозит, osu! выдает ~300fps. Я что-то не так настраиваю, или enjoy your ati? Карта-то в разы мощнее старой. И считает через opencl резво.

★★★★★

osu!... я даже хз, что это.
А флеш... Во первых флеш не нужен, есть html5 и оно вроде ускоряется в хромиуме. А во вторых, флеш для ускорения использует vdpau.

no-steam ★★ ()

флеш на полный экран сильно тормозит

мобильная 5470, никаких тормозов с флешем нету.
в игры играю в оффтопике.

Sonsee ()
Ответ на: комментарий от no-steam

С открытым драйвером флеш работает на порядок быстрее в полном экране

ValdikSS ★★★★★ ()

Еще артефакты иногда проскакивают, установил пропатченный xorg, убил иксы, выполнил aticonfig --set-pcs-str=DDX,ForceXAA,TRUE иксы не запускаются.

ValdikSS ★★★★★ ()
Ответ на: комментарий от ValdikSS
Section "Module"
        Load  "extmod"
        Load  "dbe"
        Load  "xtrap"
        Load  "record"
        Load  "dri"
        Load  "glx"
        Load  "GLcore"
        Load  "freetype"
EndSection

это всё по дефолту и так грузится.

просто aticonfig --initial, а потом в графическом настройщике по желанию.

Sonsee ()
Ответ на: комментарий от N1ghtmare

Ничего особого нет вроде, только когда с модулями баловался было [ 19.857] (EE) Failed to load module «xtrap» (module does not exist, 0), больше никаких ошибок нет.

ValdikSS ★★★★★ ()
Ответ на: комментарий от ValdikSS

Так и должно быть?

так быть не должно, поэтому в MODULES !radeon.

эм...а radeon fglrx'у не мешает?

но на тормоза это никак не влияет, ибо работает один из них.

короче.
сноси свой catalyst, ставь catalyst-hook, потом:

[kos@iVAIO ~]$ cat /etc/mkinitcpio.conf | grep HOOKS
HOOKS=«base udev autodetect v86d sata filesystems uresume fglrx fbsplash »
[kos@iVAIO ~]$

aticonfig --initial
mkinitcpio -p kernel26

потом ставишь mplayer-vaapi libva и xvba-video.

всё должно летать.

Sonsee ()
Ответ на: комментарий от Sonsee

Так mplayer-vaapi и так отлично работает. Флеш тормозит сильно, и игра. И это плохо. Попробую завтра через хук(сейчас через демон), отпишусь. И ядро у меня kernel26-ck.

ValdikSS ★★★★★ ()
Ответ на: комментарий от ValdikSS

Так mplayer-vaapi и так отлично работает.

поздравляю, просто сделай вот именно так, как я описал и всё.

Sonsee ()
Ответ на: комментарий от ValdikSS

у меня 38-ое даёт ~+8 градусов на цпу и ~+10 градусов на видео карту, выдаёт непонятные ошибки и прочие проблемы. Поэтому не нужно. Посмотрим что будет в 39-ом. И да, отключи тестинг, же.

Sonsee ()
Ответ на: комментарий от Sonsee

Поставил catalyst-hook, модуль собрался сам, загрузился в 38 ядро(не -ck) - все так же тормозит. xorg.conf пересоздавал. Даже twm запустил вместо кед - тормоза флеша. Пробовал три браузера.

ValdikSS ★★★★★ ()
Ответ на: комментарий от Sonsee

Лол. Если в kwin убрать галку «Отключить графические эффекты для полноэкранных окон», то флеш работает замечательно! Ежели не отключать, или вообще композитинг не включать, то флеш тормозит на полный экран.

ValdikSS ★★★★★ ()

Откатился на flashplugin 10.1 - все нормально в полном экране.

ValdikSS ★★★★★ ()
Ответ на: комментарий от bsdfun

У мышки отзывчивость больше на высоком fps. Да и тормозит осу с этой видеокартой.

ValdikSS ★★★★★ ()

Как решить проблему медленного opengl? Может, в wine покрутить чего? Крутил orm и другие параметры через wintricks - не помогло.

ValdikSS ★★★★★ ()

Еще артефакты появляются при запуске программ частенько, но это лечится настройками в xorg.conf, а вот в wine пришлось выбрать в качестве офскрин рендера backbuffer. Вобщем, все еще недостаточно быстро все. Похоже, нужно ставить мою старую нвидию.

ValdikSS ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.