LINUX.ORG.RU

[xf86-video-ati] Radeon HD2600 не подгружается glx.


0

0

Решил переидти на открытый драйвер, все настроилось через Xorg -configure, но при запуске иксов меня ждало разочарование. Compiz отказался включаться, начал копать логи и обнаружил, что не подгрузился glx модуль. Подскажите, что я делаю не так?
OS: Ubuntu 10.04 (amd64)
Xorg: 7.5+6ubuntu1~xorgedgers3~lucid
Xserver: 1.8.2+git20100705
xf86-video-ati: 6.13.99+git20100823
xorg.conf
лог

★★★★★

>Section «Module»

# Load «dbe»

# Load «glx»


Load «dri»


# Load «record»


# Load «dri2»


# Load «extmod»


EndSection



# Load «glx»

# Load «dri2»


сам догадаешься или подсказать?

snoopcat ★★★★★ ()

А разве на свободных дровах нужен xorg.conf?

После перехода с хала на удав. Я свой xorg.conf выкинул. Правда штеуд у меня, дык вроде у него дрова как раз открытыми считаются. В etc/X11/xorg.conf.d/ никаких упоминаний о юзающемся драйвере нет, а настройки клавиатуры и тачпада у меня в автозагрузке прописаны.

kraftello ★★★★★ ()
Ответ на: комментарий от snoopcat

>сам догадаешься или подсказать?

Извините, что ввел в заблуждение. Эт я экспериментировал, оно одинаково не работает, что так, что без комментирования.

fang90 ★★★★★ ()
Ответ на: комментарий от snoopcat

>кстати да - у меня xf86-video-radeon вообще без Xorg.conf работает. KMS настроен.

Спасибо, сейчас буду пробовать.

fang90 ★★★★★ ()

[кактус][мыши][ням-ням]

Ждём в тред Silvia. Респект ей и уважуха за знание темы и помощь. Можешь посмотреть её профиль, может где-то отметилась сегодня в комментариях. Я внимательно слежу за её комментариями по поводу открытых дров ATI, ибо недобук хочу леново, но с привкусом кактуса.

kraftello ★★★★★ ()

Почитал арчевики

Должно без хоргконф подхватываться. Вроде драйвер указывают, если More than one graphic card. Но на всякий случай там примеры /etc/X11/xorg.conf.d/10-monitor.conf есть.

kraftello ★★★★★ ()
Ответ на: Почитал арчевики от kraftello

Дык оно-то и подхватывается. Монитор, карточку и т.д. определяет на ура, а вот glx подключать не хочет.

fang90 ★★★★★ ()
Ответ на: комментарий от fang90

тогда сдаюсь (%
может, проблема в xorg'е\драйвере\их сборке (все -таки из git собирали, мало ли там что поломать могут..)? что если поставить из основного репозитория?

snoopcat ★★★★★ ()
Ответ на: комментарий от snoopcat

Я думаю, здесь собака порылась.

Поиск по Linux 2.6.24-27-xen Failed to load module «glx» дал похожие результаты без решения проблемы.

kraftello ★★★★★ ()

А собственно говоря, XEN нужен? Если нужен, копай в эту сторону. Если нет, смени ведро.

kraftello ★★★★★ ()
Ответ на: комментарий от fang90

вот это glx

[    16.906] (II) LoadModule: "glx"
[    16.907] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    16.907] (II) Module glx: vendor="X.Org Foundation"
[    16.907]    compiled for 1.7.6, module version = 1.0.0
[    16.907]    ABI class: X.Org Server Extension, version 2.0
[    16.907] (EE) module ABI major version (2) doesn't match the server's version (3)
видно, что скомпилено под 1.7.6
а вот какой версии у тебя Х
[    16.857]
X.Org X Server 1.8.2
Release Date: 2010-07-01

daemonpnz ★★★★★ ()
Ответ на: комментарий от snoopcat

>сам догадаешься или подсказать?

Он всё равно их по-умолчанию подгружает.

anon_666 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.