LINUX.ORG.RU

xf86-video-ati + подсветка


0

0

Есть ноут Toshiba Satellite L30-10X. Дистриб - Arch, драйверы - xf86-video-ati-6.12.4, xorg-server-1.7.3, kernel26-2.6.31-6.

В общем, после запуска иксов, весь экран становится очень тёмным, как будто подсветка на нуле, и в тёмно-зелёных тонах, при этом значок курсора мыши имеет обычные цвета. Если подправить клавишами на ноуте яркость - ничего не меняется, всё так же в тёмно-зелёных тонах и подсветка практически на нуле. В настройках Гнома та же фигня - сколько не дёргай ползунок яркости экрана, за какие-то пределы почти полной темноты не выходит.

Поменял в xorg.conf драйвер с radeon на vesa - всё стало нормально.

Таки вопрос - что не так с xf86-video-radeon? Куда копать?

KMS как включал, так и отключал - результат одинаковый. xf86-video-ati обновил из git - всё равно ничего не поменялось.

Ответ на: комментарий от anonymous

А то что при переключении в консоль цвета остаются такими же тусклыми - нормально?

fedyan ()

xf86-video-ati-6.12.4, xorg-server-1.7.3, kernel26-2.6.31-6

эту связку они поломали, так что глюки могут быть разные. У меня к примеру полностью отвалился OpenGL и XVideo. Посему поставил kernel26-2.6.32.2-1 из тестинга, а сверху накатил из yaourt'а xf86-video-ati-git(т.к. пакеты из тестинга поломаны).

Andru ★★★★ ()
Ответ на: комментарий от Andru

Сейчас поправил этот глюк полным удалением из xorg.conf всего, что касается видео. Благо дефолтные настройки, которые определяет драйвер - самые те.

fedyan ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.