LINUX.ORG.RU

xf86-video-ati 6.14.0

 , , ,


0

1

Alex Deucher сегодня объявил о выходе новой версии драйвера для карт AMD/ATi.

Основные изменения:

  • Поддержка ускорения EXA/Xv при использовании KMS для карт Evergreen (необходимо ядро 2.6.36 или новее);
  • Поддержка ускорения EXA/Xv при использовании KMS для чипов Ontario Fusion, а также карт Northern Islands (необходимо ядро 2.6.38 или новее);
  • Поддержка UMS для чипов Ontario;
  • Поддержка KMS pageflipping для всех карт Radeon (необходимо ядро 2.6.38 или новее);
  • Чистка man-страниц;
  • Множество исправлений ошибок.

>>> Подробности

★★★★★

Проверено: JB ()

(необходимо ядро 2.6.38 или новее)

Украли машину времени?

FakeLinux ()
Ответ на: комментарий от FakeLinux

>Украли машину времени?

Выходи из криокамеры, -rc3 на дворе. обновления drm были еще в -rc1

devl547 ★★★★★ ()
Ответ на: А в гугл? от madgnu

угрожаешь?

а, это APU. наконец-то появятся нормальные нетбуки?

registrant ★★★★★ ()
Ответ на: комментарий от FakeLinux

> Ну, я в том смысле, что релиза не было.
И что? Ядро от этого перестало быть тридцать восьмым?

Lumi ★★★★★ ()

Спасибо, очень полезная новость.

Ребят, кто-нибудь, скажите незнающему, чем поможет KMS pageflipping?

neocrust ★★★★★ ()

> Поддержка KMS pageflipping для всех карт Radeon (необходимо ядро 2.6.38 или новее)

Ядро kernel26-git от 31.01.2011 подойдет?

neocrust ★★★★★ ()

А на 2.6.32 эта штука будет работать?

tailgunner ★★★★★ ()

Так это, «buy from ATI» уже можно делать ?

Creed ()

А имя-фамилию чувака испугался по-русски написать?

Shlyapa ★★ ()

Супер! Все летает. Отказался от блоба, всем доволен.

anonymous ()

А тем временем nvidia optimus вперде, причём глубоко.

Quasar ★★★★★ ()

Никак не могу понять - для работы с железом придумали KMS и Gallium3d которые находятся в ядре. Нафига тогда для каждой железки нужен еще и userspace драйвер?...

BlackV ()

да как же вы сцуга заводите ускорение на Evergreen? блобы в ядро встыркаю, kernel говорит drm initialized, иксы говорят not dri capable и превед sw

x0r ★★★★★ ()
Ответ на: комментарий от Quasar

<вброс>

А тем временем атишники гоняют glxgears, потому что больше ничего не работает. особенно под вайном.

</вброс>

leg0las ★★★★★ ()

ну так теперь появилось 3Д на hd5xxx и выше или нет еще?

Kompilainenn ★★★★★ ()
Ответ на: комментарий от Kompilainenn

> ну так теперь появилось 3Д на hd5xxx и выше или нет еще?
присоединяюсь к вопросу

DJm00n ()

а у меня гефорсе 4 мх4000 и эта xynta тормозит в 2д и падает на блобе, нуеуеэоыаово тоже тормоз

а ещё у меня есть ати 9250 нисколь не лучше

всё говно

anonymous ()
Ответ на: комментарий от leg0las

А тем временем атишники гоняют glxgears, потому что больше ничего не работает. особенно под вайном.

вы наверное удивитесь, но владельцы нвидии делают абсолютно то же самое на nouveau драйвере, отличие лишь в том, что зонд они вынимают с жутким скрипом ввиду отсутствия спеков ;)

ЗЫ: в очередной раз убеждаюсь, что владельцы нвидии, умеют делать только «вбросы» своими кривыми ручонками.

Sith ★★★★★ ()
Ответ на: комментарий от Kompilainenn

на моей 5470 3D работает: direct rendering: Yes OpenGL vendor string: X.Org OpenGL renderer string: Gallium 0.4 on AMD CEDAR OpenGL version string: 2.1 Mesa 7.11-devel OpenGL shading language version string: 1.20

glxgears крутятся, kwin композитит, urban terror бегает шустро. Другой вопрос - когда ожидать HDMI audio на hd5ххх и выше?

NForce ()
Ответ на: комментарий от Sith

Я бы сей вброс не написал, если бы не трогали нвидию

/me ушел гамать в SR2 Революция (под вайном, да).

leg0las ★★★★★ ()
Ответ на: комментарий от leg0las

Заметь, ты тут первый начал сравнивать nvidia и amd. До тебя твою тобой боготворимую нвидию никто не трогал.

daemonpnz ★★★★★ ()

Как всегда от попаболи неистово буйствуют нвидишные быдлотролли, лол

paran0id ★★★★★ ()

Хороший драйвер, я правда только в Quake3 и Heroes играю, но работает все на HD 2600 отличненько. Лучше чем проприетарный, имхо, не большой, поставил из реп и работает без проблем. А вот в Дебиановских репах его нет вроде, а зря.

Deleted ()
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: Mesa DRI R600 (RV730 9490) 20090101  TCL DRI2
OpenGL version string: 2.1 Mesa 7.10
OpenGL shading language version string: 1.20

Как вы gallium включаете, и есть ли от него очевидные плюсы на hd4670?

kernelpanic ★★★★★ ()
Ответ на: комментарий от kernelpanic

для этого нужно пересобирать месу, с --enable-gallium-r600

Novell-ch ★★★★★ ()
Ответ на: комментарий от leg0las

> А тем временем атишники гоняют glxgears, потому что больше ничего не работает. особенно под вайном.

Я год не обновлял xf86-video-ati, полгода ядро, играю на древнючей R300 в Duke Nukem: Manhattan Project под вайном без тормозов. ЧЯДНТ?

anonymous ()

а если сейчас взять AMD Radeon HD 6950 то можно на ней уже без блоба жить? нужно от неё HD фильмы крутить, легкий 3d для mutter/compiz и что бы температуру себе регулировала. а? или хоть через пол года это будет работать? серьёзный 3д все равно в линуксе никогда не потребуется.

druganddrop-2 ★★ ()
Ответ на: комментарий от druganddrop-2

Сейчас не будет , если конечно ядро rc3 не ставить. Я с 5870 живу до выхода .38 ядра на блобе .. без кмс плохо и 3д работает только , если композит отключить

Loki13 ★★★★★ ()

У меня как только появился KMS в ядре, 4870 ведёт себя одинаково вплоть до 2.6.37 - как только ядро инициализирует этот самый KMS, монитор просто выключается =\

GAMer ★★★★★ ()
Ответ на: комментарий от druganddrop-2

http://www.x.org/wiki/RadeonFeature

Через полгода - вряд ли, если ожидаешь работу на уровне fglrx/nvidia, то не ранее чем через пару-тройку лет. Но это не значит что через полгода нельзя будет ей пользоваться в принципе. Я на R300 играю в Sauerbraten, Quake 3, Duke Nukem: MP под Wine как на родных драйверах, более тяжёлое не пробовал из-за старости видяхи.

anonymous ()
Ответ на: комментарий от GAMer

У меня была похожая проблема, оказалось, что не подгружается модуль fbcon.

daemonpnz ★★★★★ ()
Ответ на: комментарий от daemonpnz

У меня по идее фреймбуфера быть вообще не должно - всё это отрублено, чисто VGA консоль 80х25, но с фб попробовать видимо стоит =)

GAMer ★★★★★ ()
Ответ на: комментарий от kernelpanic

у меня нет r600 и точно сказать не могу, но если бы была сидел бы на r600g. для квак, компизов должно хватать с головой.

Novell-ch ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.