LINUX.ORG.RU

странное поведение драйверов nvidia


0

0

Есть ноутбук Acer Aspire 5739G, с видеокартой Geforce GT 130M.

Стандартные драйвера vesa и nv правильно определяют положенное разрешение 1366x768, а с драйвером nvidia рисуются шесть картинок 640x480, игнорируя даже прописанный в xorg.conf modeline (проверено на стабильных драйверах 185.18.31 и beta 190.18) Я в замешательстве, подозреваю, что можно как-то настроить это дело, но гугление ничем не помогло :( Может, кто-то с таким сталкивался?

Да, фото как это выглядет с нвидиевскими дровами - http://img40.imageshack.us/img40/4227/dsc00037xue.jpg

Заранее спасибо :)

Re: странное поведение драйверов nvidia

Section "Screen"
        ...
        Option  "UseEDIDDpi" "false"
        SubSection "Display"
                Viewport 0 0
                Virtual 1366 768
        EndSubSection
EndSection

modeline и прочую пакость убери, не CRT все таки

nu11 ★★★★★ ()

Re: странное поведение драйверов nvidia

Попробуй через nvidia-setting выставить разрешение.
Может ты где в синтаксисе наврал.

athost ★★★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от athost

Re: странное поведение драйверов nvidia

>Судя по поиску дров на сайте nvidia.com поддержки данной карты под линух пока нет даже в бетах дров.

У них поиск на сайте кривой :( В README файлах дров в списках поддерживаемого - есть. Да и работают дрова, компиз красиво компизит, только в 6 изображениях 640x480 вместо одного нормального))

shuthdar ★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от madgnu

Re: странное поведение драйверов nvidia

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "DontZap" "False"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

	# generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nv"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option	"UseEDIDDpi" "false"
    SubSection     "Display"
        Depth       24
        Viewport    0 0
		Virtual		1366 768
    EndSubSection
EndSection

shuthdar ★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от shuthdar

Re: странное поведение драйверов nvidia

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "NoLogo" "True"
    Option	   "UseEDIDDpi" "false"
    SubSection     "Display"
        Depth       24
        Viewport    0 0
	Modes	   "1366x768"
    EndSubSection
EndSection

Попробуй так. Если не поможет - сделай 

lspci | grep VGA

и впиши строчку 

BusID       "PCI:X:X:X" (с твоим адресом, ессно)

в Section "Device". Чем черт не шутит :)

А вообще полезно делать X -configure с вырубленными иксами - он генерит нормальный конфиг со всеми доступными для драйвера опциями (закомментированными).

ЗЫ Virtual же вроде выкинули из иксов?..

madgnu ★★★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от madgnu

Re: странное поведение драйверов nvidia

Без modes то же самое... Лог:


X.Org X Server 1.6.3
Release Date: 2009-7-31
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-24-server i686 Ubuntu
Current Operating System: Linux vl 2.6.28-14-generic #47-Ubuntu SMP Sat Jul 25 00:28:35 UTC 2009 i686
Kernel command line: root=/dev/sda1 ro quiet splash
Build Date: 05 August 2009  11:48:50AM
xorg-server 2:1.6.3-1ubuntu1 (buildd@rothera.buildd) 
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 14 15:30:51 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout0"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Device0"
(**) |-->Input Device "Keyboard0"
(**) |-->Input Device "Mouse0"
(**) Option "DontZap" "False"
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
	Entry deleted from font path
(==) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/75dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	/usr/share/fonts/X11/75dpi,
	/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
	built-ins
(==) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard0
(WW) Disabling Mouse0
(II) Loader magic: 0x1fbc0
(II) Module ABI versions:
	X.Org ANSI C Emulation: 0.4
	X.Org Video Driver: 5.0
	X.Org XInput driver : 4.0
	X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(--) PCI:*(0:1:0:0) 10de:0652:1025:021e nVidia Corporation G96 [GeForce GT 130M] rev 161, Mem @ 0xce000000/16777216, 0xd0000000/268435456, 0xcc000000/33554432, I/O @ 0x00002000/128
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
	compiled for 1.6.3, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions//libdri.so
(II) Module dri: vendor="X.Org Foundation"
	compiled for 1.6.3, module version = 1.0.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
	compiled for 1.6.3, module version = 1.1.0
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
	compiled for 1.6.3, module version = 1.0.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Server Extension
(II) NVIDIA GLX Module  185.18.31  Tue Jul 28 16:15:35 PDT 2009
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
	compiled for 1.6.3, module version = 1.13.0
	Module class: X.Org Server Extension
	ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
	compiled for 4.0.2, module version = 1.0.0
	Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  185.18.31  Tue Jul 28 15:49:53 PDT 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
	compiled for 1.6.3, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
	compiled for 1.6.3, module version = 1.0.0
	ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]

shuthdar ★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от shuthdar

Re: странное поведение драйверов nvidia

продолжение...

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo" "True"
(**) NVIDIA(0): Option "UseEdidDpi" "false"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce GT 130M (G96) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 1048576 kBytes
(--) NVIDIA(0): VideoBIOS: 62.94.7a.00.10
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce GT 130M at PCI:1:0:0:
(--) NVIDIA(0):     AUO (DFP-0)
(--) NVIDIA(0): AUO (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): AUO (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(==) NVIDIA(0): 
(==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) NVIDIA(0):     will be used as the requested mode.
(==) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
	[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
	[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
	[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
	[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
	[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
	[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): ACPI display change hotkey events enabled: the X server is new
(II) NVIDIA(0):     enough to receive ACPI display change hotkey events.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) config/hal: Adding input device Power Button (CM)
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 2.2.2
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 4.0
(**) Power Button (CM): always reports core events
(**) Power Button (CM): Device: "/dev/input/event2"
(II) Power Button (CM): Found keys
(II) Power Button (CM): Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button (CM)" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "lv"
(**) Option "xkb_options" "grp:alts_toggle"
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event7"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "lv"
(**) Option "xkb_options" "grp:alts_toggle"
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event5"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)

shuthdar ★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от shuthdar

Re: странное поведение драйверов nvidia

(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "lv"
(**) Option "xkb_options" "grp:alts_toggle"
(II) config/hal: Adding input device Power Button (FF)
(**) Power Button (FF): always reports core events
(**) Power Button (FF): Device: "/dev/input/event0"
(II) Power Button (FF): Found keys
(II) Power Button (FF): Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button (FF)" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "lv"
(**) Option "xkb_options" "grp:alts_toggle"
(II) config/hal: Adding input device Sleep Button (CM)
(**) Sleep Button (CM): always reports core events
(**) Sleep Button (CM): Device: "/dev/input/event3"
(II) Sleep Button (CM): Found keys
(II) Sleep Button (CM): Configuring as keyboard
(II) XINPUT: Adding extended input device "Sleep Button (CM)" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "lv"
(**) Option "xkb_options" "grp:alts_toggle"
(II) config/hal: Adding input device Macintosh mouse button emulation
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event4"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) filter chain progression: 2.00
(**) Macintosh mouse button emulation: (accel) filter stage 0: 20.00 ms
(**) Macintosh mouse button emulation: (accel) set acceleration profile 0
(II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
	compiled for 1.6.1.901, module version = 1.1.2
	Module class: X.Org XInput Driver
	ABI class: X.Org XInput driver, version 4.0
(II) Synaptics touchpad driver version 1.1.2
(**) Option "Device" "/dev/input/event9"
(II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(II) SynPS/2 Synaptics TouchPad: buttons: left right middle double triple
(--) SynPS/2 Synaptics TouchPad: touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) filter chain progression: 2.00
(**) SynPS/2 Synaptics TouchPad: (accel) filter stage 0: 20.00 ms
(**) SynPS/2 Synaptics TouchPad: (accel) set acceleration profile 0
(--) SynPS/2 Synaptics TouchPad: touchpad found

shuthdar ★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от shuthdar

Re: странное поведение драйверов nvidia

Самое противное место вот это:

(==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(==) NVIDIA(0):     will be used as the requested mode.
(==) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480

madgnu ★★★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от madgnu

Re: странное поведение драйверов nvidia

уже :) в логе:

(WW) NVIDIA(0): No valid modes for "1366x768"; removing.
(WW) NVIDIA(0): 
(WW) NVIDIA(0): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(0):     "nvidia-auto-select".
(WW) NVIDIA(0): 
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480

shuthdar ★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от madgnu

Re: странное поведение драйверов nvidia

В общем ясно, что дело (скорее всего) не в кривизне моих рук, запостил отчёт о проблеме в форум суппорта нвидии. Спасибо за консультации :)

shuthdar ★★★ ()

Re: странное поведение драйверов nvidia

Нужно именно 1366? Попробуй так:

Section "Monitor"
    Identifier     "monitor1"
    HorizSync       28.0 - 51.0
    VertRefresh     43.0 - 61.0
    ModeLine "1360x768" 85.5 1360 1440 1552 1792 768 771 777 795 +hsync +vsync
EndSection

Section "Device"
    Identifier  "device1"
    Driver      "nvidia"
    Option      "RenderAccel" "true"
    Option      "DPMS"
    Option      "HWCursor"      "true"
EndSection

Section "Screen"
    Identifier     "screen1"
    Device         "device1"
    Monitor        "monitor1"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes       "1360x768"
    EndSubSection
EndSection

Suigintou ★★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от Suigintou

Re: странное поведение драйверов nvidia

Разные варианты с 1360 пробовал с самого начала, с тем же результатом. Родное разрешение монитора - именно 1366.

shuthdar ★★★ ()

Re: странное поведение драйверов nvidia

у меня gf8500 подключенный к lcd-tv 1360x768 по hdmi получал неправильный EDID и отказывался устанавливать родное разрешение, помогло только добавление в секцию "Screen" строки

Option "CustomEDID" "DFP-0:/etc/X11/LE32R86BD.BIN"

файл LE32R86BD.BIN содержит образ EDID с рекомендуемым разрешением 1360x768

inoremap ★★ ()

Re: странное поведение драйверов nvidia

Может тупо разъём монитора не контачит, и, соответственно, инфа о доступных режимах по EDID не передаётся.

dn2010 ★★★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от dn2010

Re: странное поведение драйверов nvidia

>Может тупо разъём монитора не контачит, и, соответственно, инфа о доступных режимах по EDID не передаётся.

Во-первых - это ноутбук. Во-вторых - со стандартными неускоренными драйверами разрешение детектится как надо.

shuthdar ★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от Deleted

Re: странное поведение драйверов nvidia

> И как формировал LE32R86BD.BIN, можно ссылку?

никак не формировал, взял где-то готовый, вроде бы на форуме ixbt по телевизорам samsung

inoremap ★★ ()
Ответ на: Re: странное поведение драйверов nvidia от Unnamed_Hero

Re: странное поведение драйверов nvidia

Запустил с VerboseMode "True" по просьбе чувака из техподдержки nvidia. В логах иксов вот что:

(II) NVIDIA(0):   Validating Mode "1366x768":
(II) NVIDIA(0):     1366 x 768 @ 60 Hz
(II) NVIDIA(0):     For use as DFP backend.
(II) NVIDIA(0):     Mode Source: EDID
(II) NVIDIA(0):       Pixel Clock      : 69.50 MHz
(II) NVIDIA(0):       HRes, HSyncStart : 1366, 1414
(II) NVIDIA(0):       HSyncEnd, HTotal : 1446, 1437
(II) NVIDIA(0):       VRes, VSyncStart :  768,  771
(II) NVIDIA(0):       VSyncEnd, VTotal :  775,  806
(II) NVIDIA(0):       H/V Polarity     : -/-
(WW) NVIDIA(0):     Mode is rejected: This mode's horizontal sync end (1446)
(WW) NVIDIA(0):     exceeds the horizontal total size (1437).

shuthdar ★★★ ()
Ответ на: Re: странное поведение драйверов nvidia от Reset

Re: странное поведение драйверов nvidia

>должно быть nvidia

Пытаясь показать меня идиотом, ты выставил идиотом себя. Естественно сюда я скпопипастил xcorg.conf на момент, когда я мог нормально работать в иксах ;)

shuthdar ★★★ ()

Re: странное поведение драйверов nvidia

Если кому-то будет интересно, проблема решилась добавлением Option "ModeValidation" "NoTotalSizeCheck" в конфиг.

shuthdar ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.