LINUX.ORG.RU

Подключение 2х мониторов и 1 проектора

 , ,


0

1

Ребята, помогите разобраться.

Пытаюсь подключить к компу 2 одинаковых монитора DELL, каждый с разрешением UHD 3840x2160 и 1 проектоа JVC с тем же разрешением.

Система Arch Linux, полностью свежий. В системе установлены 2 видеокарты NVIDIA GTX 1070 Ti

Все мониторы и проектор включаю в 1ую видеокарту. Моники подключены к DP-1 и DP-2, а проектор к HDMI-1

При загрузке и включении иксов, после благополучного залогинивания в KDE Plasma экраны начинают мигать с периодичностью где-то раз 2 секунды. Т.е на мониках картинка появляется на пару секунд и пропадает, потом снова. Ощущение такое, что система перебирает возможные видеорежимы, но не может включить их.

Я пользуясь этими паузами, все же добрался до настроек экранов и вижу, что проектор там, то появляется, то исчезает, соответственно при всех этих моментах, система каждый раз перераспределяет рабочие столы. Отсюда и идет систематическое мигание. При этом все это время на проекторе изображение так и не появлялось.

Если выдернуть HDMI проектора, то все нормализуется и у меня просто 2 включенных моника.

Я пробовал проектор подрубить вообще во вторую видеокарту, но это не дало нужного эффекта.

Подскажите, что это может быть? И как решить проблему? Может видюха не тянет? Но я попробовал отключить один монитор и включить проектор в паре, но мигание не прекратилось.

Спасибо

Ответ на: комментарий от ITdreamer

Видюха тут ни при чем, попробовал на разных, все одинаково. Если просто только проектор подрубить, то на этапе текстового режима загрузки изображение есть, но как только идет переключение в видеорежим сигнал пропадает. Пробовал перейти по Ctl+Alt+F2 в текстовый режим, но изображение так и не появляется. Если подрубить в этот момент, один из моников или оба, то изображение появится на мониках. Но в текстовом режиме xrandr не сработает.

Попробовал подключить проектор, и один монитор. В этом случае все то же самое. Пока идет текстовая загрузка на проекторе есть изображение, на монике нет. Как только врубается видеорежим на монике изображение появляется, а на проекторе исчезает и no signal, при этом на монике изображение начинает с периодичностью мигать, как я описывал выше. В промежутках между меганиями удалось xrandr запустить. Вот что он написал.

Screen 0: minimum 8 x 8, current 7680 x 2160, maximum 32767 x 32767 DVI-D-0 disconnected (normal left inverted right x axis y axis) HDMI-0 connected 3840x2160+0+0 (normal left inverted right x axis y axis) 2107mm x 1185mm 3840x2160 60.00*+ 59.94 50.00 29.97 25.00 23.98
4096x2160 59.94 50.00 29.97 25.00 24.00 23.98
2048x1080 60.00 24.00
1920x1200 59.88
1920x1080 59.94 50.00 23.98 60.00 50.04
1680x1050 59.95
1600x1200 60.00
1600x900 60.00
1440x900 59.89
1280x1024 60.02
1280x800 59.81
1280x768 59.87
1280x720 59.94 50.00
1024x768 60.00
800x600 60.32
720x576 50.00
720x480 59.94
640x480 59.94
DP-0 connected primary 3840x2160+3840+0 (normal left inverted right x axis y axis) 609mm x 349mm 3840x2160 60.00*+ 29.98
2560x1440 59.95
2048x1280 59.96
2048x1080 24.00
1920x1200 59.88
1920x1080 60.00 60.00 59.94 50.00 23.98
1600x1200 60.00
1600x900 60.00
1280x1024 75.02 60.02
1280x720 59.94 50.00
1152x864 75.00
1024x768 75.03 60.00
800x600 75.00 60.32
720x576 50.00
720x480 59.94
640x480 75.00 59.94 59.93
DP-1 disconnected (normal left inverted right x axis y axis) DP-2 disconnected (normal left inverted right x axis y axis) DP-3 disconnected (normal left inverted right x axis y axis) DP-4 disconnected (normal left inverted right x axis y axis) DP-5 disconnected (normal left inverted right x axis y axis)

ITdreamer ()

Проблема может быть в плохом HDMI кабеле. По своему опыту, сталкиваясь с проблемами видео, в первую очередь меняю кабель, чтобы отсеять наиболее банальную причину.

Таким образом недавно «починил» артефакты в виде красных пикселей, а так же невозможность отображать 4к картинку при частоте более 30Гц (причем в некоторых случаях монитор моргал как в твоем случае).

Ради интереса попробуй вручную понизить частоту обновления/разрешение до минимума.

d1on1s ()
Последнее исправление: d1on1s (всего исправлений: 2)
Ответ на: комментарий от d1on1s

Проблема точно не в проводе

Решил для теста воткнуть старую задрипанную GTX 650.

Поставил, воткнул только проектор в HDMI и все запустилось.

Получается проблема в дровах или иксах?

Вот вывод xrandr

Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 16384 x 16384 VGA-0 disconnected (normal left inverted right x axis y axis) DVI-D-0 disconnected (normal left inverted right x axis y axis) HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 2107mm x 1185mm 3840x2160 60.00*+ 59.94 50.00 29.97 25.00 23.98
4096x2160 59.94 50.00 29.97 25.00 24.00 23.98
2048x1080 60.00 24.00
1920x1200 59.88
1920x1080 59.94 50.00 23.98 60.00 50.04
1680x1050 59.95
1600x1200 60.00
1600x900 60.00
1440x900 59.89
1280x1024 60.02
1280x800 59.81
1280x768 59.87
1280x720 59.94 50.00
1024x768 60.00
800x600 60.32
720x576 50.00
720x480 59.94
640x480 59.94
DVI-D-1 disconnected (normal left inverted right x axis y axis)

ITdreamer ()
Ответ на: комментарий от ITdreamer

В общем проблема была в герцах на проекторе.

При 3840x2160 24-25Гц все работает норм. А именно: 1ый монитор 3840x2160 60Гц + 2ой монитор 3840x2160 60Гц + Проектор 3840x2160 24-25Гц все норм.

Но стоит у проектора поднять герцы выше 25ти, скажем 30 и начинаются вот эти мигания.

Может видюха не тянет?

Потому что, если, к примеру воткнуть проектор в старую видеокарту GTX 650, то он прекрасно работает при 4096x2016 на 60Гц, и тем более на 3840x2160.

Видюха щас напоминаю GTX 1070 Ti

ITdreamer ()
Ответ на: комментарий от ITdreamer

И еще кое-что обратил внимание.

Почему-то второй монитор где-то раз в минуту выключается, но не в смысле питание отрубается, а просто изображение на мгновение гаснет и потом появляется.

Что это может быть?

ITdreamer ()