LINUX.ORG.RU

Интелловская звуковуха на ноуте под Gentoo определяется, но звук не работает

 ,


0

2
 aplay -l 

говорит:

card 0: MID [HDA Intel MID], device 0: 92HD81B1X5 Analog [92HD81B1X5 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Альсамикшер штатно работает. При попытке спикертеста:
speaker-test -c2

speaker-test 1.2.3

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.2.3.2-r1/work/alsa-lib-1.2.3.2/src/confmisc.c:767:(parse_card) cannot find card '2'
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.2.3.2-r1/work/alsa-lib-1.2.3.2/src/conf.c:4743:(_snd_config_evaluate) function snd_func_card_driver returned error: Нет такого файла или каталога
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.2.3.2-r1/work/alsa-lib-1.2.3.2/src/confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.2.3.2-r1/work/alsa-lib-1.2.3.2/src/conf.c:4743:(_snd_config_evaluate) function snd_func_concat returned error: Нет такого файла или каталога
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.2.3.2-r1/work/alsa-lib-1.2.3.2/src/confmisc.c:1246:(snd_func_refer) error evaluating name
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.2.3.2-r1/work/alsa-lib-1.2.3.2/src/conf.c:4743:(_snd_config_evaluate) function snd_func_refer returned error: Нет такого файла или каталога
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.2.3.2-r1/work/alsa-lib-1.2.3.2/src/conf.c:5231:(snd_config_expand) Evaluate error: Нет такого файла или каталога
ALSA lib /var/tmp/portage/media-libs/alsa-lib-1.2.3.2-r1/work/alsa-lib-1.2.3.2/src/pcm/pcm.c:2660:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,Нет такого файла или каталога
Почему оно вторую карточку ищет, ей же нулевая нужна?

★★★★★

Ответ на: комментарий от Pinkbyte
$ dmesg | grep audio
[    5.537908] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    5.575355] snd_hda_codec_idt hdaudioC0D0: autoconfig for 92HD81B1X5: line_outs=1 (0xd/0x0/0x0/0x0/0x0) type:speaker
[    5.575357] snd_hda_codec_idt hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.575358] snd_hda_codec_idt hdaudioC0D0:    hp_outs=1 (0xb/0x0/0x0/0x0/0x0)
[    5.575359] snd_hda_codec_idt hdaudioC0D0:    mono: mono_out=0x0
[    5.575360] snd_hda_codec_idt hdaudioC0D0:    inputs:
[    5.575362] snd_hda_codec_idt hdaudioC0D0:      Internal Mic=0x11
[    5.575363] snd_hda_codec_idt hdaudioC0D0:      Mic=0xa
$ dmesg | grep sound
[    5.616701] input: HDA Intel MID Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
[    5.616815] input: HDA Intel MID Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input15
burato ★★★★★ ()

В конце пишет: неизвестный PCM по умолчанию, попробуй пересобрать media-libs/alsa-lib. Мой вывод, для примера, такой, это уже с доработкой по лоопбаку:

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Loopback [Loopback], device 0: Loopback PCM [Loopback PCM]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 1: Loopback [Loopback], device 1: Loopback PCM [Loopback PCM]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7600000 irq 35
 1 [Loopback       ]: Loopback - Loopback
                      Loopback 1

spawn_sp ★★ ()
Ответ на: комментарий от burato

Сделай:

speaker-test -c 2 -D hw:0,0
должно звучать, насчёт микшера молчу, вкурсе что может быть убавлено в ноль? Если звук в этом тесте будет то пропиши устройство как дефолтное в ~/.asoundrc:
defaults.pcm.!card 0
defaults.pcm.!device 0
или /etc/asound.conf:
pcm.!default {
    type hw
    card 0
}

ctl.!default {
    type hw
    card 0
}

spawn_sp ★★ ()
Ответ на: комментарий от burato

Пропиши его как деф устройство, можешь ещё device 0 добавить(уточнить так сказать), где то писали что звукашки могут индексы менять от загрузки к загрузке, можно ещё примерно так: options snd-card index=0 в /etc/modprobe.d/alsa-snd.conf

spawn_sp ★★ ()
Ответ на: комментарий от spawn_sp

При сборке вообще не нужны модули.
Они нужны там, где нужна универсальность на разном железе.

Если ты зачем-то что-то подключаешь модулями, значит делаешь не так или не знаешь своего железа.

shleemypants ()
Ответ на: комментарий от burato

Там не стараться, а любые комбинации =m убрать или вообще module enable меню выключить. Как я и делаю при сборке ядра. Ядро должно быть монолитным, независимым, с поддержкой того, что нужно (шифрование, ФС, железо, Firmware - обязательно!).

shleemypants ()
Ответ на: комментарий от shleemypants

Согласен, конечно подумал об универсальности когда писал, да и не советовал модулями, вроде там было с ними у ТС, для своего железа можно и монолит, оно и безопасней.

spawn_sp ★★ ()
Ответ на: комментарий от shleemypants

Нет, я так не думаю, нет у меня фирмвари.

burato ★★★★★ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей