LINUX.ORG.RU

Не работает звук


0

0

У меня проблема никак не могу настроить звук на Debian, выдает такую ошибку когда пытаюсь вопроизвести mp3 через mpg123:

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3513:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:3985:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default
[jack.c:201] error: Failed to open jack client: 0x1
[module.c:110] error: Failed to open module ▒▒▒▒▒9▒▒▒▒▒▒▒▒0▒▒▒▒▒8▒▒: file not found
[audio.c:179] error: Unable to find a working output module in this list: alsa,oss,esd,jack,pulse,nas,arts
[audio.c:463] error: Failed to open audio output module
[mpg123.c:757] error: Failed to initialize output, goodbye.

Не подскажите что делать? Я уже голову сломал чего ему еще надо...

Ответ на: Re: Не работает звук от Serpico

Не работает звук

Никак, есть еще варианты?

Что никак? Эти команды должны были выдать полезную информацию, которую ты должен был запостить здесь.

Выполни эти команды:

lspci -nn >lspci.result
lsmod >lsmod.result
cat /proc/asound/cards >cards.result
dmesg >dmesg.result
и выложи куда-нибудь файлы *.result. Убеительная просьба: не выкладывай на говнохостинг, где придётся закрыть 100500 порнобаннеров и ввести нечитабельную капчу.

Ещё сообщи что выдают такие команды:

uname -a
cat /proc/asound/version

И самое главное: какая версия дистрибутива?

Deleted ()
Ответ на: Не работает звук от Deleted

Не работает звук

Вот здесь результаты:

uname -a выдало:

Linux homeserver 2.6.26-2-486 #1 Wed Nov 4 20:19:07 UTC 2009 i586 GNU/Linux

cat /proc/asound/version выдало:

Advanced Linux Sound Architecture Driver Version 1.0.16.

карту обнаружил вроде такую:

00:0f.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 12)

Serpico ()
Ответ на: Не работает звук от Serpico

Не работает звук

Кусок dmesg

[   50.209481] firmware: requesting ess/maestro3_assp_kernel.fw
[   50.383648] Maestro3: probe of 0000:00:0f.0 failed with error -2

Похоже для драйвера этой звуковой карты нужна прошивка, которая у тебя не установлена. Вот тут есть информация где взять прошивку: http://wiki.debian.org/snd-maestro3.

P.S. Неужели в дебиане не готового пакетика с прошивками?..

Deleted ()
Ответ на: Не работает звук от Deleted

Re: Не работает звук

Так понятно, саму PCI карту он видит но вот драйвера отказывается узнавать для ESS Technology ES1988 Allegro-1, где бы найти не подскажите? Как наденые звуковые карты он пишит мне --no soundcards-- так что нужно драйвера искать.

Serpico ()
Ответ на: Re: Не работает звук от Serpico

Не работает звук

Драйвер есть и он работает (snd-maestro3). Он просто не может инициализировать звуковую карту, т.к. для этого в неё нужно загрузить прошивку. А прошивки то и нету. Ссылку на инструкцию по установке прошивки я уже дал: http://wiki.debian.org/snd-maestro3

Deleted ()
Ответ на: Re: Не работает звук от Serpico

Не работает звук

dmesg

[ 6529.783777] PCI: Found IRQ 10 for device 0000:00:0f.0
[ 6529.783915] firmware: requesting ess/maestro3_assp_kernel.fw
[ 6529.883833] firmware: requesting ess/maestro3_assp_minisrc.fw
[ 6530.857770] ac97 serial bus busy
[ 6531.821817] ac97 serial bus busy
[ 6532.897870] ac97 serial bus busy
...
[ 6536.420219] ac97 serial bus busy
[ 6536.424191] ac97 serial bus busy
[ 6536.428165] ac97 serial bus busy
[ 6536.432636] AC'97 0 does not respond - RESET
[ 6536.436623] ac97 serial bus busy
[ 6536.440608] ac97 serial bus busy
[ 6536.440666] AC'97 0 access is not valid [0xffffffff], removing mixer.
[ 6536.440986] Maestro3: probe of 0000:00:0f.0 failed with error -5

А карточка точно исправна? Если да, то это похоже баг в драйвере и надо сообщать разработчикам.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.