LINUX.ORG.RU

Горизонтальные полосы

 


0

1
OS: Arch Linux 
Kernel: x86_64 Linux 5.0.0-arch1-1-ARCH
DE: GNOME 
WM: GNOME Shell
CPU: Intel Core i5-4430 @ 4x 3.2GHz
GPU: GeForce GTX 550 Ti [Gainward]
Nvidia Driver Version: 390.116

Наблюдаются каждые ~4px горизонтальные полосы
Фото: https://yadi.sk/i/qrGXU5GHjcEvng
Монитор подключен через DVI в видеокарту. Под Windows такого не наблюдается. Можно ли как-то исправить, или придется жить с этим? :D

Ответ на: комментарий от darkenshvein

Под Ubuntu также, но только некоторые полосы имеют другое расстояние (или мне кажется)

Ponywka ()

Ты смотри как зашёл и не придраться.

В настройках блоба есть масштабирование изображения. Выкрути всё на оригинальный размер или как там..

Deleted ()

У меня тоже есть 550Ti и гном, всё вместе с 2013 года отлично работает (не тормозит, не полосит, не микрифризит и анимация плавная) вот так /etc/X11/xorg.conf.d/11-nvidia.conf (DFP-1 это HDMI)

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GTX 550 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth   24
    Option      "ConnectedMonitor" "DFP-1"
    Option      "metamodes" "1920x1080_60 +0+0; nvidia-auto-select +0+0"
    Option      "TripleBuffer" "1"
    Option      "RenderAccel" "1"
    Option      "AllowGLXWithComposite" "1"
    Option      "nvidiaXineramaInfo" "0"
    Option      "UseEdid" "1"
    Option      "AddARGBGLXVisuals" "1"
    Option      "DisableGLXRootClipping" "0"
    Option      "DamageEvents" "1"
    Option      "ConnectToAcpid" "0"
    Option      "MultisampleCompatibility" "1"
    SubSection  "Display"
        Depth       24
    EndSubSection
EndSection

bass ★★★★★ ()
Ответ на: комментарий от darkenshvein
01:00.0 VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTX 550 Ti] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: CardExpert Technology GF116 [GeForce GTX 550 Ti]
	Flags: bus master, fast devsel, latency 0, IRQ 33
	Memory at f4000000 (32-bit, non-prefetchable) [size=32M]
	Memory at e0000000 (64-bit, prefetchable) [size=128M]
	Memory at e8000000 (64-bit, prefetchable) [size=64M]
	I/O ports at e000 [size=128]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: nvidia
	Kernel modules: nouveau, nvidia_drm, nvidia

01:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)
	Subsystem: CardExpert Technology GF116 High Definition Audio Controller
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at f6080000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
Ponywka ()

Можно ли как-то исправить

Купить AMD, использовать GNOME on Wayland. Серьёзно, Nvidia особо не чешется с поддержкой современного графического стека на Linux.

commagray ★★★★★ ()
Ответ на: комментарий от bass

Потому что тупой студент
Применил конфиг не отредактировав и пропало изображение. Через другой терминал (CTRL+ALT+F2) отредачил конфиг и установил VGA1 (посмотрел с телефона). Сейчас полезу в Google за настройкой для DVI

Ponywka ()
Ответ на: комментарий от Ponywka

потому что нужно прочитать справку по каждой опции конфига и выставить как нужно тебе. хотя тебя конкретно интересует:
«ConnectedMonitor» - можешь удалить, сам найдет.
«metamodes» - а вот тут решение твоей проблемы и находится. нужно правильно выставить разрешение/частоту монитора
«UseEdid» монитор может отдавать несовместимые значения, можно попробовать выключить
Всё остальное это вкусовщина заставляющая карточку работать в гноме идеально как можно

можешь забить на конфиг и играть с разрешение/частота в xrandr

bass ★★★★★ ()
Последнее исправление: bass (всего исправлений: 1)
Ответ на: комментарий от bass

Как бы я не тыкал, выводит теперь изображение только на квадратный моник подключенный к VGA, в Gnome же работают 2 монитора, но оба полосят

Ponywka ()

Dimez

Ты ваще шоле? Нафига скриншот удалил, когда он одинаковый для всех платформ и именно неправильные настройки вызывают искажения изображения, на больших панелях так точно 100%, да и на мелких тоже. Именно что выкручивал для моника в 24"

Ку-ку! 🤢 перемахал немножко молотком.

Deleted ()
Последнее исправление: RTP (всего исправлений: 3)

А точно не хардварная проблема? Для чистоты эксперимента хорошо бы полностью залить экран этим же цветом, проделать аналогичное на винде, сравнить. Не исключено, что одна часть изображения может влиять на другую.

И да, судя по фоточке с виндой, матрица скорее всего 6-битная. Возможно, это всё приколы дизеринга.

Slavik763 ()
Ответ на: комментарий от Slavik763

А точно не хардварная проблема?

Вроде нет. Завтра после теха чекну

Ponywka ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.