LINUX.ORG.RU

AMD vs Nvidia для Linux

 ,


0

1

Уже давно на десктопе стоит gtx560. Пора бы поменять её на что-то поновее но не хочется отдавать за это больше 20к. По всем тестам 1060 делает и rx560 и rx570. Но так как большую часть времени я все-таки не играю, хотел поинтересоваться как поддержкой AMD вообще сейчас дела. Например на Nvidia в Chrome аппаратное ускорение надо включать через flags и то оно коряво работает. Как с этим на видеокартах AMD. Fedora 28 Gnome вообще у меня выдает черный экран после входа в систему при установке проприетарных драйверов, да я знаю что Nvidia кинула старые карты, ставил 390 драйвер, в Ubuntu Gnome работает в Fedora нет. Ну и вообще у кого есть опыт работы с современными картами что лучше для работы и нетребовательного гейминга?


Ответ на: комментарий от anonymous

И много таких серверов? Большинство серверов все-таки занимаются хранением и обработкой данных, а не вычислениями на GPU. Это не оправдание большого болта от нвиди на линукс.

AleksK ()
Ответ на: комментарий от AleksK

ну на карте за 20К вышеперечисленное должно летать. хотя я за последними сериями в сериалах не слежу, так что смотря какой деусэкс, ведьмак и т.д.
просто надо помнить, что покупка видеокарты с целью поиграть это всегда в какой-то степени покупка воздуха. и чем дороже видеокарта тем больше процент газа. так устроен рынок игр. ведь карта успевает устаревать не то что пока ты ее донесешь до дома, а еще будучи не купленной на полке. ибо в любой момент времени есть какая-нибудь игра, которую эта карта не тянет. и с каждым моментом их все больше. так что это всегда компромисс и больше зависит от требований человека. если ты сейчас купишь карту за 20К то сможешь жить (играть) с ней ооочень долго. если конечно ты не хочешь всегда включать все возможные эффекты да еще в разрешении 100500на100500. в этом случае ты либо школьник/либо подросший школьник но уже на самообеспечении и занимаешься «сурьезным» строительством этих пылесборников под столом, со всеми полагающимися СЛИ, жикдостными охлаждениями и самыми крутыми ССД. И само собой самыми дорогими видяхами тыщ за 40 каждая.
А если это всё тебе дико то с картой за 20К можно отлично прожить лет 5-7.

mos ★★☆☆☆ ()
Ответ на: комментарий от AleksK

Лучше посиди пока на встройке, к осени цены на старые линейки могут упасть. А могут и не упасть, впрочем.

anonymous ()
Ответ на: комментарий от anonymous

Линуксовых десктопов по миру больше десятка миллионов, а серверов для вычислений на GPU по любому меньше.

AleksK ()
Ответ на: комментарий от AleksK

ну вот если присмотрел уже эти модели то и ищи их или максимально аналогичные во всяких тестах.

в общем случае, разница между невидией и амуде будет в том, что закрытые дрова невидии для линуксов не очень «родные» в плане обновления и прочей поддержки (тут всё еще от дистростроителей зависит), хотя реальных проблем нет - если ты только ядро обновлять не соберешься или там ксорг, последнее особенно вряд ли. зато с амуде и работает изкоропки и для той же убунты добрые люди собирают в ППА самые свежие версии и они работают беспроблемно в 99% случаев.

mos ★★☆☆☆ ()
Ответ на: комментарий от mos

они работают беспроблемно в 99% случаев

В целом беспроблемно, но часто медленно. Понятно, что это бывает по вине кривых игр, но что есть, то есть.

anonymous ()
Ответ на: комментарий от mos

Да к десктопной карте в плане драйверов у меня вопросов особых нет, если не экспериментировать она вроде работает, а вот оптимус это просто пиздец, костыль на костыле и работает похоже только при определенной фазе луны.

AleksK ()
Ответ на: комментарий от AleksK

за оптимусы не скажу, не беру такие ноуты. либо десктоп либо ноут со встройкой.
но да слышу что проблемы есть...

mos ★★☆☆☆ ()
Ответ на: комментарий от anonymous

но часто медленно

4.2 все-таки. проходим на пхороникс и смотрим разные тесты. разрывы в производительности неумолимо сокращаются, а то уже местами полностью исчезли.
и даже кривизна игр тут ни при чем. ну понятно что ферал через свой вроппер портиРУЕт с пенальти на перформанс, но и там дела более менее штабильно обстоят.

mos ★★☆☆☆ ()
Ответ на: комментарий от mos

проходим на пхороникс и смотрим разные тесты

Я в дотку не играю, что мне толку от их тестов.

4.2

Расскажи это моей видеокарте.

anonymous ()

Вот вопрос к знатокам nvida. Поставил тут себе недавно вышедший Mint 19. Поставил из ppa:graphics-drivers самый последний 390.67 все замечательно запустилось.

Теперь вопрос. Куда они засунули 32 битные либы? Без них стим не работает. Раньше был отдельный пакет. А теперь?

AleksK ()
Ответ на: комментарий от SR_team

Ведьмак под линукс в стиме есть только второй, купил я его как только он вышел, но после запуска показал мне слайд шоу, я что-то сомневаюсь что он сейчас будет лучше работать. DeusEX ещё меньше кадров показывал. В Bioshock в принципе играть можно но так себе.

Вот что теперь делать с последними дровами, я что-то читаю, пишут что 32 битные либы они выкинули. Как стим теперь запустить?

AleksK ()
Ответ на: комментарий от Thero

хм.. а у меня на радеонах нормально работают шейдеры..

я в том посте ДАЛ ССЫЛКУ на шейдер который крашит иксы на АМД
ты ее нажал? нет

есть шедертой целиком, 50% шейдеров на шадертое НЕ РАБОТАЮТ НА РАДЕОНЕ(любой версии с любыми дровами), 20% из них вешают дрова/иксы
ты заходил пролистывал шадертой? нет

но продолжаешь «слепо верить»
земля металом брат

и огл 4.5 там где про драйвер есть

ниодна игра со стима на ОГЛ4.5 на АМД так и не заработала, держи в курсе

missxu ()
Ответ на: комментарий от anonymous

на АМД amdgpu Vulkan работает.

расскажи это разрабам dxvk и xenia (у них там большая часть багов когда зависает и крашей на АМД)

верующие, шок конешно

missxu ()
Ответ на: комментарий от missxu

У меня сейчас вообще стим не включился. Держу в курсе. Где блин 32 битные либы?

AleksK ()

Годный тред, буду апгрейдиться с 460 на днях - тоже решаю во что.

Deleted ()
Ответ на: комментарий от SR_team

работают из коробки.

на 2-х 3-х летней месе(дефолтной после установки) ничего не работает
версия llvm не совместима с иксами/месой/ядром
версия месы не совместима с иксами
версия ядра не совместима с иксами
версии gcc нехватает для сборкых иксов/месы
обновив gcc обновятся clib**xxyy который конфликтуют со старым ядром (совместимость ABI дада кулстори)
пересобрав ядро потом месу и иксы
будешь жить до следущего обновления месы
и на каждое обновление месы(раз в неделю) будешь пересобирать «мир»

удачи и хорошего настроения, как говориться

missxu ()
Ответ на: комментарий от missxu

расскажи это разрабам dxvk

Я лично считаю, что проблема в DXVK, ибо DOOM 2016 всегда работал и работает хорошо.
Ну и да, amdgpu-pro не поддерживается.

SR_team ★★★★★ ()
Ответ на: комментарий от missxu

на 2-х 3-х летней месе(дефолтной после установки) ничего не работает

Дистрибутивозависимая проблема. У меня в арче ее нет, в Debian 9 тоже не было.

версия llvm не совместима с иксами/месой/ядром
версия месы не совместима с иксами
версия ядра не совместима с иксами
версии gcc нехватает для сборкых иксов/месы
обновив gcc обновятся clib**xxyy который конфликтуют со старым ядром (совместимость ABI дада кулстори)
пересобрав ядро потом месу и иксы

Не доводилось сталкиваться с таким

и на каждое обновление месы(раз в неделю) будешь пересобирать «мир»

Чет не пересобираю. Меса может обновляться отдельно от ядра/иксов/llvm и ничего не ломается.

SR_team ★★★★★ ()
Ответ на: комментарий от al-kasch

Свободный драйвер работает кое-как, fglrx выкидывает поддержку старых карт.

fglrx

Из какого ты вообще тысячелетия?

robus ★★★★ ()
Последнее исправление: robus (всего исправлений: 1)
Ответ на: комментарий от anonymous

И не для меня, и не для тебя. А чтобы распилить.

robus ★★★★ ()
Ответ на: комментарий от al-kasch

fglrx выкидывает поддержку старых карт.
fglrx

Сударь, ваша осведомленность просто поражает вображение!

templarrr ★★★★★ ()
Ответ на: комментарий от al-kasch

В райзене нет встроенной графики.

Сударь, ваша осведомленность просто поражает воображение![2]

templarrr ★★★★★ ()

Пока на видеокарты еще нормальные цены бери какую-нибудь RX580. Там тебе и нормальная поддержка линуксового графического стека, и хорошая производительность в играх под игровой ОС. А игры на онтопике - это индюшатина, AAA в любом случае через прослойки, жрущие производительность. И если тебе будут давать результаты тестов, в которых все в этих прослойках хорошо, но нет замеров средних значений 1% и 0.1% максимального времени кадра (обычно дают обратную величину и называют 1% FPS и 0.1% FPS) - не верь. Даже минимальный FPS, не то что средний, еще не является показателем хорошей игровой производительности.

templarrr ★★★★★ ()

Вот о чем я и говорил добавил ppa с последней доступной для моей карты версией драйвера 390.67, он прекрасно заработал, только к нему забыли положить 32-битные либы, и стим просто не запустился без них. Пришлось убрать ppa и откатится до 390.48, а с ним 32-битные либы поставились сами.

Вот вам пример косяков с драйверами Nvidia.

AleksK ()
Ответ на: комментарий от AleksK

про исправление ошибок и оптимизацию речи вообще не идет

OpenGL на NVIDIA под Linux, быстрее, чем под Windows.

На оптимус для линукс, они как положили болт так и кладут его постоянно

Нет. Они его сделали лучше, чем на Windows и довольно давно. На Linux утилиткой nvidia-xrun (просто скрипт и набор xorg конфигов) можно поднять конфигурацию аналогичную оптимусовской хоть на десктопе.

Сейчас у NVIDIA в моде не работающий Wayland, древнющее разрешение в tty, убогий велосипед-рендер-шрифтов, не компилящиеся некоторые GLSL шейдеры (привет, NextGenCompiler!) в Core Profile, отсутствие утилит разработчика (Debug HUD, вменяемые OpenGL debug messages, профайлеры, валидаторы — зачем? Вот вам монструозный монолитный комбайн на базе эклипс и отстаньте).

robus ★★★★ ()

Fedora 28 Gnome вообще у меня выдает черный экран после входа в систему при установке проприетарных драйверов

У меня на GT730 и GTX960 в 26-28 Fedora всё работает хорошо.

Юзал https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/ для установки.

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от AleksK

Убунтомантейнеры как обычно нахеровертили с пакетами, а виновата невидия. Типичный лоровский аналитег.

Deleted ()
Ответ на: комментарий от anonymous

Я не знаю, почему в убунте для установки драйверов приходится подключать ppa. Или не приходится, и наш аналитег и тут отличился?

Deleted ()
Ответ на: комментарий от Deleted

Ну для новейших версий в LTS приходится, хотя их там и так вроде обновляют, просто не сразу.

anonymous ()
Ответ на: комментарий от missxu

там не с шейдерами проблема а с вебгл( зависаний я полистав так и не нашёл, но иногда вебгл просто не стартует увы ни гугл ни мозила пока не ставят приоритетом чинить вебгл под линуксом, вполне верю что у нвидии в этом плане нечему ломаться потому что блоб уверенно игнорит линуксовый графический стек), и да это конечно тоже проблема, но сама карточка шейдеры рисует нормально( если они конечно стандарт не нарушают) но я конечно ещё потыкаю может найду где иксы фризятся, возможно на старой версии браузера\иксов, на другой машине ещё гляну.. а то я прям сначала испугался что шейдеры умудрились сломать за пол года.

у меня парадоксовые игры требующие огл 4.5 работали на месе даже когда там 4.5 ещё не целиком был готов(с оверрайдом что конечно подсказывает что им не все фичи от огл 4.5 нужны), и это на весьма старой r600 карточке.. но там уже вроде даже драйвер с полной поддержкой релизнулся, а не экспериментальный.. если подскажешь игру которая жмёт огл 4.5 по максимуму будет интересно посмотреть.

Thero ★★★★★ ()
Ответ на: комментарий от AleksK

GTX 1060 с 3Gb брать не надо, она не перспективная. Вот 6 Gb - это тема. Насчет карточек AMD не подскажу. А так есть Debian 9 с Gnome 3 и GTX 1060 6Gb, что именно интересует?

th3_smart ()
Ответ на: комментарий от missxu

(или фризят систему) https://www.shadertoy.com/view/XstBzM

Подтверждаю, проверил на mesa 17.3.9 (LLVM 5.0.1), POLARIS10.

про OpenGl4.5 даже писать не стоит

Я прошел Alien Isolation (ogl 4.3), играл Dirt Rally, Observer и Cities:Skylines. Все работало, других игр у меня просто не было.

WebGL декмки смотрел, твоя линка это первый кейс когда я такое увидел. Кажись называется такое gpu lockup, это компилятор шейдеров полученными инструкциями ввел gpu в неконсистент состояние, такое обычно фиксят в llvm, обычно все очень оперативно фиксят, тем более бага так легко воспроизводится.

anonymous ()
Ответ на: комментарий от SR_team

карточки красных работают из коробки.

А ещё у них из коробки напильник, паяльник и водянка сразу идут.

devl547 ★★★★★ ()
Ответ на: комментарий от robus

Вроде только недавно. В X-Server 1.20. Который не успел войти в Fedora 28. Что касается OpenGL, то на первой странице я давал ссылку на Phoronix. FPS одинаковый. Насчёт высоких разрешений во фреймбуферной консоли - их можно получить при помощи uvesafb. Не работает uvesafb А ещё на «дискретке» можно «поднять» KMS, вот так:

sudo rmmod nvidia-drm; sudo modprobe nvidia-drm modeset=1

Или прописать это в автозагрузку, как в этой статье. Но я не знаю, влияет ли это на виртуальный терминал так же хорошо, как на nouveau! Возможно что не влияет.

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 5)
Ответ на: комментарий от Thero

Шейдер не может «нарушать стандарты»

во первых в шейдерах «не может быть утечек памяти» и конфликтов из за этого(каждый шейдер в своей памяти крутится и это основная Фича GLSL(не однократно сами разрабы АМД и Нвидии говорили на конференциях) что об этом не нужно думать при кодописании, компилятор и драйвер все сами сделают)

во вторых если шейдер компилится то он работает, тоже самое с OpenGL кодом, это забота драйвера слать ошибки и прекращать прием команд после ошибки, а не «юзерспейс процеса» что очевидно и банально
(тоже самое что объявить виновником «зависаний браузера на сайтах» не разрабов веббраузера и javascript кодеров)

и учитывая что код компилятора vulkan GLSL шейдеров идентичен OpenGL то там этиже самые шейдеры будут давать этиже самые баги, поэтмоу Вулкан на АМД не работает (примеры я привел dxvk и xenia которые компилят тонну шейдеров)
(также могу напомнить про страдания разработчика Cemu когда у него весь графен на OpenGL4.5 шейдерах который несмотря на все сотни сделаных подпорок для АМД, всеравно багают и сегодня)

и да на Нвидии на линуксе Все шейдеры на шадертое работают(кроме тех где синтаксис с webgl1.0 не обновился, их там пара штук)

missxu ()
Ответ на: комментарий от anonymous

«это» можно запустить на OpenGL2.0, вулкан там рисует геометрию и печатает текстурки, уж это смогли реализовать в АМД драйверах, но когда речь идет о возможностях OpenGL3.0 до 4.5 и Вулкане- АМД не может в них

еще раз повторяю качает dxvk либо xenia либо cemu и пытаешься запустить одну из последних ААА игр через них(спойлер-помимо очевидного зависания иксов почти сразу,у тебя может закончиться место на жестком диске при компиляции шейдеров в этих программах на АМД, ибо все криво что даже кэш течет)
когда на нвидии все работает

missxu ()
Ответ на: комментарий от missxu

Примеры ААА игр в Linux привести забыл?

anonymous ()
Ответ на: комментарий от missxu

Dxvk Radv mesa 18.2 llvm 6.0 dark souls remastered, 2 scholar, ff xii zodiac age - все работает. Не работает как раз на нвидии много что, так как у разработчика dxvk нет рычагов что-то добавить в невидеский драйвер, а в радв все его желания и фиксы добавляют.

abbcto ()
Ответ на: комментарий от ZenitharChampion

Вроде только недавно. В X-Server 1.20. Который не успел войти в Fedora 28.

Ох уж эта стагнация в Fedora. Но nvidia-xrun работал и с более древними xorg. А в убунте вроде бы был «NVIDIA PRIME».

fps одинаковый

По ссылке отставание десятки за пределами погрешности в каждом отдельном тесте. Лишь пара игр идет быстрее/также на 10. В конце статьи автор говорит о баге драйвера NVIDIA на Win10.

А ещё на «дискретке» можно «поднять» KMS

Спс. Утащил в свой gpu-detect.sh

robus ★★★★ ()
Ответ на: комментарий от missxu

это основная Фича GLSL

А я то дундук думал, что основная фича glsl, это куча встроенных функций, которые выполняются оптимально (в теории) на карте, для которой шейдер скомпилирован, поддержка модулей (почти как в C), компилятор шейдеров, встроенный прямо в драйвер компилятор шейдеров, позволяющий приложению генерировать glsl в рантайме.

А оно вон как оказалось. Их основная фича — отутствие malloc/free.

robus ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.