LINUX.ORG.RU

Radeon hd2400 vs backlight

 , ,


0

1

Решил установить linux для домашнего пользования, выбор пал на debian 8 с xfce, все завелось и работает отлично, но столкнулся с одной проблемой, копал и так и сяк, но побороть не смог, надеюсь на вашу помощь, друзья.

Имеется ноутбук asus m51sr с видеокартой radeon hd2400. Fn клавиши на нем адекватно регулируют подсветку экрана в состоянии, когда не загружена никакая ось, визуально яркость в пределах от 20% до 100%. Так-же они адекватно работают из под вин (xp/win7/win10).

Но запуске на ноутбуке debian (и ubuntu), эти клавиши регулируют подсветку в пределах видимости 0%-80%, при этом на средних значениях происходит мерцание. Регулировка посредством модуля на панели дает точно такой же результат. Запись значений в файлы /sys/class/backlight/acpi_video0 (/radeon_bl0)/brightness тоже косячно изменяют подсветку. Изменение параметра загрузки acpi_backlight=native (video/vendor/none) не дает никаких результатов.

Примечательно, что если загрузиться с чистого debian без установки драйвера, то подсветка работает как надо и с клавиш и с панели, но изображение вырвиглазное и никак не располагает к работе.

Подскажите пожалуйста, как можно побороть драйвер, или на крайний случай вообще отключить регулировку подсветки посредством драйвера, чтобы получился вариант как при чистой установке, но с поддержкой видеокарты.

Сейчас на ноуте Debian 8.5 (jessie), ядро 3.16.0-4-686-pae Пакеты: firmware-linux-nonfree, xserver-xorg-video-radeon, xserver-xorg-video-ati

Пс: сильно не пинайте, мой первый пост

как вариант - попробовать acpi_osi=linux или acpi_osi= (да-да, пусто без ничего). может помочь.

NiTr0 ★★★★★ ()
Ответ на: комментарий от NiTr0

acpi_osi=linux или acpi_osi=

NiTr0, спасибо за участие.

Отсюда я выделил несколько параметров, которые напрямую, или косвенно затрагивают подсветку:

acpi=           [HW,ACPI,X86]
				Advanced Configuration and Power Interface
				Format: { force | off | strict | noirq | rsdt }
				force -- enable ACPI if default was off
				off -- disable ACPI if default was on
				noirq -- do not use ACPI for IRQ routing
				strict -- Be less tolerant of platforms that are not
						strictly ACPI specification compliant.
				rsdt -- prefer RSDT over (default) XSDT
				copy_dsdt -- copy DSDT to memory

				See also Documentation/power/runtime_pm.txt, pci=noacpi

acpi_backlight= [HW,ACPI]
                        acpi_backlight=vendor
                        acpi_backlight=video
                        If set to vendor, prefer vendor specific driver
                        (e.g. thinkpad_acpi, sony_acpi, etc.) instead
                        of the ACPI video.ko driver.

acpi_os_name=   [HW,ACPI] Tell ACPI BIOS the name of the OS
				Format: To spoof as Windows 98: ="Microsoft Windows"

acpi_osi=       [HW,ACPI] Modify list of supported OS interface strings
				acpi_osi="string1"      # add string1
				acpi_osi="!string2"     # remove string2
				acpi_osi=!*             # remove all strings
				acpi_osi=!              # disable all built-in OS vendor
										  strings
				acpi_osi=               # disable all strings

video.brightness_switch_enabled= [0,1]
                        If set to 1, on receiving an ACPI notify event
                        generated by hotkey, video driver will adjust brightness
                        level and then send out the event to user space through
                        the allocated input device; If set to 0, video driver
                        will only send out the event without touching backlight
                        brightness level.
                        default: 1

Комбинируя значения переменных, получал разные результаты: отключались клавиши подсветки, отключалось управление с панели, индикация яркости. Но к сожалению, в любом из случаев linux как не хочет отпускать подсветку в свободное плавание, так и не хочет адекватно ей управлять.

Перехватывает управление он, как мне кажется, где-то на этом месте:

[    1.469275] ATOM BIOS: F3Sr
[    1.469407] radeon 0000:01:00.0: VRAM: 128M 0x0000000000000000 - 0x0000000007FFFFFF (128M used)
[    1.469410] radeon 0000:01:00.0: GTT: 512M 0x0000000008000000 - 0x0000000027FFFFFF
[    1.469413] [drm] Detected VRAM RAM=128M, BAR=256M
[    1.469414] [drm] RAM width 64bits DDR
[    1.469479] [TTM] Zone  kernel: Available graphics memory: 428862 kiB
[    1.469481] [TTM] Zone highmem: Available graphics memory: 2072194 kiB
[    1.469483] [TTM] Initializing pool allocator
[    1.469490] [TTM] Initializing DMA pool allocator
[    1.469512] [drm] radeon: 128M of VRAM memory ready
[    1.469514] [drm] radeon: 512M of GTT memory ready.
[    1.469525] [drm] Loading RV610 Microcode
[    1.469548] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/RV610_pfp.bin
[    1.469578] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/RV610_me.bin
[    1.469593] radeon 0000:01:00.0: firmware: direct-loading firmware radeon/R600_rlc.bin
[    1.469597] [drm] Internal thermal controller without fan control
[    1.469644] [drm] radeon: power management initialized
[    1.469649] [drm] GART: num cpu pages 131072, num gpu pages 131072
[    1.472393] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[    1.472593] input: Video Bus as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:1a/LNXVIDEO:00/input/input4
[    1.476014] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
[    1.476730] radeon 0000:01:00.0: WB enabled
[    1.476734] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x0000000008000c00 and cpu addr 0xff60fc00
[    1.476737] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[    1.476738] [drm] Driver supports precise vblank timestamp query.
[    1.476741] radeon 0000:01:00.0: radeon: MSI limited to 32-bit
[    1.476763] radeon 0000:01:00.0: irq 47 for MSI/MSI-X
[    1.476776] radeon 0000:01:00.0: radeon: using MSI.
[    1.476804] [drm] radeon: irq initialized.

Но могу ошибаться, тк не силен в этом.

leowerd ()

Попробуйте отключить горячие клавиши регулировки яркости в XFCE. Точную настройку не подскажу, но подобная проблема была на моем ноутбуке с KDE. Суть была в том, что при нажатии на клавишу регулировки яркости реагировал и bios ноутбука, напрямую меняя яркость, и KDE, из-за чего появлялось неравномерное изменение уровня яркости и мерцание. Решилось сбросом горячих клавиш на команды управления яркостью в настройках KDE. Наверняка что-то подобное есть в XFCE.

UPD:

Вы можете переопределить назначение горячих клавиш или добавить новые через Меню → Все настройки → Клавиатура → Вкладка «Комбинации клавиш».

xmichael ()
Последнее исправление: xmichael (всего исправлений: 1)
Ответ на: комментарий от xmichael

Меню → Все настройки → Клавиатура → «Комбинации клавиш».

xmichael, спасибо за помощь. Там нет данных комбинаций, но я на всякий случай создал их и назначил на другие действия. Подсветка при этом все равно менялась.

Эти хоткеи биндятся немного в другом месте, но если их отключить там, то при нажатии на них ничего не происходит совсем, при этом все же можно изменить яркость через /sys/class/backlight/acpi_video0/brightness

К сожалению вариант отвязки клавиш не исправляет ситуацию.

leowerd ()

Проблема решена, всем спасибо за участие.

leowerd ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.