LINUX.ORG.RU

После установки debian 8 появились проблемы с яркостью

 ,


0

3

Добрый день всем,

переехал на 8ой дебин. Всё завелось замечательно и без каких-либо проблем, кроме яркости дисплея ноутбука.

Модель ноутбука lenovo z500 (intel graphics 4000), на всякий случай, вот что даёт lspci:

# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

Согласно рекомендациям в сети добавил опцию в конфиг GRUB'a:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

ну и переконфигурировал командой update-grub, однако это не помогло.

Драйвера обновлял, сейчас стоит такое:

# aptitude show xserver-xorg-video-intel
Пакет: xserver-xorg-video-intel                  
Состояние: установлен
Автоматически установлен: да
Версия: 2:2.21.15-2+b2

Смущает только, что поиск по mesa ничего не выдаёт:

# aptitude search ~i~mesa

нужно поставить mesa или есть какое-нибудь готовое решение, о котором я не знаю?

Файлики max_brightness и brightness говорят, что у меня всё на максимуме, одна дисплей явно не на полную яркость работает. При этом рядом стоит подключенный к этому ноуту монитор и там с яркостью всё замечательно, видно всё отлично. Сама яркость не регулируется: уменьшаю и ничего.

Кто сталкивался, прошу помочь =) заранее спасибо

А энвидия там у тебя не спряталась, которая Оптимус? Я такую проблему заметил, когда запускаюсь на лайфе какогонить линукса, из последних, то иксы стартуют и на интеле и на энвидии с модулем нуво, делают общий стол, половина которого спряталась на энвидии. Так вот, как я понял, управление яркостью тоже передаётся модулю нуво, что неправильно. Когда ставлю драйвер от энвидии и бамблби, всё становится на места.

Deleted ()
Ответ на: комментарий от Deleted

Да вроде когда ноут покупал, не было там нвидии. Спецом брал интегрированную видяху, а она интеловская.

тем не менее, в интернете много сообщений как раз по поводу оптимуса и бамблби, соответственно вопрос: как бы проверить, есть ли у меня еще и графика от нвидии или нет?

в lspci только один графический адаптер

mr_brightside ()
Ответ на: комментарий от Deleted

Проверил опытным путём.

Посмотрел, какие nvidia ставились на эти z500 (есть модели с интегрированной картой интел, есть с нвидиа), скачал себе драйвер, запустил и вуаля:

You do not appear to have an NVIDIA GPU supported by the 352.55 NVIDIA Linux graphics driver installed in this system.  For     
           further details, please see the appendix SUPPORTED NVIDIA GRAPHICS CHIPS in the README available on the Linux driver download   
           page at www.nvidia.com.
mr_brightside ()

Попробуй в конфиг груба поставить

acpi_backlight=video

Если не поможет, стоит перебрать другие. В ядрах 4 ветки используются эти параметры.

voltron ()
Ответ на: комментарий от voltron

Попробовал, что то не помогло =(

Попробую дальше по статье воспользоваться предлагаемыми библиотечками.

Мне кажется, что проблема явно с драйверами, потому что (сейчас заметил) если взять какое-нибудь окно и изменять его размер водя мышкой туда сюда - остаются ошметки этого окна (надеюсь, нормально объяснил). Если окно развернуть/свернуть, то эти ошметки стираются.

При этом разрешение меняется нормально, эффекты гнома вроде на месте (всякие плавные сворачивания, активные уголки и т.д.). На 7ом дебиане было так, что пока не воткнешь нормальные драйвера, никаких тебе эффектов.

mr_brightside ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.