LINUX.ORG.RU

А куда выпилили Radeon из Debian Jessie?

 , ,


0

1

Есть два мануала:

https://wiki.debian.org/ru/AtiHowTo
https://wiki.debian.org/ru/ATIProprietary

В первом предлагается установить пакет xserver-xorg-video-radeonhd, который есть только в squeeze и sid, во втором fglrx-driver и другие, которые есть только в squeeze, wheezy и sid.

А что делать счастливым юзерам Jessie?

Карточка:

> lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon HD 7500M/7600M Series] (rev ff)

★★

Status 09/2010: Linux distributions, including Novell's openSUSE, have now abandoned radeonhd as the default driver, instead using the radeon driver.

Zubok ★★★★★ ()
Ответ на: комментарий от SaBo

тогда ставь нормальный дистр вроде арча, в котором есть git версии месы и радеона

чего в твоем говнодебиане никогда не будет

но если хочешь сидеть на протухших дровах, то ..

smilessss ★★★★★ ()
Ответ на: комментарий от SaBo

В git последний комит в драйвер radeonhd был 4 года назад.

Zubok ★★★★★ ()
Ответ на: комментарий от smilessss

но если хочешь сидеть на протухших дровах, то ..

В Jessie вполне себе свежие. Последняя версия драйвера radeon 7.4. В Debian такая же. Jessie - это тестинг, а не stable. И, к тому же, тестинг не заморожен еще.

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)

fglrx убрали из-за x.org 1.16. Сам не нашел другого решения кроме как откатиться на stable + backports и ядро 3.12. Ждем пока amd разродится.

Archer73 ()
Ответ на: комментарий от smilessss

расскажи это мне, когда в арче на xf86-video-ati-git прилетают обновления каждые 4 дня.

Расскажу! Начнем! Какая у тебя версия?

Zubok ★★★★★ ()
Ответ на: комментарий от morse

Не - времени не было. Задача была купить ноут за 3 часа включая поездку в магазин и установку ОС.

SaBo ★★ ()
Ответ на: комментарий от Zubok

ты знаешь, что такое git версия пакета?
Туда изменения каждый день сыпятся.

Судя по https://packages.debian.org/jessie/xserver-xorg-video-radeon
в говнодебиане (1:7.4.0-2)

судя по https://www.archlinux.org/packages/extra/x86_64/xf86-video-ati/
в православном арче - 1:7.4.0-3 и дата сборки - Build Date: 2014-07-17 22:49 UTC
т.е. В дебиане еще древнее.
Идем дальше.

http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/log/ - последняя правка - 9 дней назад.
В дебиане же - бьльше 45 дней в лучшем случае.
Про версии месы я вообще молчу.

smilessss ★★★★★ ()
Ответ на: комментарий от smilessss

http://cgit.freedesktop.org/xorg/driver/xf86-video-ati/log/ - >последняя правка - 9 дней назад.
В дебиане же - бьльше 45 дней в лучшем случае.

Этим ты мне пыль в глаза не пустишь. Я git читать умею. С момента релиза там всего 16 коммитов. Практически все правки косметические. Там в сумме и 100 строчек не наберется.

Zubok ★★★★★ ()
Ответ на: комментарий от smilessss

забью на поиски

в любом случае я помню, что обновы летели часто, да и стабильная версия пакета в арче все равно выше.

smilessss ★★★★★ ()

Ну и где его убрали из jessie? https://packages.debian.org/search?keywords=radeon&searchon=names&sui...

В первом предлагается установить пакет xserver-xorg-video-radeonhd

с открытым исходным кодом — radeon и radeonhd для X11.

и собственно там далее до самого конца идёт настройка именно драйвера radeon, а не radeonhd.

daemonpnz ★★★★★ ()
Ответ на: комментарий от SaBo

В Debian Jessie xorg-server версии 1.16: https://packages.debian.org/source/jessie/xorg-server

Драйверы ati поддерживают xorg-server до версии 1.15.49 включительно. Вот поэтому и нет проприетарного драйвера от AMD в составе Debian Testing.

Вот когда в AMD обновят драйвер и добавят поддержку более нового xorg-server тогда и появится проприетарный драйвер в составе Debian Testing.

kostik87 ★★★★★ ()
Ответ на: комментарий от smilessss

Ты хоть сравнивать версии пакетов и думать умеешь? Или можешь только кричать о величии Arch`а?

Сам же написал:

в говнодебиане (1:7.4.0-2) в православном арче - 1:7.4.0-3

Отсюда вывод, что версии xf86-video-ati в Debian и Arch Linux одинаковые, только в debian сам пакет обновлялся два раза, т.е. на базе исходников xf86-video-ati-7.4.0 пакет был собран два раза, вероятнее всего накладывались какие-либо патчи или вносились прочие исправления, а в Arch Linux пакет на базе исходников xf86-video-ati-7.4.0 собирался 3 раза, т.е. в пакет вносились исправления 3 раза. В то же время версия драйвера, что в Debian Testing, что в Arch Linux одинакова.

Про версии месы я вообще молчу.

Чего молчать-то? В Debian mesa (10.2.6-1), а в Arch Linux mesa 10.2.7-3, и что из этого, различия в минорной версии.

kostik87 ★★★★★ ()

Да, а невидия сразу была готова к новому ксоргу, а вот у амудэ как всегда драйверопроблемы.

Единственное: тс, ставь открытый драйвер, он вполне годный на амудю.

Freyr69 ★★★ ()
Ответ на: комментарий от Freyr69

Ну, у Nvidia тоже не мало проблем, взять хотя бы поддержку ядер, почитайте прошлые темы, да новости посмотрите, просто не собирался модуль ядра nvidia с новыми ядрами, к тому же сторонние патчи появились через несколько дней.

Так что у всех могут быть проблемы.

kostik87 ★★★★★ ()
Ответ на: комментарий от smilessss

Через месяц пакетная база в Debian Jessie «заморозится» и новые версии программ в неё приниматься не будут. Arch - rolling-release дистрибутив, а Debian выпускается просто релизами. Так что сравнивать Debian Jessie и Arch Linux не будет ни какого смысла. А вот сравнивать Arch Linux с Debian Testing, именно Testing можно будет, точнее после того, как Debian Jessie стабилизируется.

Ну и ещё раз, сходи закопай уже топор святой войны, ну Arch Linux у тебя и что дальше?

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kostik87

ничего)

Я просто не понимаю людей, которые ставят открытый драйвер, который активно пилится на не ролинг дистр. А потом жалуются, что он не торт.

smilessss ★★★★★ ()
Ответ на: комментарий от smilessss

Ещё раз, у тебя в Arhc Linux драйвер версии 7.4.0, в Debian Jessie драйвер то же версии 7.4.0.

Кроме всего прочего в Debian можно смешивать ветки, это уж если ТС захочет уж действительно самую последнюю версию драйвера и её не будет в его релизе, то он сможет установить её из Debian Testing или Debian Sid, но в начале сможет просто подключить репозиторий Debian Backports, в котором будут пакеты с актуальными версиями драйверов именно для его релиза, он их получит даже без смешивания веток релизов. Ещё вопросы и недопонимания остались?

А потом жалуются, что он не торт.

Я не вижу, что бы здесь кто-то жаловался, есть только некоторое не понимание устройства дистрибутива, в частности правил появления пакетов и зависимостей программ в них.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

я помню момент, когда в ядре 3.11 врубили DPM и запилили vdpau и нужен был последний билд открытых драйверов и месы. Так вот местный умелец, делает свои сборки (gears of galium вроде ) не смог затестить все это дело ибо под дебиан, даже в тестинге просто не было пакетов нужных версий.

smilessss ★★★★★ ()
Ответ на: комментарий от smilessss

даже в тестинге просто не было пакетов нужных версий.

В Debian несколько больше веток, чем Stable и Testing, не говоря уже про OldStable. После Testing есть ещё Unstable (Sid) и Experimental. Вот в последних двух уж точно были пакеты с нужным функционалом.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от SaBo

aticonfig --initial выдал такой конфиг:

Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

Но X'ы отказались стартовать, с ошибкой «unable to query kernel module!(EE) fglrx(0): PreInit failed» «Screen(s) found, but none have a usable configuration.»

Полный лог

SaBo ★★ ()
Последнее исправление: SaBo (всего исправлений: 1)
Ответ на: комментарий от SaBo

хреново... значит, не поддерживается (в Debian такой бардак со списком поддерживаемого железа).

у меня hd6310, поддерживается и в jessie и в openbsd, безо всяких radeonhd, просто поставил и работает :)

odii ()
Ответ на: комментарий от SaBo

14.9 как-то очень незаметно 10 сентября вышел, даже без Release notes, но там где о нём упоминают, говорят, что с поддержкой xserver 1.16 и для готовящейся ubuntu 14.10

grem ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.