LINUX.ORG.RU

Странные дела

 , , , ,


0

2

Привет!

В продолжение темы. Была куплена Intel PRO 1000/Desktop adapter.

Но, оказалось, что причина, скорее всего, в повреждении материнки.

Мать вот такая.

А к мужикам у меня вопрос, как можно продиагностировать, что еще выгорело после молнии?

Система карту опознает, IRQ назначает, в БИОС карты заходит, НО карта пакетов не передаёт.

Хотелось бы слышать мнение бывалых железячников, куда копать, чтобы точно определить причину неисправности самостоятельно.

Под онтопиком ситуация аналогичная: драйвер e1000 загружен, карта ip не получает.

Короче, день сегодня неудачный :-(

★★★★★

По идее быть такого не должно. Если проблема с метиринкой то сетевая просто бы не работала (драйвер бы сигналезировал что сетвевой адаптер не отвечает на запросы).

Что говорит ethtool ?

Может проблема не в сетевой а в кабеле, или порт на свиче не работает ?

zaz ★★★★ ()
Ответ на: комментарий от zaz

или порт на свиче не работает

Сначала сам так думал, НО кабель заведомо рабочий.

Соединил «комп-комп», та же байда, крутит бублик, ждет ip :-(

Бред какой-то.

Twissel ★★★★★ ()
Ответ на: комментарий от Twissel

Сначала сам так думал, НО кабель заведомо рабочий. Соединил «комп-комп», та же байда, крутит бублик, ждет ip :-(

И кто ему IP даст ? Или вы подключились напрямую к DHCP серверу ? И ждать IP это не совсем корректноя диагностика в данном случае. Нужен tcpdump и спомтреть траффик на интерфейса (что шлется что приходит), смотреть через ethtool как реагирует порт на подключение / отключение провода в каком режиме поднимается линка и тд ... А так до получения IP там может быть 10000 проблем не связаных с вашим железом.

zaz ★★★★ ()

Просто некоторые железячники советуют выпаивать чип интеграшки, перед тем как ставить pci-ку.

Меня смущает, что интеграшка тоже сидела на PCI-express x1.

Глянуть бы где его разводку pci, как они уходят с южника.

Twissel ★★★★★ ()
Последнее исправление: Twissel (всего исправлений: 1)
Ответ на: комментарий от zaz

Или вы подключились напрямую к DHCP серверу?

Именно так.

Просто до всех неприятностей все работало «с полоборота».

Twissel ★★★★★ ()
Ответ на: комментарий от zaz

Запустил диагностику, которая идет вместе с драйвером под офтопик, результат таков, что карта «не видит» DHCP-сервера, а он есть и даёт ip моей целой сетевухе на ноуте, с которого пишу это.

Ясно, что проблема в железе, вот только где, хз :-(

Twissel ★★★★★ ()
Ответ на: комментарий от yars068

Нифига, уже пробовал.

Я же говорю, странные дела.

С двумя разными сетевухами.

Для этой матери Ethenet, видимо, все.

Twissel ★★★★★ ()

А в БИОС системной платы отключить встроенную сетевую нельзя?

Может это intel me сумятицу вносит?

greenman ★★★★★ ()
Ответ на: комментарий от Michail_Ul

Каким образом, если он целую новую сетевуху вставляет, которая всё это не использует?

anonymous ()

Под вендой проверь, возможно как обычно кривые дрова. Иначе слоты pci-e повреждены что только определяется но не работает (не совсем понимаю, как такое возможно, наверное вторичные питающие напряжения выгорели), или проблема в другом компе/роутере.

anonymous ()
Ответ на: комментарий от Twissel

А на последней миле хоть где-то, хоть какая-то гальваническая развязка есть? А то мало ли, где-то оптрон накрылся, или одна из обмоток развязывающего трансформатора сгорела, а ты мучаешься.

yars068 ★★★★ ()
Последнее исправление: yars068 (всего исправлений: 1)
Ответ на: комментарий от yars068

У меня Сеть ловить и раздаёт по dhcp вот такой девайс — http://www.ubnt.su/ubiquiti/powerbeam_m5-400.htm

Ноут адрес получает, стационарник нет. Соединение «комп-комп» тоже не работает.

Отсюда я делаю вывод, что очень оригинально что-то где-то подгорело.

Twissel ★★★★★ ()

CMOS сбрось. Иногда помогает.

И упсу купи с защитой (в том числе сети), спокойнее будет.

Deleted ()

Это у тебя странные дела? Купил нод32 лицензию на 1 месяц, а в программе нарисовано что лицензия закончится через 10 лет. Я ничего не ломал и пиратскими сайтами не пользовался. Купил в цифровом магазине.

YLoS ★★★ ()
Ответ на: комментарий от Twissel

Скриншот приложить?

http://storage2.static.itmages.ru/i/16/0903/h_1472902384_1610313_599cc8f8c3.png

Может быть я дурак и не там смотрю? На главной странице программы написано то же самое. Смотрел как у других в интернете: там максимум на год вперёд.

YLoS ★★★ ()
Последнее исправление: YLoS (всего исправлений: 1)

Чиста фантазийно — попробуй мак сменить на тот, что был у интегрированной.

greenman ★★★★★ ()
Ответ на: комментарий от Twissel

Ну, значит, как и сказали, мост гавкнул, или вторичные питающие напряжения. Они, кстати, часто на обычных линейных стабилизаторах, заменить - не проблема...

yars068 ★★★★ ()
Последнее исправление: yars068 (всего исправлений: 1)
Ответ на: комментарий от Twissel

Или я чего-то не понял?

Возможно. Я имею ввиду то, что UPS стоит взять с защитой для сети (то есть провод от провайдера ты вставляешь в UPS, а потом от него уже куда хочешь).

Deleted ()
Ответ на: комментарий от Deleted

Понял. После драки, как говорится... но все равно спасибо :-)

Twissel ★★★★★ ()
Ответ на: комментарий от yars068

А ты не думаешь, что мёртвая тушка RTL 8112, которая висит по сути на той же шине может создавать такую картину?

Twissel ★★★★★ ()
Ответ на: комментарий от yars068

Спасибо.

Но, уже поборол лень и нашел даже лучше картинку.

Twissel ★★★★★ ()
Последнее исправление: Twissel (всего исправлений: 1)
Ответ на: комментарий от Twissel

В твоей материнской плате южный мост - SoC. Сгорела часть моста, отвечающая за переферию. Остальные функции моста рабочие.

Michail_Ul ★★ ()
Ответ на: комментарий от Michail_Ul

Хорошо, я повторяю свой вопрос: почему USB рабочие, почему видяха PCI-Express рабочая?

Версия с дохлым чипом на шине мне кажется более правдоподобной.

Twissel ★★★★★ ()
Ответ на: комментарий от Michail_Ul

южный мост - SoC

Вот с этого места я тебя совсем не понял.

На сеть стоял отдельный чип Realtek RTL 8112, емнип. Он сгорел, но на шине остался, что не так?

Twissel ★★★★★ ()
Последнее исправление: Twissel (всего исправлений: 1)
Ответ на: комментарий от Twissel

Как мне кажется, все таки лучше проверить (заменить) кабель. Бывает так, что один и тот же кабель работает в одной сетевой, но не работает в другой. Так же можно попробовать воткнуть USB сетевушку - может заработает. Вариант с тем, что питание уходит в защиту из-за сгоревшей карты, конечно тоже имеет место, но странно, что видеокарта продолжает работать

r0ck3r ★★★★★ ()
Ответ на: комментарий от r0ck3r

Приветствую!

С другими ПК кабель рабочий, до этого работал 1,5 года.

Так что, я для себя остановился на варианте с дохлым чипом Рилтек, который портит мне жизнь.

Twissel ★★★★★ ()
Ответ на: комментарий от Twissel

Кстати, такой вариант, что тупо iptables не дает новой карте работать - возможен? Может на всякий его проверить?

r0ck3r ★★★★★ ()
Ответ на: комментарий от r0ck3r

По-моему, не этот случай. Дело в том, что на подключенном свиче диод загорается, горит 5 секунд, гаснет и так циклически. Т.е., похоже, что срабатывает защита таки.

Twissel ★★★★★ ()
Ответ на: комментарий от Twissel

Глянуть бы где его разводку pci, как они уходят с южника.

Ну и гугли схему на свою мать, мы ж не телепаты.

oknechsak ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.