LINUX.ORG.RU

Cubietruck + батарейка


0

2

Если подключить к плате акум и ас-адаптер одновременно, то при команде poweroff система не выключает плату, а тупо перезагружается. Без подключенного акума poweroff работает как надо. У меня одного так?

$ cat /etc/debian_version
7.2

$ uname -a
Linux tujad 3.4.61 #8 SMP PREEMPT Thu Jan 9 16:24:46 EET 2014 armv7l GNU/Linux

$ cat /sys/class/power_supply/battery/uevent
POWER_SUPPLY_NAME=battery
POWER_SUPPLY_MODEL_NAME=battery
POWER_SUPPLY_STATUS=Full
POWER_SUPPLY_PRESENT=1
POWER_SUPPLY_ONLINE=0
POWER_SUPPLY_HEALTH=Good
POWER_SUPPLY_TECHNOLOGY=Li-ion
POWER_SUPPLY_VOLTAGE_MAX_DESIGN=4200000
POWER_SUPPLY_VOLTAGE_MIN_DESIGN=3300
POWER_SUPPLY_VOLTAGE_NOW=4170000
POWER_SUPPLY_CURRENT_NOW=1000
POWER_SUPPLY_ENERGY_FULL_DESIGN=2100
POWER_SUPPLY_CAPACITY=100
POWER_SUPPLY_TEMP=300
★★★★★

Ответ на: комментарий от Deleted

а другие команды (halt, shutdown) тоже не отрабатывают?

К сожалению эффект одинаковый, во всех случаях перезагрузка :(

Кстати, если в /etc/default/halt прописать HALT=halt, то система не перезагружается и не выключается, а тупо останавливается после отработки скриптов init-а. В общем, эффект как при отключении Win95 «теперь ваш компьютер можно выключить» :) Это конечно не совсем, то что надо, но всеже лучше чем перезагрузка.

Если будет свободное время, попробую ядро поновее собрать - может поможет.

Rost ★★★★★ ()
Последнее исправление: Rost (всего исправлений: 3)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.