LINUX.ORG.RU

Broadcom 4313 и brcmsmac. Странное поведение

 , ,


0

1

Всем привет. Наблюдаю странное поведение своей карточки: после включения ноута не могу сразу подключиться к вайфаю (роутер ростелекомовский), хотя другие сети видит. А когда подключаюсь, то через некоторое время связь рвется и сеть больше нигде не наблюдается. Совсем. Помогает только перезагрузка. Приходится сидеть через соседей (d-link dir300). У них все нормально.

Стоит арч, ядро 3.12.6.

PS. На убунте такого не было

И есть что-то странное в dmesg после разрыва?

Medar ★★★★★ ()
Ответ на: комментарий от Medar

На ранних ядрах то же самое было. А насчет dmesg - надо немного подождать, пока wifi опять не отвалится

devnikor ()

шлюхоком - это, к сожалению, диагноз.
3 драйвера - и может так случиться, что для какой-нибудь модели ни один нормально не работает. пичаль, когда у тебя такая модель.

mos ★★☆☆☆ ()
Ответ на: комментарий от devnikor

я в итоге поменял сетевуху. на гораздо более простой атерос из старого ноута. с одной антенной вместо двух, только g и без блютуса вообще. зато работает.

mos ★★☆☆☆ ()

Была такая же проблема, решилась переходом на LTS ядро.

anonymous ()

Попробуй, вдруг поможет:

Зайди на 192.168.1.1 (или как там у тебя), найди настройки беспроводной сети, и там, где пункт «Канал», если стоит «авто» - то выбери определённое число 1 - 9. Мне помогало.

evilmanul ()

Хм, странно, сейчас, пока, все работает нормально, но на всякий случай сделал как сказал evilmanul. Посмотрим, что будет дальше.

devnikor ()

Вроде помогло. Спасибо всем за советы.

devnikor ()

было, исправил

Была такая же шляпа с 4313. Скачай драйвер broadcom-wl из AUR, bcma и brcmsmas, brcmfmac в блэклист и будет тебе счастье.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.